Question about 1997 Mercury Mountaineer

1 Answer

Dash lights are not working properly

Keep losing more and more dash lights. Hazel may have screwed it up by being tempermental.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 8 Answers

MINE WENT OUT TO, FIRST A FEW THEN MORE THEN ALL. I REMOVED THE CLUSTER AND PULLED OUT THE LIGHTS. USING A 12 VOLT BATTERY AND TWO WIRES I TESTED EACH ONE AND THEY WERE ALL GOOD BUT ONE. SO I WIGGLED AND PUSHED EACH ONE TO MAKE SURE THEY WERE IN THE SOCKETS ALL THE WAY, PUT THEM BACK IN AND REINSTALLED THE CLUSTER. NOW THEY WORK. I THINK THEY WIGGLE LOOSE AFTER TIME. I HAVE A 1999.

Posted on Feb 16, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why do dash lights go off & on (Not always same light)


look under the dash for a large connector that may not be clipped together called the C220 disconnect.
The instrment cluster also gets data and operating voltage and keep alive memory voltage from the smart junction box.The fuel cap may be bad losing vacuum and just coincidence.

Feb 23, 2015 | 2006 Ford Escape

1 Answer

I have a 1998 VW Beetle and Im trying to locate the alarm/buzzer that comes on with the oil light. I need to unhook it. ITS DRIVING ME CRAZY! HELP!!!


First thing, check your oil pressure. Even if you check the oil level, if the oil pump is going bad then the oil pressure isn't high enough to keep the engine lubricated- that's probably why you hear the alarm. You'll end up needing to rebuild the engine if you drive too much without the proper oil pressure. If you're really sure you want to disable the alarm you'll need to remove the dash to get to the buzzer and disconnect the wires. You can also experiment with removing the fuse for the instrument cluster, but you'll lose all your dash lights too. Good luck.

Oct 29, 2013 | 1998 Volkswagen Beetle

1 Answer

Change out heater core


Heater cores are quite easy to change,what's hard is taking down the entire dash assembly,start by taking off the meters,lonce this is done keep working piece by piece of the entire dash until you get to the core, this would be behind the glove box you need lots of room and many long extentions and definately need screw-gun careful not to lose any screws good luck

Jun 06, 2013 | 1998 Chevrolet Astro

1 Answer

Front speaker replacement


speakers in the dash you have to remove instrument cluster to remove the speakers mounting screws.be sure disable airbags first just first turn off radio to keep from losing code and disconnect negative battery cable wait 20 minutes before working around dash area.

Sep 01, 2012 | 2000 GMC Safari

1 Answer

Dodge stratus 2003 turn signal and all lights come on when turn signal is turn on


Check all fuses inside and out in the engine compartment. Chrysler products do strange things sometimes with blown fuses! Also, they use a master light control module, usually under the dash, that runs everything. The only way to check this would be to try a good one in place of yours. It used to be bad ground connections could also cause this. If you look behind the dash for any black wires attached to a screw into metal, try wiggling them to see if the screw is tight or if a wire broke off!! Good luck!

Aug 01, 2012 | 2003 Dodge Stratus

1 Answer

I have a 1993 Dodge dynasty and I changed the fuses for the dash lights and running lights. They still don't work. Were do i go from here?


you might have a a wire lose causing it it not to work,I would look and see if their is a lose wire somewhere cauing your lights not to work I hope that helps you Good luck ED...

Feb 21, 2012 | Cars & Trucks

1 Answer

Gas gauage is not working


their should be a reset button on the dash push and hold it

Feb 16, 2012 | 2001 Oldsmobile Aurora

1 Answer

In my 2005 pontiac sunfire the dash board light is deam on the speedometer so how do i change the light bulb out


FIRST TURN OFF RADIO TO KEEP FROM LOCKING OUT.THEN REMOVE NEGATIVE BATTERY CABLE WAIT 20 MINUTES UNTIL AIRBAG DISCHARGE.YOU WANT TO DISABLE AIRBAGS IN THE STEERING WHEEL OR DASH ANY TIME YOU WORKING AROUND STEERING WHEEL OR STEERING COLUMN OR WORK AROUND DASH AREA AIRBAGS NEED TO BE DISABLE.YOU NEED TO BUY A HAYNES REPAIR IT WILL SHOW YOU THE CLUSTER SCREWS LOCATION SO YOU CAN LOCATE SCREWS AND REMOVE CLUSTER TO REPLACE BULBS.

Aug 26, 2011 | Pontiac Sunfire Cars & Trucks

1 Answer

I have a radle sound coming from inside the dash, feels like something just went lose inside. i need to remove the instrument cluster to see what could have gone lose in there - i just cant figure how to...


these are kind of tricky on the VWs as you will need to remove the steering wheel. There are a few screws and bolts that need to be removed from the bottom dash, on the drivers side, and then work your way up, after removing that there will be a series of screws on the mid column of the dash, and a few behind the blanks that need to be popped out. by this point you will see the screws that are under the upper portion of the cluster trim and the 2 that are on the bottom. after these are removed you will see the screws for removing the cluster. Also you will need a 26mm socket to remove the steering wheel.

Jun 29, 2011 | Volkswagen Routan Cars & Trucks

1 Answer

2003 dodge ram1500 no bus now no power without key in on position


Try disconnecting the main plug held down by a screw in the fuse box in the engine compartment, clean it and plug in again. Make sure that the screw is tight. This should bring everything back alive. Sometimes the plug may become loose and you will lose communication in the computer.

Mar 29, 2009 | 2004 Dodge Ram 1500

Not finding what you are looking for?
1997 Mercury Mountaineer Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

64286 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...