Question about 2003 Oldsmobile Alero

1 Answer

Rear window defogger stopped working

I have a 2004 Olds Alero. The rear window defogger stopped working. The button lights up. I replaced the relay switch and it's still not working.

Posted by on

  • samiam214 Dec 21, 2008

    The film is fine, not scratched and the wires are attached.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 75 Answers

More than likely something has scratched the film that heats up to do the defrosting, Look to make sure it has both wires attached, and use either a test light (make one out of a 12volt bulb and wire if you do not have one.) See if you have electricity to the wires at the ends. If you do, you have a break in the film. You should be able to see where it is broken or scratched. There is an after market repair kit for this, that is not really expensive.

Posted on Dec 21, 2008

  • Gerry Haverland Dec 22, 2008

    You need to check across it with a volt ohm meter. It should have some resistance. If not, there is a short there.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wiring diagram for rear window defogger 2005 silverado from dash to deffoger


Rear Window Defogger System Components
The rear window defogger system consist of the following components:
• HVAC control module
• Body control module (BCM)
• DEFOG relay
• Rear window defogger grid
Rear Window Defogger Operation
When you turn the ignition to the ON position, ignition voltage is supplied to the DEFOG relay coil. Battery positive voltage is supplied at all times to the DEFOG relay switched input. When the rear window defogger switch is depressed, the HVAC control module illuminates the rear window defogger indicator and sends a class 2 message to the BCM. The BCM energizes the DEFOG relay by grounding the control circuit of the relay. This allows battery positive voltage from the relay switched input through the switch contacts and out the relay switched output to the rear window defogger. Ground for the rear window defogger is provided by G306 or G390 (crew cab).
When you turn ON the ignition and press the rear window defogger switch for the first time, the defogger cycle lasts 10 minutes. Further operation results in 5 minute defogger cycles.

Do you know what your messing with ? What's the problem ?

Oct 30, 2016 | Cars & Trucks

1 Answer

My heater only works some of the time and my rear defrost dont work what could be the problem


As by heat only works some of the time , you mean it doesn't blow air out of the vent's . This means you probably have a problem with the blower motor or blower motor resistor or blower motor relay .
Rear Window Defogger Inoperative

    Exchange the rear defogger relay with a known good relay from the under hood junction block.
  1. Turn the ignition switch to the ON position.
  2. Press the rear defogger switch to the ON position.
Does the rear defogger grid warm?
--
Yes Go to Step 2
NO Go to Step 3

2

Replace the faulty relay.
Is the repair complete?
Go to Defogger System Check --

3

  1. Use a fused jumper wire in order to backprobe between terminal A4 of underhood junction block connector C3 and ground.
  2. Use a test lamp in order to backprobe between terminal C5 of underhood junction block connector C3 and ground.
Does the test lamp light?
--
Go to Step 4
Go to Step 23

4

  1. Use a test lamp in order to backprobe between terminal C5 of underhood junction block connector C3 and ground.
  2. Press the rear defogger switch to the ON position.
Does the test lamp light?
--
Go to Step 5
Go to Step 14



Mar 23, 2016 | 1999 Oldsmobile Alero

2 Answers

Why is my rear defrost not working


Switch, fuse or maybe the wiring to the window has come loose or off, happens alot, kits are available at local auto parts stores...
I hope that helps...

Mar 02, 2015 | 2008 Chevrolet Malibu

1 Answer

I have a 2002 alero. Need to know where to plug in the radio antenna.


THE OLDSMOBILE ALERO DONT HAVE A EXTERNAL ANTENNA MAST. THE OLDS ALERO HAVE WIRE GRID ANTENNA INCORPORATED INTO THE DEFOGGER GRID IN THE REAR WINDOW.THE GRID ANTENNA HAVE A REAR WINDOW ANTENNA MODULE MOUNTED BEHIND TOP OF THE REAR SEAT BACK. THE RADIO ANTENNA CABLE GOES TO ANTENNA MODULE LOCATED TOP OF THE REAR SEAT BACK.

Jan 02, 2011 | 1999 Oldsmobile Alero

1 Answer

I have an '03 Olds Alero and the rear defrost is not working...replaced the relay....switch lights up and continuity is good across the grid. I put the relay in both ways..not knowing if it makes a...


The relay can go in either way--no problem. The relay runs off 2 different fuses--one to power the relay itself and one to power the defogger. Make sure both fuses 33 and 46 in the engine compartmet fuse box are good.
Next, have someone listen to the relay while you turn on the defogger to see if it's clicking. If it isn't clicking, the problem is before the relay--probably in the control panel.
If the relay is clicking, the problem may be with the antenna amplifier (radio borrows the defogger grid to improve reception). Not sure where that module is but would guess it's in the right pillar by the passenger's fuse box. If you can find it, check continuity across the 2 black leads. Also verify the back side of the defogger is getting it's ground.
Please let me know if you have more questions.

jturcotte.gif

jturcotte_0.gif

Nov 02, 2010 | 2003 Oldsmobile Alero

1 Answer

1998 buick park ave. rear window defroster not working. fuse is good, has anyone replaced the black box located next to rear window where element plugs into along with the antenna. element on window is not...


Rear Defogger Inoperative, But Heated Mirrors Operate Correctly
1. Connect scan tool. Turn ignition switch to RUN position. Turn rear defogger on. Using scan tool, display BCM
outputs. If rear defogger is being requested on, go to next step. If rear defogger is not being requested on, go to
step 10).
2. Ensure ignition switch is in RUN position. Remove rear defogger relay from rear junction block, located on center
right rear of passenger compartment, under rear seat. Connect test light between ground and defogger relay
harness connector terminal F3 (Brown wire). If test light illuminates, go to next step. If test light does not
illuminate, go to step 11).
3. Connect test light between ground and defogger relay harness connector terminal A2 (Red wire). If test light
illuminates, go to next step. If test light does not illuminate, go to step 12).
4. Connect test light between defogger relay harness connector terminals A2 (Red wire) and B3 (Purple wire). If test
light illuminates, go to step 13). If light does not illuminate, go to next step.
5. Disconnect rear defogger positive and negative feed bus connectors. Connect a jumper wire between defogger
relay harness connector terminals F3 (Brown wire) and A4 (White wire). Connect test light between ground and
positive feed bus connector terminal "A" (Black wire). If test light illuminates, go to next step. If test light does not
illuminate, go to step 8).
6. Connect test light between positive feed bus connector terminal "A" (Black wire) and negative feed bus connector
terminal "B" (Black wire). If test light illuminates, go to next step. If test light does not illuminate, go to step 9).
7. Repair open in Black wire between rear defogger and ground. Recheck system operation.
8. Repair open in Purple wire between rear junction block and heated backlight antenna module. Recheck system
operation.
9. Check for proper terminal contact at rear defogger connectors. Repair as necessary. Recheck system operation.
10. Check for proper terminal contact at BCM. If terminal contact is okay, replace BCM. Recheck system operation.
11. Repair open in Brown wire between rear junction block and instrument panel junction block. Recheck system
operation.
12. Repair open in Red wire between rear junction block and underhood junction block (located in right front corner of
engine compartment, between battery and strut tower). Recheck system operation.
13. Connect test light between defogger relay harness connector terminals F3 (Brown wire) and A4 (White wire). If
test light illuminates, go to next step. If test light does not illuminate, go to step 16).
14. Reinstall defogger relay. Disconnect BCM 32-pin Pink connector C2. BCM is located behind right side of instrument
panel, near rear of glove box. Using DVOM, check voltage between ground and BCM harness connector C2
terminal A3 (White wire). If any voltage is present, go to next step. If no voltage is present, go to step 17).
15. Repair open or short to ground in White wire between rear junction block and BCM. Recheck system operation.
16. Check for poor connection at defogger relay terminals. If connections are okay, replace defogger relay. Recheck
system operation.
17. Check for proper terminal contact at BCM. If terminal contact is okay, replace BCM. Recheck system operation.

Feb 25, 2010 | 1998 Buick Park Avenue

1 Answer

Rear window defogger dont work replaced relay & fuse still dont work


REAR WINDOW DEFOGGER SWITCH IS BAD OR YOUR REAR WINDOW HAS A BROKEN PLACE IN THE GRID.

Nov 01, 2009 | 1999 Oldsmobile Alero

1 Answer

Rear defrost on olds alero


Remove the interior panel next to the rear window on the passenger side. There should be a small black box (3"x3") bolted there. This box sends power to the rear defogger and carries the signals from teh integrated FM antenna. Often, the end of the plug fries and stops the defoggers from working while the radio has no problems.

The plug into the box is usually melted. It may look like it can be soldered and hardwired to work again, but more often than not the box is fried too. You can get them on the cheap from a JY or get them through GM.

Jul 13, 2009 | 1999 Oldsmobile Alero

1 Answer

2002 Alero defogger


A common thing to fial on these- assumning the grid is ok, and wires are still attched to grid, is the rear def / antenna module. It is behind rt. rear quarter trim panel. The modules burn up, and also melt the connector. the module and connector would need to be replaced.

Dec 06, 2008 | 2003 Oldsmobile Alero

1 Answer

2003 olds alero rear windoe defogger


the rear passager panel the one that cover the side rear window there a relay connector in there that were the power to window go that defectif that gonna FIXYA our post thank you pierre

Jul 06, 2008 | 2003 Oldsmobile Alero

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

359 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...