Question about 2003 Ford Windstar

1 Answer

Van idles fine at low rpm's, however at 4000 rpms or higher van runs like timing is off or has bad gas?

Posted by on

  • 2 more comments 
  • dwebb89 Dec 22, 2008

    Both in gear and in drive. notced on the freeway first at about 60 mph, 4000 rpm

  • dwebb89 Dec 22, 2008

    yes I was passing and car had no power and was sluggish

  • warlock61
    warlock61 May 11, 2010

    is this in gear or in park?


  • Anonymous Mar 25, 2014

    van runs like it has bad gas in it

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 659 Answers

The vehicle has a rev limiter built in. this is what you probably feeling. Are you passing? The rpm's shouldn't be that high at 60

Posted on Dec 22, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Vibrations during idling


which engine.??? never post lacking engine ,here is why.
1.3 L G13B I4
1.5 L G15A I4
1.6 L G16B I4
1.8 L J18A I4
1.8 L BP-ZE I4
1.9 L XUD9 diesel I4

Ill answer in the generic and for GAS engines. only.
that is illegal RPM, the ECU regulates it to 800 all the time
that means the ECU can not regulate the RPM now, for many reasons.
and sure it vibrates too low, that is normal for all 4cylinders to do that.
no bad engine mounts never lower RPM to 600, ever.
they dont control idle speed at all.
the #1 reason for most cars to idle too low are:
1: EGR leaks, (clean it)
2: ISC stuck closed (electric idle speed acututor dirty) clean it.
3: gross misfiring , caused by bad spark or bad fuel mix.
4: low compression on 1 or more cylinders (real low) Do compression test at WOT. throttle.



Apr 19, 2014 | 1997 Suzuki Baleno

1 Answer

My van shifts fine at low speed but when I go fast the rpm go above 4000 before shifting


the farther you press the gas pedal the higher the rpm will go before shifting. if you floor it it will redline before shifting. if it isn't shifting at the right time it could be the line pressure needs to be adjusted

Mar 24, 2013 | 2005 Chrysler Town & Country

2 Answers

1991 nissan maxima the car will run fine and just cut out i also noticed the tachometer will sometimes go 4000 rpms while stepping on gas pedal but the engine is missing and bairly running also i noticed...


Are you sure what you found is the temperature sensor? It sounds like it could be a faulty camshaft position sensor. That would explain the erratic idle and rpm spike. Will aslo cause the engine to skip because of the irregular signal being sent back to the ecm.

Mar 30, 2011 | 1991 Nissan Maxima

1 Answer

2003 Ford Focus ZTS. After running on the highway


Check for stuck throttle plate. Check pcv hose that goes to the intake manifold. They get soft and leak, check while running.

Mar 19, 2010 | 2003 Ford Focus

2 Answers

Hello. My oil light stays on at a very low idle


200 rpm's will diffenetly create a very low oil pressure signal. I can not see how your engine will run at 200 rpm's neither. check the voltage output of your altenator for if its bad this will cause a problem such as yours

Feb 15, 2010 | 2004 Mitsubishi Endeavor

1 Answer

Galant 95 backfires and shuts down at higher rpms


check ur plug wires they might be mismatched ...joe

Aug 29, 2009 | 1995 Mitsubishi Galant

1 Answer

Car runs fine at idle but wants to surge


there is a fuel pump inside the tank that is bad replace it

Jan 01, 2009 | 1988 Nissan 300ZX

1 Answer

My 2000 Accent GL is reving into HIGH RPMs! 5 speed 1.5 L


check your anti freeze and watch your temp gauge.any check engine light on.

Nov 15, 2008 | 2000 Hyundai Accent

1 Answer

96 eclipse.


Check for a vaccum leak at the intake. With the engine at idle spray a bit of starting fluid to find it. You will hear the engine pick-up when you hit the spot. Change the necessary gasket. Hopefully this will solve your prob! Frankster016

Sep 20, 2008 | 1996 Mitsubishi Eclipse

Not finding what you are looking for?
2003 Ford Windstar Logo

Related Topics:

257 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...