Question about 1989 Oldsmobile Delta 88

1 Answer

No air/heat from Vents in 89 delta 88

When I turn on the climate controle unit I don't get any air through the vents regardless of what 'setting' i have it on (defrost, floor, bi level etc), and regardless of how 'high' i have the fan setting. It is almost as if the vents are not 'open'. The fan seems to spin (or at least there is noise from the fan). Is it likely a blower motor?

Posted by on

  • vars46 Jan 25, 2009

    I have the same problem but no sounds from from the blower. I put a new blower in about two years ago and it worked for a while then would not work...work not work. Now you can feel heat but no blower. Power module maybe is bad??? Any suggestions??

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

1996 olds lss .no heat from vents which seem blocked.The fan runs

Posted on Dec 10, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2010 F150 Lariat. Dual climate control works only on passenger side. Rear temperature controls work fine. Driver side or left vents only blow hot air. Regardless if AC is turned on or temperature...


If the driver's blend door actuator has failed completely, or the wiring to it is damaged, you will not hear any clicking. Check for appropriate voltage at the blend door actuator, and determine from there if it's the actuator or the control unit.

Dec 20, 2016 | 2010 Ford F-150

1 Answer

Chevy climate control


it sure could be that head unit. if you want to clean the unit it might help. disconnect the battery, pop the bezel off the radio and head unit remove the four 9/32" bolts that hold the unit in the dash, unplug the head unit and spray it with computer duster.

Apr 03, 2014 | 2005 Chevrolet Malibu

1 Answer

Air blend door actuator


Possible bad blend door actuator .some gm cars can be relearned to the new climate control head

Jul 28, 2013 | 2001 Oldsmobile Aurora

1 Answer

2000 Buick Lesabre Limited with electronic climate control.


Could be a vacuum actuator problem. or just a vacuum leak, period. I have a Jeep that when it has a vac leak, the climate system defaults to the defrost, no matter what you set it at.

Feb 05, 2012 | 2000 Buick LeSabre

1 Answer

No heat coming from vents. Only cold air. 1998 caddy seville with climate control. No air coming from front vents at all, only defroster and heater vents.


Fuse has blown in the heater control unit, I had this on my audi last year most likely cause, get youe user manual and loacte the fuse box.

Jan 13, 2010 | 1998 Cadillac Seville

1 Answer

My 2007 Acura TL is having an air conditioning issue... The air is coming out cold from the two vents on the driver's side, but the air coming out of the passenger's side vents is very warm. The air on the...


Navigation has no relevence at all. but what does is the vent system in the dash.there is a flap inside the vents under the dash it sounds like it is not moving on the passengers side.

Jul 30, 2009 | 2007 Acura TL Sedan New Cars

3 Answers

I have a 99 Buick LeSabre with the same problem.


if car has had dash work vent tubes may not be attached to vent opening if the job wasnt done properly-or tubes may be cracked or missing

Jun 17, 2009 | 1999 Buick LeSabre

1 Answer

Passenger side blows hot air when front control set to Air


you cant adjust it ,this requires the dealers computer to re set it,or a phyiscal control has packed up like a vacumn pipe has split where it pushes onto the valve that controls the flap in the heater unit.

Apr 25, 2009 | 2005 Dodge Durango

1 Answer

Heater problems


there is a blower motor control unit under the hood on the right side near the firewall, unplug this and it should stop running. normal problem for a lot of gm cars with electronic climate control

Nov 23, 2008 | 1989 Oldsmobile Delta 88

Not finding what you are looking for?
Cars & Trucks Logo

720 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6869 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...