Question about 1997 Land Rover Discovery

1 Answer

My engine cuts out like it is running on two cylinders after it has been running and is warmed up. It does not lose RPM's but it scrubs off speed and it will do it running 70 mph or 35 mph and everything in between. I recently had a tune up done but it did not help. In fact, it may be worse. What else can I check?

Posted by on

  • Anonymous Jan 12, 2009

    What kind of coil? Does it have a formal name?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Can you get a hold of a new coil to try ? 

Posted on Jan 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My mazda soho 1.4i cuts out when you stop at the stop street or robot and she doesn't rev up?


Check out the related help links with solutions to troubleshoot the problem.
Click the link below:----
1990 Toyota 4Runner: Engine cuts off when reaches 2000 RPM?


http://whatisbyme.blogspot.in/2012/05/1990-toyota-4runner-engine-cuts-off.html

-----------
Volvo 760 engine cuts off frequently while driving? http://schematicsdiagram.blogspot.in/2012/02/volvo-760-engine-cuts-off-frequently.html

----------
Car starts and cuts off immediately? http://repairhelpcenter.blogspot.com/2012/01/car-starts-and-cuts-off-immediately.html

-----------
Engine cuts out at 3000 RPM? http://schematicsdiagram.blogspot.com/2011/12/engine-cuts-out-at-3000-rpm.html

-------------
While stop engine idles like cylinder missing? http://schematicsdiagram.blogspot.com/2012/01/while-stop-engine-idles-like-cylinder.html

-----------
These details will help.
Thanks.

Nov 22, 2012 | Cars & Trucks

1 Answer

I have a 1989 mustang 5.0 supercharged the engine runs great when cold after it gets warm around 205 it develops a miss almost when u are driving down the road the tach will drop 200 300 rpms and pick back...


Hello, Check you running engine when it is hot. Use an old spray bottle and mist every seam you can find. If the RPM changes you have found a Vacuum leak. I suspect that as the engine heats up, the parts swell and it creates a gasket leak.

If you have a more serious problem, you may have a crack in a head which expands as the engine warms up. There are Electronic tests for Cylinder balance which can expose a cylinder or head gasket which leaks and changes the Cylinder balance. You need a shop with a scope that can do Cylinder balance.

A lazy O2 sensor can also make the RPM float like yours is doing. Usually your onboard computer generates and identifies the specific O2 sensor that is bad. If your car has set a Code, then Autozone, Oreillys, and Advance will scan your car for free.

I hope my solution helps you find your problem. Would appreciate a note when you get your car fixed.

Jun 08, 2011 | 1989 Ford Mustang

1 Answer

Idle problem when brakes applied


Sounds like you have a vacume leak on your brake booster ....with engine running have someone press the brake while you listen on the driver side by the master cylinder the large vacume line going to the booster behind the master cylinder is most likely the vacume leak...and if so you can get what you need at your local parts store ...

Nov 20, 2009 | 2004 GMC Sierra 1500 Crew Cab

1 Answer

97 k1500 5.7 liter vortec misses on cylinders 3 and 5 while idling. about 1500 rpm only cylinder 3 and 4 miss then at 2000 rpm only cylinder 4 and 8 miss. what could cause this?


I have had continuous missing issues on my 1997 Silverado after i had a new engine installed 30,000 miles ago. Today I purchased a new gasket for the EGR Valve and removed it. The mechanic had re-used the old gasket when he replaced the engine and cut corners to save $2.00. I found he had installed the EGR bass-ackwards causing my check engine light to stay on and the engine always to miss. Engine runs GREAT now

Oct 14, 2009 | 1997 Chevrolet K1500

1 Answer

Subaru legacy gt twin hard to start on a warm day


Hi, have the same problem with my 1995 legacy gt twin turbo and the problem lyes with the ecu temp switch, it sound's like the ecu thinks the engine needs more fuel to start and run

Sep 09, 2009 | 1996 Subaru Legacy

1 Answer

Engine idling gone crazy


check for lose vacuum hoses or lose throttle hose make sure you air flow meter ducks are tite if you see everything ok then the idle speed control valve could be dirty with a little carburetor cleaner spray while engine is running open throttle and spray into throttle till you can see throttle is clean you may have to do this a few time hope this information is useful good luck

Jul 27, 2009 | 1995 Toyota Previa

1 Answer

Cold idle is right at 2k rpm.


could be a vacume leak. check hose for cracks or lose conections.

Jun 13, 2009 | 1997 Land Rover Discovery

1 Answer

Engine bk firering & lose of compression.


Backfiring after warming up can be from many things.

One that comes to mind is carbon deposits on valves, causing them to not close properly. The carbon deposits would also heat up and then ignite air/fuel mixtures before the spark plug can fire.
Or you would have hot exhaust gasses leaking back into the cylinder on intake and that would ignite the fuel.

Tac gauge fluctuating, and engine running rough on acceleration could be a vacuum leak, do you hear a hissing sound when the engine is running? listen closely under the hood. If you have a vacuum leak you would lose power and your RPM would fluctuate oddly. As for the backfire however, there are probably more than just one problem. Its hard to say for sure.

So please, more details, noises you hear, when exactly everything happens etc.
What speed and RPM the engine begins to bog down at, does it stall? What range is ur tac fluctuating at? anything you can think of, throw it on there.

Hope this helps you

Apr 24, 2009 | 1998 Nissan Pathfinder

1 Answer

When warmed up, the engine (2.7) may miss erratically


1391 is lose off cranksensor or cam sensor like code 340 i would by a cam sensor for that code.356 sounds like a bad coil on #6 which there are one per cylinder .dont worry about code 432 for now.

Mar 15, 2009 | 1999 Dodge Intrepid

Not finding what you are looking for?
1997 Land Rover Discovery Logo

Related Topics:

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

61037 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...