Question about 2004 Pontiac Sunfire

2 Answers

2004 Sunfire Running Very Rough

We bought this 04 Sunfire in Jan 08 for a car lot and now its Dec 08 and the problems have begun. The other day my girlfriend went out to start the car early in the morning and it was running bad. First thought I had was a headgasket as gone.

Here's the thing, the cars oil is clean, the antifreeze in the tank has not really moved and its clean and theres no leaks coming from anywhere on the vehcile. There was a little white smoke coming from the tail pipe but the smell was that of gas not sweet like antifreeze.

I also noticed the rad fan runs as soon as you turn the car on but does not turn off. Also the car feels like its running on only 2 cylinders and barley moves.

Im hopeful that it has something to do with the fuel pump constantly pumpng fuel into the car or choke stuck on. Its doing the samething my bike does when I first start it with the choke and give it full gas.

Could someone give me some ideas please. One of the local garages has quoted us 1500 for new head gasket and labour then another 700 if it needs a new cylinder head. This seems a little weird considering the car is well taken care of and has just went over 100,000km.

Again no leaks, oil clean, antifreeze clean, bad smell of gas from exhaust and bad loss of compression or flooding out. Any ideas please??????

Posted by on

  • Andreadrejo Mar 05, 2009

    I seem to have the same problem with my Pontiac Sunfire, I have replaced the module that sits on top of the engine about 5 times this year, the problem was fixed for about a year the first one and then every module ive had since then didnt even last me a driving of my car. It seems to blow out when I put the pedal to the floor. Dont know what could be causing this part to keep going out. Did you ever figure out what was wrong?

  • shaunamason2 Apr 29, 2009

    i AM HAVING THE SAME PROBLEM ONLY I CHANGED EVERYTHING AND I CHANGED THE MODULE LIKE SOME ONE ELSE SUGGESTED STILL THE SAME PROBLEM RUNNING ROUGH AND HAVING TO PUT MY GAS PEDAL TO THE FLOOR BEFORE IT WILL START THEN RUNNING ROUGH AND WNATING TO STALL ANY OTHER SUGGESTIONS?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Change the Sensor on top of the coil pack and that will fix the problem. #2 also try tune up. #3 Clean Fuel Injectors

Posted on Jan 19, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 449 Answers

Do a tune up change spark plugs, wires, air filter, pcv ,and fuel filter.

Posted on Dec 18, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just bought an 04 isuzu rodeo with only 75000 miles it seems to run rough and makes a knocking noise and shakes and no the chk engine light is on what do you suggest I do


First thing I would check is timing then plugs and wires. With electronic ignitions, even bad plugs and wires can cause rough running and pinging and knocking, backfire and such.

Apr 02, 2016 | 2004 Isuzu Rodeo

2 Answers

S60 Trunk won't open with remote or switch


trunk won't open with remote/release - Volvo Forums - Volvo ...

volvoforums.com > ... > Volvo Vehicles > Volvo S60 & V60
Oct 24, 2008 - ... will not open with the remote nor with the release switch on the trunklid. ... My 2002 S60 trunk button (above Lic. plate) never has worked. electrical trunk release
Apr 15, 2011
trunk won't open
Jan 27, 2011
Trunk won't open
Sep 7, 2009
New to me 04 S60 trunk release problem
Sep 27, 2006
More results from volvoforums.com

Re: 2002 S60 Trunk won't open with remote or switch - Matthews ...

www.matthewsvolvosite.com/forums/viewtopic.php?t=45848
Jan 16, 2012 - My trunk won't open with the remote or by using the soft switch"handle" on the trunk. I can open the trunk using the key. I can hear an electronic ... Trunk & Fuel Door Won't Open & Fuel Gauge is Wrong In 1 Day?
Dec 2, 2015
Power Locks/Fuel Door/Trunk won't open 1999 s70 GLT Turbo ...
Aug 14, 2011
2001 V70 T5 Tailgate - Matthews Volvo Site
Jan 12, 2010
Re: 98 V70 XC - Trunk open light on - Matthews Volvo Site
Dec 20, 2009
More results from www.matthewsvolvosite.com

Dec 18, 2015 | 2006 Volvo S60 2.5

1 Answer

2008 mercury mountaineer. heat will blow and then it will blow cold. Coolant is full and no leaks. It's overheated twice in the past week. Now high rpms at low speed, when heat is turned on or off.


Mercury Mountaineer Start Stall Idle Problems - Car Forums at ...

forums.edmunds.com > Mercury > Mercury Mountaineer

Dec 12, 2010 - 14 posts - ‎14 authors
Learn more about Mercury Mountaineer at the Edmunds.com Car Forums! ... Light came back on but no more stalling at speed. ... I have the same stalling at low idleproblem (under 500 RPM) with my 2003 Mountaineer 4.6L V8 AWD. ... My computer is telling the engine to rev at a high RPM on startup, then ...

Engine Rev's high, slow to accelerate - Ford Truck Enthusiasts Forums

www.ford-trucks.com > ... > Expedition & Navigator
Aug 22, 2003 - Engine Rev's high, slow to accelerate Expedition & Navigator. ... If you give it more gas I do pick up speed faster, but the noise gets louder. ... 99 Expedition 5.4/3.55 LS (plan to replace with SD-PSD) & 95 Mercury Mystique 2.5L/v6 .... What transmission, mrpositraction, 2004 - 2008 F150, 15, 04-08-2008 ... 2008 F-150 - Rough Idle and Hissing Noise at 1800 RPM
May 22, 2014
2001 mercury moutaineer 5.0 high idle 1000-1200 rpm's at idle ...
Aug 2, 2011
Head gasket leaks; Overheats at high speed/RPM.
Jan 11, 2011
Strange "whoop" sound?
Jun 19, 2007
More results from www.ford-trucks.com

Loud..the RPMs increase like I am stuck in 1st gear..torque


Dec 07, 2015 | Mercury Cars & Trucks

2 Answers

Car momentarally shutters at all speeds and gears more and more frequently after it is warmed up. You can feel it slightly at idle.


2003 neon shaking after changing both right motor mounts ...

www.topix.com > Dodge Neon
Mar 10, 2012 - ... News Offbeat Stars! Topix > Dodge Neon > 2003 neon shaking after changing both. .... Google dodge neon engine alignment, and some sites will fill you in better. Reply ». Report Abuse .... 95 neon oil leak? (Oct '08), Oct 22 ... dodge neon engine vibration
Nov 10, 2012
2004 Dodge Neon SXT Problems
Jan 8, 2011
02 neon vibration under acceleration
Jul 21, 2007
97 Neon Idle rough
Jan 18, 2007
More results from www.topix.com

Oct 29, 2015 | 1995 Dodge Neon

1 Answer

I'm having a four-wheel-drive problem on my 2002 tundra. I just bought a new 4wd actuator and I still have the same problem


Thread: 4 Wheel Drive just broke - Tundra Solutions

www.tundrasolutions.com/...driveshaft.../1419-4-wheel-drive-just-broke/
Feb 16, 2002 - 15 posts - ‎5 authors Some 2000 model year Tundra owners have reported problems with .... I have a 2002TRD and I cannot get it into 4WD when the temperture ... DIY 2002 Sequoia No 4WD, Blinking Orange Light ...
15 posts
Jan 21, 2010
Question 2004 Sequoia Blinking amber light no 4wd
12 posts
Dec 10, 2009
2004 tundra 4WD not engaging
15 posts
Sep 9, 2007
Tundra 4 Wheel Drive Won't Engage. Help!
11 posts
Nov 27, 2004
More results from www.tundrasolutions.com

Any Tundra owners had the blinking orange light 4WD problem


Sep 30, 2015 | Cars & Trucks

1 Answer

Having Engine Problems with my 04 Sunfire, can anyone help?


The generic code is for a problem with the heater circuit in the O2 sensor after the catalytic converter.
The sensor is not heating up fast enough to work correctly.
It could be a faulty sensor or a problem with the power to the heater. The sensor does have a slight effect on the fuel mixture, but I doubt it would cause the engine to run rough.

Sep 01, 2012 | 2004 Pontiac Sunfire

1 Answer

2004 sunfire showed code po 300


Probably not. Depends on what the red line is.
Code 300 is a random miss - which could be a spark plug, coil, fuel injector, or other problem.

Jul 31, 2012 | 2004 Pontiac Sunfire

1 Answer

04 sunfire drove perfect all day but just as I was pulling in my parking lot it started shaking real bad....what could be wrong?


Sounds like an engine misfire, One of the cylinders isn't firing correctly, You could have a bad spark plug or injector, but that year sunfire were known for faulty ignition coils. If the shake was severe enough it would indicate a coil issue because 2 out of you 4 cylinders aren't firing properly (a coil controls spark to 2 cylinders at a time). To be sure have it checked out at a garage, if the check engine light is on have it scanned at a large parts retailer (usually for free) or at a locate reliable garage. It would better determine the cause of the shaking.

Feb 02, 2011 | 2004 Pontiac Sunfire

1 Answer

My 2004 Pontiac Sunfire...


sounds like a dead battery i would have it check and your alternator

Jun 13, 2008 | 2004 Pontiac Sunfire

Not finding what you are looking for?
2004 Pontiac Sunfire Logo

390 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...