Question about 1994 Jeep Grand Cherokee

2 Answers

Bad sensor... ...what would 'windshield sensor bad' display mean? where would I need to check if it isn't the plastic tube that actually goes in to the fluid reservoir? Thanks

Posted by on

  • 5 more comments 
  • prez96 Dec 18, 2008

    ....well, 'am investing in a code reader today, hopefully that helps :) otherwise, I am stumped as far as that 'sensor' warning goes...

  • prez96 Dec 18, 2008

    ....thank you :) I will do that :)

  • prez96 Dec 18, 2008

    Hi, me again...I stand corrected, the on board computer display on my JGC LTD. actually says 'washer sensor bad'....any ideas?

    Thanks...

  • prez96 Dec 23, 2008

    ...yea, just did...unfortunately, nothing on the (haynes) manual was really much help...will consult with chilton's manual...

  • yadayada
    yadayada May 11, 2010

    no idea's, have u thought of buying a manual?? they are avail on ebay.

  • yadayada
    yadayada May 11, 2010

    if u buy one get one that reads main stream data as well as codes

  • yadayada
    yadayada May 11, 2010

    I am only sure of one thing it is not the low fluid sensor for the washer tank.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

It means that the sending unit that tells you when your low on washer fluid is either not reading it or is dirty try spraying wd40 in the plug and try again or see if it is loose.

Posted on Jan 04, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Try to check the fluid container inside of there is a sensor that your looking for that should solve your problem if it is replaced it will look like a round cork of some sort get back in touch with me if thtats not it

Posted on Dec 24, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My windshield washer hose broke off at the hood and windshield, How is the best way to fix it... Also I have my traction off light on and ABS,Brake light on all the time... My traction and ABS have been...


For the windshield washer. Get a small piece of rubber hose that is snug around the plastic hose that broke. For the rest, First check the brake fluid level. Fill as necessary. If the brake light goes off. The have the ABS system scanned for codes. Bad wheel sensor. If the brake light stays on, Check the ground for the ABS module first. It runs from the module to the frame below it. I cut the wire and run it to the body. If it is still on. The module or pump is bad. You can still have the codes read.

Mar 24, 2015 | 2002 Oldsmobile Aurora

1 Answer

Daytime running lights not working


Can you see the smoke colored sensor near the windshield? I've had one break and fall down which caused this exact problem. If you can see it, pull the plastic trim piece off, make sure the connections are actually connected, have seen these come unhooked.

Mar 22, 2014 | GMC Envoy Cars & Trucks

1 Answer

1998 Jetta TDI compressor goes on--full charge, but no cold air-


possibly a bad expansion valve/orifice tube. or the blower switch isn't working properly. I mean, not moving the blender door correctly, not letting air flow through the A/C evaporator!

Jun 22, 2012 | 1998 Volkswagen Jetta

1 Answer

What is involved to fix check engine light codes P1361 and P1362 and how much should I pay a reputable mechanic


The code P1361 and P1362 can relate to a TDC sensor failure, the plug could be dirty or you may need to replace the sensor. Here's a walkthrough:

http://www.civicforums.com/forums/115-engine/323984-diy-tdc-sensor-cmp-sensor-replacement-w-pics.html

P1362 means the PCM isn't getting a signal from the TDC sensor. The TDC sensor is actually the camshaft position sensor.

TDC is also a Crank Position Sensor, Advanced Auto Parts has them for $70, or you can pick it up from your local dealer.

Nov 07, 2011 | 2002 Honda Civic

1 Answer

After engine is warm ( V 6 ) sometimes, but not always, hesitates when trying to speed up and sometimes backfires. Dealer replaced coils and plugs but can't find the problem. 2005 lincoln LS


The spark plugs get replaced around 60,000 miles
& the L/S requires a special spark plug,also
premium fuel or it will knock

If you change plugs every 3 years, then that isn't the issue

Did they remove the upper intake manifold to do the right side
spark plugs?

You never have more then 1 bad coil a year, or sometimes
2 ,but never at one time

A dealer can not work on an L/S for some reason
I own a 2004 V8 & have no issues diagnosing these problems

The front 2 O2 Sensors ,the ones in the front of exhaust converter,
get slow & get replaced at 100,000 miles

You clean the MAF Sensor with CRC MAF Cleaner

A back fire could be a lean condition from a vacuum leak
That could be around the engine or in the EVAP System

Hopefully they checked the TPS Sensor

When I refer to check, I don't mean replace,I mean test &
use an oscilloscope to back probe the sensors,not continually
make love to their scan tools,actually get involved & see what
does work & how well,then you will eventually find something
that doesn't.

The EGR Valves fail on ford products quite offten

Need to check/test fuel pressure at rail on engine,even
road test with gauge taped to the windshield & take scan
tool along to collect data.

You got sometimes & when warm,that is what they should
be working off of
You don't go after a problem ,you find out how things are
doing that do work & the drivability issue will surface.

Dealers sometimes never even road test a car or long enough
So there you go,they won't find anything

Keep in touch,I have all the manuals etc if you give me more
symptoms

Jun 22, 2011 | 2005 Lincoln LS

1 Answer

Where is the pvc tube located


I think you mean PCV (Positive Crankcase Ventilation) rather than PVC.

It is on the valve cover. on the firewall side to the right. (with you facing windshield) it is plastic, threaded in to the hole.


Please remember to rate this solution. Thanks!

Feb 18, 2011 | 2001 Ford Focus

2 Answers

Check engine light


Code PO442 means you have a small leak in your evap system. Codes PO452 & PO453 refer specifically to the fuel thank.

Although it will be a good idea to change your gas cap, I don't think it is where your problem is coming from.

I would check the vacumm hoses for loose fitting or small cracks.

Specially if you had your car worked on recently.

Good luck

Mar 09, 2010 | 2000 Buick Park Avenue

1 Answer

Can 2001 a4 quattro low oil light be reset


No, it goes out when the oil level is read to be correct. If you have the right amount of oil in the car, your pressure sensor is bad or you have oil sludge blocking the pickup tube at the oil pump. Run some Seafoam in the oil for 100 miles and then change the oil and filter (or if the pressure light stays on, add half a can of Seafoam and idle it for 20 minutes before changing the oil). Repeat 2-3 times and see if it goes away. If not, change the pressure sensor (on the oil cooler - the aluminum block the filter screws onto). If this still isn't a fix, you need a desludging kit from www.ecstuning.com. If THAT doesn't fix it, drop the oil pan and change the pickup tube and filter screen, clean out the pan, and repeat the Seafoam treatment.

Jul 12, 2009 | 2000 Audi A4

4 Answers

89 vw cabriolet oil light comes on....


I would say you might have a weak oil pump. you should try and change the sensor first so u can make sure that its not the sensor.

Jun 09, 2009 | 1989 Volkswagen Cabriolet

1 Answer

On board sensor for windshield fluid


The sensor may still be bad even with cleaning, as this is an electrical part, Since the sensor only checks for a low fluid level, it should just be like an on-off switch.  You can check it by removing the sensor from the Jeep and checking the resistance or continuity  across the 2 wires, is there is no change when you move the float up and down, then the sensor is probably bad.  If the continuity changes then the sensor is good, pointing to a deeper problem like a short in the electrical system or a bad body control module.  Good Luck!

Dec 18, 2008 | 1994 Jeep Grand Cherokee

Not finding what you are looking for?
1994 Jeep Grand Cherokee Logo

136 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...