Question about 2000 Ford Expedition

2 Answers

My 2000 Expedition is shaking when I excelerate. Could I have blown a spark plug or what else could it be?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Welcome to the party, sounds like we may have the exact same problem. My 2000 EB expo left us stranded on Thankgiving with that sort of issue. It is a fifteen amp fuse under the hood that controls the transmission relay. After sending it in and discovering the problem we still have no idea what is causing it. It will go in to an auto-electricain after the Holidays because the problem persist! Have you had the joy of replacing the GEM modual yet?

Posted on Jan 04, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 66 Answers

Could be plug or coil pack ck compression

Posted on Dec 18, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Knocking in engine when excelerate and the loose all funtion steering and now car dont start at all.


does it have coils? it might had blew out a spark plug. coils cause the same problem on my ford expedition

May 14, 2015 | Ford Taurus Cars & Trucks

3 Answers

I have 2000 ford expedition and last few weeks its been making a whistling noise when accelerate, then past few days it's been running rough, idel low and shakes a bit then today check engine ligh


You might check the pulleys that the serpentine belt runs on. Make sure all are free wheeling and not loose or rough or make noise. You would need to remove the belt to check them.

Jan 16, 2013 | 2000 Ford Expedition

1 Answer

I have a 2000 Ford Expedition that rides rough (front end shakes as if i'm going over pot holes) at around 40 - 50 mph. My guess is...my spark plugs need to be replaced but I'm not a mechani


I'm assuming its petrol as you mention spark plugs. When you say it feels like your going over pot holes again I assume you mean he engine is misfiring? And it's not a steering problem? Firstly I would check the work done on your inlet, If you have any form of leak within your inlet system you will experience loss of power and potential misfiring, you may also hear an induction noise or whistle if there is a leak. Secondly you need to see if its an ignition or fuel problem, it may be easier to conduct a minor service, replace spark plugs, fuel filter, air filter. Unfortunately with the symptoms you have given it could be a whole host of things, fuel pump, ecu! Sorry for being vague.

Dec 03, 2012 | 2000 Ford Expedition Eddie Bauer

1 Answer

Electrical Problems


Your best bet is making an appointment with a mechanic. There could be any number of possibilities that might be causing all this.

Apr 22, 2012 | 2000 Ford Expedition

1 Answer

My 2002 Ford Expedition shakes when put in drive. In park it does not shake. What would cause this, spark plug wires, plugs, fuel filter?


Spark plugs and wires,
Bad or leaky vacuum line
Bad 02 sensors, (check engine light would likely be on)

If it doesn't do it at idle, then motors mounts should be good and the problem is one of the listed above.

Jul 22, 2010 | 2002 Ford Expedition

1 Answer

Cuts out when excelerating like its not getting fuel? also backfires when excelerating-has newer spark plugs all checked and tune up-still has the same issue


Mine does the same thing(same year) and my best guess is....
It only seems to do it when its really low on gas. On the expedition the pump is located near the back of the gas tank(when backed into a driveway the gas gauge reads significantly less gas than what is really in there) so when accelerating the gas sloshes around and the pump doesnt get enough gas to keep it running. Hope this helps.

Jun 29, 2009 | 1999 Ford Expedition

1 Answer

Sputturing engine


have your spark plugs, coil pack boots checked for moisture,on many ford water will accumulate around plugs,expeually if it has rained recently.

Jan 13, 2009 | 2001 Ford Expedition

1 Answer

Vehicle shaking like it is missing real bad


when was the last tune up done and fuel filter was changed?
there is no spark plug wires I had to replace the boot for the number one cylinder on a 2000 expedition that was also having the same problem if the check engine light is on take it to auto zone and they will put it on a tester free of charge and I hope and pray that it is not the problem like the one I am working on right now I am replacing the upper and lower intake gaskets

Jan 11, 2009 | 2000 Ford Expedition

Not finding what you are looking for?
2000 Ford Expedition Logo

Related Topics:

380 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...