Question about 1995 Chevrolet K1500

1 Answer

1998 Ext. Cab chevy 5.0

When idle motor is loping "going up an down" an when in gear it spits an sputters,its real boggy when off the start an not wanting to go,when reving the motor it sounds fine..and when u get goin its fine but off the start and idle its have difficulties,recently overheated an hasnt ran the same sense,in 1 week had to put 3 gallons of antifreeze in it,first i thought it was the cap so i replaced it,then thought perhaps leak in the hose,replaced it,i do not appear to have a hole in the radiotor but i may have a small leak on the intake but im not sure..any suggestions?

Posted by on

  • Anonymous May 02, 2009

    I HAVE A 1995 Z71 5.7 I HAVE REPLACED THE SPARKPLUGS&WIRE,EGR,EGR SOLENOID,CAP&ROTOR,PCV,ICD,AND SET THE TIMEING. THE TRUCK WILL NOT IDLE RIGHT. SOMETIMES WHEN YOU START IT THE RPM GAUGE,MPH GAUGEAND SHIFT IND. WILL NOT COME ON, AND IT WILL GIVE TRANS. CODES.AND IT WILL HAVE NO POWER. TURN IT OFF AND BACK ON AND IT WILL RUN FINE BUT WILL NOT IDLE, IT WONT GIVE ANYOTHER CODES IDLES LIKE TIMEING IS OFF,SET TIMEING OVER AND OVER AGAIN, IT JUST WONT IDLE RIGHT

  • Barry May 11, 2010

    do a compression test,sonunds like a blown head gasket

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I also have a '95 ext. cab silverado got it Dec. of 09 I love it come the middle of Jan. '10 It started to hesitate, push the gas no power, it herks and jerks, to me it sound like its gurgling when i push on gas. Just today i came across this site (http://www.carterfueldelivery.com). i am now going to check and do what i have learned. see i changed the TPS, o2 sensor, blown the gas lines out, checked the MAP sensor, EGR valve and sensor and much more........ SO HOPE THIS HELPS BOTH OF US.. GOOD LUCK

Posted on Jul 09, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i fix a lope in my 1998 chevy malibu


Vaccum test the machine,this will narrow down the problems source....Idle air control(IAC) can and does malfunction without setting fault codes....Hence the old tried and true method of vaccum testing,also a fuel pressure test wouldn't hurt.....You can purchase all these tools from ebay for less than 100.00.....Well worth the initial investment...

Sep 15, 2014 | Cars & Trucks

1 Answer

Motor skipps during acceleration on 1998 s10 pick up 4.3 v6


a bad plug wire will break down when accelerating but act ok when idling change plugs and wires

Dec 27, 2012 | 1998 Chevrolet S-10 Pickup

1 Answer

I have a 1985 chevy s10 pickup 2.8 liter,2wd,automatic,w/2 barrel carbuerated motor.it starts rite up..but it idles rough,but when in park if i accelerate it smoothes out and sounds fine..revs rite...


You should probably fix the cable for the second barrel--maybe you can make one with a coat hanger or similar item.

It seems to me that you may also have a miss. Have you checked plugs and wires? How about the timing?

More Questions--please reply.

Sep 08, 2010 | 1991 Chevrolet S-10

2 Answers

I have a 1991 chevy 1500 ext cab with a 350 motor


Check engine light on? Does it run normal driving it? Sounds like a vacuum leak. Check the gasket under the throttle body.

Jun 05, 2010 | 1991 Chevrolet C1500

1 Answer

What transmission will interchange with my truck a 1998 chevy 1500 with a ext cab with a 4l60e


You can replace it with another 4L60E 1998 and newer and you can upgrade it to the 4L65E which is the same but uses 5 planetary gears in stead of 4 that is used in the 4L60E.
1998 was the change off year i believe where they started to section off the transmission in to three parts. The bell housing, body and tail end. The tail shaft housing uses 5 bolts to connect to the transmission and the 1997 transmission and earlier uses 4 bolts, but internal parts had no changes other then the 4L65E.
Thank you for using fixya and good luck.

Apr 27, 2010 | 1998 Chevrolet C1500

1 Answer

1998 Pontiac Bonneville SE 3.8L Backfires/ Sputters


sounds like the ignition module is going bad.

Aug 04, 2009 | 1998 Pontiac Bonneville

2 Answers

1995 Chevy 1500 4x4 5.7L 5 spd manual ext cab fuel sending unit?


As far as your sputtering when leaving from a stop, I have found that the bushings in the distrubutor wear out. The rotor will no longer be centered under the cap and it will result in a poor idle and sputtering. The best way is to remove the cap and rotor and check to see if there is a brown rusty colored dust present. If it is, you must replace the distributor and the problem will be corrected.

Jan 03, 2009 | 1995 Chevrolet K1500

Not finding what you are looking for?
1995 Chevrolet K1500 Logo

133 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...