Question about 1999 Buick Century

1 Answer

Heater air not working. " rear defrost is working"

This problem occured yesterday. My heat only worked on high but now it just dosn't work at all. But my rear defrost does work. What could it be? maybe a fuse or maybe just the switch is out? My car is 1999 Buick if that helps? Thanks Mary

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Buick Master
  • 60,960 Answers

The problem is causes by a defective temp control blend door actuator, this is deep in the dash, to access it you must remve the dash assembly.

Posted on Dec 17, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My windows are not defrosting properly.


Do you have heat? Does the fan turn on? are you getting air from the defroster vents close to the windshield? If you have heat make sure the defrost control is working. I'd open the outside air vent and turn the blower on high speed. If there is no heat, the heater control valve is not working. Double check the radiator fluid tank, make sure you have enough fluid (antifreeze) Low fluid levels can reduce the hot water flow to the heater coil inside the car. If there
is no air flow through the defroster vents you may have a problem with the fan control, or the fan motor. Good luck.

Feb 20, 2015 | 2004 Chevrolet TrailBlazer

2 Answers

We had some subzero weather while I was on vacation. My 2004 Jaguar was parked outside for several weeks. We had another very cold, icy day, and heater did not work. Fan works, rear window defroster...


What is happening here is that the faster the heater blows air through the fan, the more it cools the liquid in the heater core, and so heat output is reduced. The root of the problem is either the engine is not warming up enough, or the heater core, and/or heater core lines, are plugged up, not allowing the water to circulate properly in the heater core. Here is what I would try.

1. Top off the radiator and overflow.
2. Is the engine warming up properly? Is your temperature gauge showing normal temperatures? If it is not, then replace the thermostat.
3. If steps 1 and 2 do not solve the problem, get the vehicle in a shop, locate the heater core lines, take them apart and flush out the heater core. Look for blockages in the fittings. Do a flow test on the core. It may be clogged and need to be replaced.

Jan 08, 2015 | 2004 Jaguar X-Type

1 Answer

Heater works in cab blower works in cabnin just not blowing heat


hot air not being directed to vents? Check vaccuume hose under hood

Jan 29, 2014 | 2002 Ford E350

1 Answer

2012 jeep liberty heater


If you find that the heater control is a problem then until you get an answer, try running the ac unit as well. It will dehumidify the cab air ( no fogging windscreen ) keep the cab at a reasonable temperature . In most cars it is referred to as climate control . Control is by the heater knob as to how hot you allow the heater to get

Nov 30, 2013 | Jeep Cars & Trucks

2 Answers

Kia Sedona- center and third row heating vents blowing cold air


There is a separate button on the lower dash labeled RR HTR for the rear heater. If you do not engage the switch it will blow cold air.
kia-sedona-center-third-row-heating-ir03o0ur3ff3pxc4zrfsqvc4-3-0.jpg

Nov 13, 2013 | Kia Cars & Trucks

2 Answers

Defrost, heater fan and air won't work on my 96


just a guess but being that the rear defrost is not woking id bet ist a fuse check owners manuel or go to a local autozone or the like store as thy should check this for free hope this is helpfull.
please post response good luck

Jan 07, 2010 | 1996 Saturn SL

1 Answer

1999 Volvo S70 heater and defroster blowing "fog"


suspect leaking heater core.check coolant level.

Sep 29, 2009 | 2000 Volvo S40

1 Answer

Ford Windstar SE, 3.8L V6, 1999, front seat heat/defrost is cold


the blendor actuators strip out the gear inside the actuator cases on these all the time. replace the actuator.

Mar 10, 2009 | 1997 Ford Windstar

3 Answers

Heating Problem w/2000 Plymouth Breeze.


Sounds exactly like what my mom's car was doing as for the blower only working on high. It was the resistor... I assumed it was the climate controls and replaced them but it didn't change anything then i thought that i must be the blower motor and replaced that too but it turned out to be the resistor which is under the dash on the passenger side of the car.

Nov 10, 2008 | 2000 Plymouth Breeze

1 Answer

Heater/ defrost


no heat can be a t stat problem and the defroster sounds like a vacuum canister that controls the switching is not operating

Oct 20, 2008 | 1992 Buick Park Avenue

Not finding what you are looking for?
1999 Buick Century Logo

150 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...