Question about 1996 Saturn SL

1 Answer

Rough start 1996 SL1 has a rough start stables for about a min. and runs find.Also sometimes really hard to start. I've changed the map,iac sensor and also the coil packs . The initial code was p0341. Cleared it and got p1159. Please what do think it can be?

Posted by on

  • kiddad Dec 17, 2008

    Thank you for tip help out alot appreciate the help

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Saturn Expert
  • 62 Answers

The coolant temperature sensor is reading incorrectly. This is a very common problem for s-series cars. Usually the sensor is cracked and leaking into the connector so it will be corroded and need to be replaced also.

Posted on Dec 17, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Problems with 1996 dodge grand caravan keeps dying replaced computer sensor alternator spark plugs wires serpentine belt fuel pump coils


FUEL FILTER,,IF IT IS OLD-REPLACE!
FUEL PUMP NOT REALLY SUSPECT.....BUT POSSIBLE AS IN A THERMAL SHORTING (AFTER A SHORT TIME)
YOU HAVE TO DETERMINE WHETHER THIS DELAYED STALL ISSUE, IS COMING FROM A FUEL OR ELECTRICAL MALFUNCTION. IE: ELECTRIC CUT OUT...SUDDEN LOSS OF POWER...FUEL ISSUES: ROUGH RU..THEN SHUTS DOWNNING, BUCKING & SURGING
IF YOUR NOT FIXED...JEFF AT: JLGPROP@!YAHOO.COM THE WORX GROUP L.L.C.

Jul 02, 2014 | 1996 Dodge Grand Caravan

1 Answer

92 Thundebird 3.8...starts hard....really rough idle in any gear...sounds loud. Almost feels as if the engine is shaking


run fault codes and look for position sensors --MAP/MAF/VAF sensor problems and fuel /injector faults.

Jan 06, 2014 | 1992 Ford Thunderbird

2 Answers

1996 jeep cherokee stalls, I've replaced the throttle position sensor, MAP sensor, and carbeurotor. What else could it be?


You replace sparkplugs,plug wire,tps,map,cap and rotor.Thats good,If the vehicle runs and you come to a stop and it stalls,That is the IAC (Idle air control) you say it ran fine for a week now its acting up, Service the IAC or get it replaced.

Mar 21, 2012 | 1996 Jeep Grand Cherokee

1 Answer

1988 gmc 5.7l engine, changed, iac motor, map sensor, fuel press. regulator, fuel pump, fuel filter, timing gear and chain, distributor, has no cat. converter , yet still cranks a long time before...


i have the same exact problem, i have replaced fuel injectors, idle position sensor, idle air sensor, map sensor, temperature sensor,. the only way i can make mine run ok. not great is unpluging the map electrical connector, and it still has no power if u gas on it but it makes it down the road and smells rich, if u find out let me know what the problem was i really love my truck and hate that it doesnt run right, Redemmett21@aol.com

Jan 12, 2011 | 1988 GMC C1500

1 Answer

2000 ford expedition ,,rough idle in park..rough idle in drive,, sometimes dies..rpm's in drive at idle 400...replaced iac


Check the fuel pressure at the rail assembly, there should be a min of 40 lbs at the rails. Do you have any loss of power under a load? You may have an issue with your o2 sensor that is causing the ecm to send an improper signal to the engine ign/fuel map.

Dec 07, 2010 | 2000 Ford Expedition

1 Answer

96 eclipse non-turbo idles way too high, disconnect MAP sensor it goes down but then idles rough


Yes by disconneting the map sensor will drop idle and make run rough, the problem is the idle air control valve or a vacuum leak, try to clean the throtlebody with an old tooth brush and some throtlebody spray cleaner if that doesnt help then try having the iac valve checked the iac valve (Idle air control valve ) if with the engine running listen for a hissing noise that will be a vacuum leak, these are the most common reasons for higher than normal idle. hope this is helpful.

Dec 05, 2010 | 1996 Mitsubishi Eclipse

1 Answer

Some times it will start rough for a min then


clean throttle body and make sure iac is not plugged up with carbon.

Nov 09, 2009 | 1997 Oldsmobile Cutlass Supreme

4 Answers

1995 Chevy silverado with a 5.7. Was running fine i stopped at a stoplight and it died. It was hard starting, i had to turn the AC off to get it to start, then had to 2 feet it home. Now it starts and...


I have experienced this problem on similar vehicles. You should try and replace the coolant temp sensor. If it is not reading the correct temp to the ecm, it will not get the right fuel map. Also, the cts will not always throw a code.

Aug 04, 2008 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1996 Saturn SL Logo

Related Topics:

219 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

70365 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6878 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...