Question about 1998 Saturn SC

1 Answer

Electrical Problem with my 99 SC-1

I've had a 1999 SC-1 Standard for about seven months. Recently I started having a weird thing happen - It doesn't happen all the time but is increasingly more frequent. When I press on the brake, it seems to disrupt the entire electrical system. The interior and exterior lights blink, the ABS, Low Fuel and Brake lights come on and all the needles drop to zero (Speedometer, RPM, Gas). This only lasts for a second, then everything goes back to normal. Usually. Sometimes the ABS and brake lights stay on until I turn the car off and restart it. Then it will be fine until I need to press firmly on the brake again. If I make the car slow extremely gradually, that doesn't usually happen although the car seems to experience a more minor, momentary power drain. I would really appreciate any ideas or suggestions. I've taken it for a diagnostic once and they didn't find anything. I have the same problem with my 1998 Saturn SC-1!! Sometimes mine refuses to start and just clicks at me, but sometimes it starts up fine. Thanks for all of this info, I will check on these things tomorrow.

Posted by on

  • kurtonius Jan 07, 2009

    I have the same problem with my 99 Saturn SL2. Various electrical loads seam to cause the same symptoms you have (guages stop working, lightes dim, etc) including: touching the brake (after I haven't for a while, usually on the highway), turning on the rear defrost, and turning on the high beams.



    I also have a problem with my windshield wipers. They usually do not turn off until I shut the car off. I can increase the speed from slow to fast but intermittent does not work. Sometimes the wipers work fine though. I wonder if these two issues are related?



    Any help?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

U need to get fuse box checked it maybe melted on the bottom

Posted on Dec 16, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

5.3L dont want to start when cold but once its warm it starts everytime


Have you checked the fuel pressure regulator to see if its leaking?

Jan 26, 2013 | 1999 Chevrolet Silverado 1500

2 Answers

Will not go into 4th gear or uphill


Hi Msch, As your vehicle is a relatively late model I think it would be fitted with electronic transmission control modules. As you have lost power to the speedo and other circuits, you may have a problem with the speed and ABS sensors. The signals from those send command signals to the management system and control both vehicle speed and gear changes. Take the vehicle and have a diagnostic scan carried out. I believe the problem to be electronic and nothing to do with how much ATF is in the box. I do believe the electrical problems are related. Regards John

Jul 02, 2012 | 2003 Chevrolet Suburban

1 Answer

1999 dodge durango ticking from flywheel or torque converter


Sounds like the metal shield between motor and transmission it happen to my durango I thought it w as torx converter bolt coming loose It was my flex plate bent

Jun 20, 2012 | 1999 Dodge Durango

1 Answer

Would a lose serpentine belt cause wierd electrical issues inside car? Its a 1999 328i bmw (e46) the inside indicator lights not working, remote key stopped working


not real likely unless battery is goin dead and alt.is bad.Chech the small ground cable attached close to battery on the frame.i have had this problem recently and seen it happen alot.its a small black wire and usually their are sometimes other grounds to body at rear of engine.any of these can make guages act up then stop and headlights go out or all lights and speedometer stop.all kinds of weird things,dim interior light,dash light so on,hope you fet it.

May 25, 2012 | 2000 BMW 328i

1 Answer

My 99 saturn sc1 is having electrical problems. The tach and speedometer drop to zero then hesitate on the way up to operating speeds. The lights kinda of dim and then every thing runs alright for a few...


the first thing i would do is to have the computer scanned for codes, this will help in finding the problem,it could be a alternator or a short or a loose connection ,

Mar 31, 2010 | 1999 Saturn SC

1 Answer

'99 Dodge Intrepid with a weird transmission


This could be a number of things but my 99 ES had a bad speed sensor that caused similar problems. Your best to have a mechanic check and replace if needed.
Don't drive it too much before getting this fixed.

Jul 12, 2009 | 1999 Dodge Intrepid

2 Answers

1999 Saab 9-5 SE


I own a  99' 9-5 V6 turbo SE.  Had the same thing.  Started smelling gas in the car, sometimes.  Instead of not starting it died (as in the engine stopped) on a barren stretch of road at night.  Towed to the Saab dealer: Conclusion?  Replaced the fuel pump and sending unit. Don't ask how much.  

Nov 03, 2008 | 1999 Saab 9-5

Not finding what you are looking for?
1998 Saturn SC Logo

191 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...