Question about 1993 Nissan Altima

1 Answer

I have a '93 Altima an it starts up fine, but as it runs it-

Starts to shake really bad an acts as though it wants too cut off; and as I begin to drive it takes for ever to pick up speed, but as I get pass 40 it starts to run as it's suppose to. Any suggestions of what's the problem?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Starts to shake really bad an acts as though it wants too cut off; and as I begin to drive it takes for ever to pick up speed, but as I get pass 40 it starts to run as it's suppose to. Any suggestions of what's the problem?

Posted on Dec 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

93 altima same fuel injector goes bad 2 times in 1 month


how did you find out it is the injector causing the problem? the injectors are wired in series on these vehicles, it is possible that another faulty injector may be causing the problem. although it may be difficult to find if this happens intermittently. A scope test may be the only way to find the problem. Does the engine light come on with a misfire code on Cylinder #1? P0301 or r u just getting a random misfire code P0300 ? a bit more info on the vehicle may also be helpful........ engine size? # of cylinders 4 or 6 ?

Dec 06, 2013 | 1993 Nissan Altima

2 Answers

Replace instrument cluster


Is your speedometer or tachometer needle acting weird or giving wrong readings? If so it's probably the drive motors going bad, very common for sunfire instrument cluster and speedometers they all need replaced which isn't too hard if you have the parts and the equipment.

If not email me at fred@drspeedometer.com or visit my site at DrSpeedometer.com and I can fix it for you for a good price.

Feb 18, 2010 | 2004 Pontiac Sunfire

1 Answer

93 altima starts fine drives fine once it has been driven long enough for the engine to heat up maybe a 15 to 30 min trip it doesn't want to start back if shut off. sometimes it cranks and cranks other...


You most likely have a bad fuel pump. Very common symptoms your describing, If your handy try squirting some brake cleaner into the throttle body when this happens. If it starts you now know what to do. Also be sure the battery terminals are clean. Voltage drops can cause a fuel pump not to run or run ineffeciently.

Jul 14, 2009 | 1993 Nissan Altima

1 Answer

Starts fine, runs fine,then dies and wont start


This sounds familiar. If your car runs fine and suddenly begins to "shudder" or shake when you're coming to a stop and then dies, you probably have a VERY common problem with Corsicas, which is a bad torque converter. There is a very simple and FREE solution for this though. Take the air filter housing off and unbolt the bottom part of it, removing it completely. Aways underneath that you'll see what looks like a "plug", with 4 wires going into it. Just grab the wires and tug hard. That unplugs the torque converter and your problem will be solved. Trust me.

BUT, if your car doesn't die as I described, then I wouldn't mess with the converter though.

Jun 05, 2009 | 1992 Chevrolet Corsica

1 Answer

I am having trouble starting my 93 altima. I have


you have intake leak.bad spark plugs and wires.your fuel pump in gas tank.

May 13, 2009 | 1993 Nissan Altima

1 Answer

Engine shuts down


This is probably a bad fuel pump. Maybe the fuel pump is going bad gradually, wherein it will work now and fail after. Consider replacing your fuel pump.

Rate this fixya!

Mar 24, 2009 | Hyundai Motor 1993 Excel

1 Answer

1998 Altima Acceleration Problems


i would say your problem is in the timing

Jan 24, 2009 | 1998 Nissan Altima

1 Answer

Shaking 1992 Ford Explore


Sounds alot like a fuel delivery issue. I would first replace your fuel filter, make sure your gas isnt bad. Make sure your fuel pump isnt starting to fail. air leaks in the fuel lines. and then move too the fuel injection pump.

Oct 13, 2008 | 1992 Ford Explorer

1 Answer

92 honda accord engine problem


You may have a vacuum leak at the intake. Spray some WD-40 along the intake while it's running. If the car's idle changes you have a vacuum leak there. Replace the intake gasket. Your IAC valve (Idle Air Control valve) could be acting up as well.

Jul 01, 2008 | 1992 Honda Accord

Not finding what you are looking for?
1993 Nissan Altima Logo

Related Topics:

236 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...