Question about 1993 Subaru Impreza

1 Answer

'93 subaru impreza wont start

My car started an hour ago just fine with a little hesistance, i moved it and then tried to start it again and it will not start. my lights come on just fine and everything and the car is trying to come on but its not getting there. if this helps we are at zero degrees right now if that could be a problem.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

  • Expert
  • 58 Answers

If it's quiet enough, turn the key to the "on" position without cranking it, then stop and listen for a humming or buzzing sound. If you don't hear it, your fuel pump may be having issues.

Posted on Jan 04, 2018

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 117 Answers

SOURCE: 98 subaru impreza knock sensor

at the top of the block under the plenum runners.
please leave feedback
cheers

Posted on Jul 02, 2008

hasbensystem
  • 63 Answers

SOURCE: 93 subaru legacy starting problems

Probably a short or loose connection between battery and starter motor, or on either end of cables. Id look there before swapping out starter.On cold days you might put a heater under car for a few hours before using it,do this carefully as to avoid a car fire, or look into a block heater for your engine.

Posted on Dec 25, 2008

jayce1980
  • 19 Answers

SOURCE: subaru impreza uk model wrx stalls and low idle, hesition

try adjusting the throttle cable, its a case of loosening a nut, pulling the cable through a bit more and then tightening it back up, you find it on the right hand side of the engine block close to the exhaust manifold.

Jayce

Posted on Feb 27, 2009

blueextc3221
  • 15935 Answers

SOURCE: Subaru Impreza gas cap door won't open

If there is one - In trunk - directly behind the gas filler door - behind trunkliner (carpet)
The cable should not have any problems... use a partner to hold the door release and try and pry it open with your fingers.
The spring popper may be bad.
Try this if you dont have an assistant :D
48a4657.jpg
I had this problem with my STI -- easy to fix by bending the little metal on the inside of the fuel door that provides the spring action to open the door. 5 second fix


Thanks for using FixYa - a FixYa rating is appreciated for answering your FREE question!!

Posted on Apr 23, 2009

  • 1 Answer

SOURCE: subaru impreza automatic transmission won t shift

Try replacing the transmission filter and the trannie fluid. Mine would only go in reverse, and now it drives pretty well. This year has a screw on filter. Hope this helps

Posted on Apr 25, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Changed light bulb on 1993 subaru impreza now car won't start, everything lit up on the dashboard


1993 Subaru Impreza Won't Start! - NASIOC

forums.nasioc.com > ... > NASIOC Technical > Service & Maintenance
Sep 12, 2004 - 3 posts - ‎3 authors The car has been running fine, but recently in the morning especially, it won't turn over. I crank it and its trying to start, but there is no spark. Car won't start, cranks but no start. - NASIOC - North ...
19 posts
Aug 26, 2013
car wont start, getting fuel and spark - NASIOC - North ...
5 posts
May 22, 2012
HELP: Car won't start after timing belt change - NASIOC ...
19 posts
Sep 23, 2008
Weird starting problem--1993 Impreza - NASIOC ...
9 posts
Mar 4, 2003
More results from forums.nasioc.com

my 1993 impreza wrx wont start please help - ClubWRX.net

www.clubwrx.net/.../134323378-my-1993-impreza-wrx-wont-start-pleas...
Dec 5, 2009 - 7 posts - ‎2 authors can anyone help me, my 1993 impreza wrx wont start, 2 days ago i went to ...ClubWRX Forum - Subaru Impreza WRX and STi Community and ...

Oct 24, 2015 | 1993 Subaru Impreza

1 Answer

93 subaru impreza stalled wont start is there a reset for the roll over valve?


Generally speaking, only Ford products have an inertia switch.
You would need to check the fuel pump relay for power and go from there.

Apr 03, 2013 | Subaru Impreza Cars & Trucks

1 Answer

Brake lights won't work on 93 Subaru impreza. Fuse ok, bulbs ok. Brake light switch replaced 1 yr ago


Mr. Williams since you tried with fuse,bulbs and brake light switch with no success,why you do not try to check your circuit by using a tester and see whether you have any broken wire or bad earth?

Aug 16, 2012 | 1993 Subaru Impreza

1 Answer

Problem with 1995 Subaru Impreza I recently changed the plugs and wires on a 95 impreza after taking it for a spin i decided to clean terminals on the battiery when i went to start over it would crank but...


removing a battery terminal can often corrupt the CPU program in the ECM
first try using the scan tool to reset the ECM
check for cam sensor wires /loose connections from moving the harness around to remove the plugs

May 11, 2017 | 1995 Subaru Impreza

1 Answer

My 1993 subaru was starting ok but the ground wire came loose,iput it back on and it started then when i tried to start it again it only clicks but wont start


Something is still not right about the way it is grounded. Grounds can be a pain sometimes, check the ground again, you might try putting a little grease on the cable. This will help it conduct and prevent oxidization which can occur in a matter of hours. Also if it arched then you could have a carbon burn which will also keep it from making the proper connection. Again redo it and put some grease on it, works wonders sometimes. Hope this helps.
Gillight

Jul 22, 2012 | 1993 Subaru Impreza

1 Answer

I am needing to replace the fuel relay switch on my 1996 subaru legacy outback, where is it located?


my car wont start ive changed plugs and fuel pump and now ive been told it could be the relay switch but dont know where it is of if it is that any suggestions and my car is a subaru impreza 93

Jun 06, 2010 | 1996 Subaru Legacy

1 Answer

My 99 impreza turbo wont start.


FUEL PUMP MIGHT STILL WORK,BUT IT MIGHT NOT BUILD UP ENOUGH FUEL PRESSURE.ALSO COULD BE M A S,,,MASS AIR FLOW SENSOR,CHECK IT CLEAN IT,OR REPLACE IT..YOUR THROTTLE POSISTIONING SENSOR ALSO.IF IT MOVED OR FAULTY CAR NO GO.I HAD IT,REPLACED AWAY I WENT...OTHER SIMPLE IS FUEL FILTER

Dec 08, 2009 | 1999 Subaru Impreza

2 Answers

2006 Subaru Impreza. Oil warning light stays on dimly when starting from cold but fades as engine warms up to normal running temperature. I did an oil and filter change about 2 weeks ago. Oil level on...


No, just keep an eye on it to see it does not start staying on longer and longer. The oil pressure sensor my be a little off,and at worse the oil pump is a little weak. Just keep up on the oil changes.3500 miles max.

May 19, 2009 | 2006 Subaru Impreza

1 Answer

Car starts up runs for a little bit and shuts off an wont start


it could be overheating either cooling system or a electronic piece .
are you getting a check engine light ?

Feb 27, 2009 | 1996 Subaru Impreza

Not finding what you are looking for?
1993 Subaru Impreza Logo

Related Topics:

165 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

Marvin
Marvin

Level 3 Expert

83036 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22382 Answers

Brandon Johnson
Brandon Johnson

Level 2 Expert

251 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...