Question about Mitsubishi Pickup

2 Answers

L200 warrior turbo fault,drives ok for miles then suddenly no power engine light on, turn off then on all ok again

Posted by on

  • 2 more comments 
  • green160 Dec 30, 2008

    hi, i have the exact same problem, once you turn the ignition off and back on its cured again, please tell me if you have sorted this problem and how? cheers

  • craig E Jan 09, 2009

    Same Problem on my 08 Animal. Fault read Over Boost. Mitsubishi assist asured me there was no problem. I have covered 3000 miles and the turbo has blown Now waiting on the part as it is on back order to Japan.

  • srm-2000 Apr 02, 2009

    Drives ok for miles - engine then loses power - smokes - coughs - turn engine off - restart -all ok again !!

  • SADIK Jun 26, 2013

    mitsubishi L200 engine lack of power

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Iv only st come on here and seen this post i know exactly what this problem is. it's the waste gate in the turbo gets full of carbon and then over boosts itself and put on the engine management light and when you turn the key on and off it resets it. so what you have to do id take the turbo off and clean out the waste gate which is on the exhaust side and that will get rid of all your problems and the better you clean it out the longer it will last.

Posted on Dec 26, 2009

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

A turbcharger is a mechanical device and if it fails then it won't start working again after a switch off. Various sensors control the fuel supply & boost conditions. It sounds like another component is faulty and you need to access & read off any fault codes to point you in the right direction but It sounds like either a faulty injector ( which is causing the ECU to go into limp mode ) or a faulty EGR valve. Both of these faults would cause the symptons you describe. Hope this helps & good luck !

Posted on Dec 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine 4d56 loose refs and go to idle


If this is a fly by wire throttle, pedal assembly may be failing.

Jun 01, 2016 | 2011 Mitsubishi L200 2.5

1 Answer

Misfiring cylinder 3 & 4


Sounds like a bad turbo to me. When you "kick it in", the engine falters and you get black smoke for a while. What is probably happening is that the turbo is leaking oil into the intake air stream, putting it into the cylinders with the fuel/air mix and causing one of two issues. Either the oil is inhibiting the combustion process, causing the falter and the resulting poor ignition, plus the oil, is giving black smoke, OR, the oil in the cylinders is fouling the plug momentarily, resulting in the fuel/oil being passed into the exhaust stream, burned in the catalytic converter and exits as black smoke. If it runs OK except when under turbo load, have that thing checked out ASAP. And, as far as the light staying on, most faults will set permanently after they occur three or more times within a certain period of time. This is ti ensure that intermittent faults won't cause false setting of the light.

Feb 11, 2016 | 2004 Chrysler PT Cruiser

1 Answer

Car runs fine then power loss till switch of engine then ok again


You MUST have the electronic engine control module scanned for fault codes to even begin to diagnose the cause of this.

Apr 06, 2012 | 2004 BMW 320d Touring

1 Answer

Boost sensor code on my l200 warrior, with now smoke and low rev/power


Check for loose boost hoses or even possibly a bad turbo. The ECU also controls boost so could be a factor in boost as well.

May 13, 2011 | Mitsubishi Pickup Cars & Trucks

1 Answer

X type engine management light


Hi, it sounds like a fuel injector fault, its worth having it checked out.

May 13, 2010 | 2003 Jaguar X-Type

1 Answer

2003 Saturn L200. Car will turn over but will not


I have the same model. Congrats you made it over a 100,000 miles! Most of them failed after as little as 20,000 or around 78,000 miles becaue there was a design flaw in that the timing chain did not get any oil to it. I had the 78,000 mile engine. Mine failed while driving at 65 miles an hour on the expressway. Pretty much wrecked the engine. The problem with putting in a used engine is that no other type of engine will fit in this car and you can count on engine failure again at 20,000; 78,000 or from what you tell me after 100,000 miles. You would be better off investing in a down payment for a Toyota made here in America that gets over 50 miles to the gallon. I used to be an oldsmobile man and then reluctantly switched to Saturn but am fed up with GM completely now and all american car manufactures.

Apr 30, 2009 | 2003 Saturn L-Series

1 Answer

Loss of power and acceleration on Mazda 6 Turbo diesel 2003


I'm assuming that that smoke was more previlant while going uphill because that's when the turbo would be really spolling up to max psi. I would guess that if you really got on the gas hard and got the turbo going even on a flat surface, that you would notice the smoke too. The loss of power and the white/grey smoke are tell tale signs that your turbo is bad or starting to fail. Good luck!

Dec 30, 2008 | 2003 Mazda Mazda6

15 Answers

Mitsubishi L200 overheating


i have an l200 animal, i started getting the same symptoms, bubbling noises, over heating, water being discharged into the header tank, i had a good look around the engine,there was no oil in the water or water in the oil ( signs of head gasket failure) when the radiator cap was off and i revved hard nothing happened, no dip in water levels and no splashing out. i took the water pump off and the impellor had sheered off the shaft. fitted a new pump and its been fine, maybe all these cracked cylinder heads and warped heads are to do with the engine being run with the fault not being cured.

Dec 26, 2008 | Mitsubishi L200 Cars & Trucks

1 Answer

Hi, I have an 03 mitsubishi L200 Warrior diesel 2477cc, the engine management light comes on, if you switch the ignition off let it reset then start it again it goes off untill you drive again, there isnt...


hello mate if it has got lack of power it could have a split vacuum hose on the turbo actuator and there is 5 or 6 hoses at the back of the rocker make sure they are all ok and not split. it sounds like u have no boost so it would put a malfunction in the ecu cause the the boost pressure sensor would be reading incorrectly. 

Aug 03, 2008 | Mitsubishi Pickup Cars & Trucks

1 Answer

Saab 9-3 turbo problem!


Check the turbo waste gate lever.
Remove the rod from lever, check lever moves freely .

Jul 24, 2008 | 2004 Saab 9-3

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

3,924 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...