Question about 1991 GMC Sonoma

1 Answer

Starts but runs rough

I just replaced the motor in my truck and i have replaces the map sensor, and the temp sensor, and the o2 sensor, plugs, wires, cap, rotor, control module, and the coil pack. when i start the truck it runs just fine at an idle and when its cold. i can hit the throttle hard all the open and it does fine, but once its been running for about 5 min and you try to give it wide open throttle it starts to shutter kinda like its missing on a cylinder and then it backfires threw the tbi(carberator) and i cant seem to get it fixed and i really need my truck for the snow. so if anyone has any answers that could help me. it would be greatly appriciated. you can email me at sean_linde@hotmail.com thank you for your help

Posted by on

  • bosshawg1983 Mar 12, 2009

    starts great and revs up great but once it gets to running temp it starts jumpin and skipping then it acts like its not accepting fuel at all stalling out but not killing the motor. ive chanrged plugs wires distributer rotor button fuel pump fuel filter cut cat and muffler off and run straight pipes. throttle position control sensor is good map sensor is good injectors are good i cant seem to find the problem

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 2 Answers

This could be the fuel pump is going bad. Its not completely bad but isnt strong enough to prduce enough fuel pressure to make it run properly. I have the same truck and mine did this a while back. Its easier to take the bed off than to drop the tank. parts are only about $60 and take about an hour and a half to do.

Posted on Feb 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

2006 Chevy Trailblazer started to run rough in idle but only after it warms up. My mechanic got P0017 code on his scan tool and told me I needed to replace the Crankshaf and Camshaft sensors. Both sensors...


Bad coolant temp sensor or EGR valve stuck. You can remove and test temp sensor (the one for the ECM--has only one wire) using cold and then hot water and read resistance with ohm meter.

Jan 28, 2015 | 2006 Chevrolet Trailblazer Ext

3 Answers

Starts and runs fine.....rough runs, when you restart after warmed up


Sorry - I didn't see the vehicle information the first time.

Let me research this - i will get back to you soon.

Aug 03, 2014 | 1999 Subaru Legacy

1 Answer

Hyundai accent stalls


The O2 sensor code could be the answer. If the sensor is faulty it could be causing the fuel mixture to be too lean.

Jan 23, 2014 | Cars & Trucks

2 Answers

91 chevy 4.3 v-6 runs extremely rich when engine is cold gives codes 13, 33 and 54 I know what these codes are but I need to know is could the computer coolant temp sensor or the air cleaner temp sensor...


DTC - 13 Oxygen sensor circuit open or no activity
DTC - 33 MAP sensor circuit error (signal high indicating low vacuum)
DTC - 54 Fuel pump circuit low voltage

Start with checking the wire leads to the O2 sensors and MAP sensor. Look for any damages to the wire harness and replace any parts damaged or faulty.

The O2 and MAP sensor take reading and sends it to the ECM to recalibrate the fuel injector pulse to adjust the amount of fuel entering the cylinders. When there is an issue to the O2 sensor or MAP sensor and even both, the ECM will be set a a factory default to run rich to keep the engine running and at times the engine may not even run. Normal fuel to air ratio is 14.7:1 - 14.7 air to 1 parts fuel and at default it could be as high as 12.5:1. Good luck and keep me posted, be glad to help you get your truck running 100% again soon and please rate. replacing the thermostat and temperature sensor would also be a good thing since the 4.3 runs best at 190".

Jan 10, 2010 | 1991 Chevrolet S-10

3 Answers

1998 Chevy s10 4 cylinder running rough


One thing to check is the fuel pressure regulator.
If the diaphram is leaking it will cause gas to be pulled into the vacuum system causing lots of white smoke and extreme rough running.

Mar 03, 2009 | 1998 Chevrolet Cavalier

Not finding what you are looking for?
1991 GMC Sonoma Logo

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...