Question about 2000 Ford Escort

2 Answers

Fan/heaters not working

Heater and fan only worked on setting 3, but now fan not working at all!!! changed fuses but no joy! Help?

Posted by on


2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a escort finesse the temp gauge keeps going into the red and the heater is blowing out cold air. I have checked the resevoirs and they seem ok. can any one help

Posted on Jan 15, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has answered 20 questions.

  • Expert
  • 153 Answers

As the blower motor resistor begins to fail it will cause the loss of fan speeds one or several at a time. This sounds like your problem. I would begin by changing this resistor. Should be cheap, about 10 or 15 bucks.

Posted on Dec 14, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

Heater doesn t blow out any heat or air

If it is not blowing at all your problem is with the fan. It is mounted up under the passenger side. Typically about 6 screws hold on the cover and the fan is right under it. Pretty easy fix. When the fan is out I would test it first....after thought here...did you check the fuses?

Mar 02, 2014 | 1999 Pontiac Sunfire

1 Answer

Windows dont work

lost operators, manual.
sun roof, can be 3 things
motor. dead.
3 fuse boxes (iml looking on online fsm)
fuse box 3 contains, fuse 32 and 45.
fuse 32 runs , "IG2-SIG-15a)
roof, and
Radiator fan relay #1
Radiator fan relay #2
Radiator fan relay #3
A/C compressor relay
Seat heater switch (Driver side)
Seat heater switch (Passenger side)
Sliding roof unit
Blower motor relay

id bet it is not the fuse. see why? the blower, would be dead.
fuse 45: all is only S/R that is the label too.

this box is long and skinny
with 3 relays on left
2 fuse top
11 fuses, in horz middle.
10 fuses on bottom row. fuse 29 bottom right.
fuse 39 center right
and top 2 are 51 and 50 , left to right

Nov 26, 2013 | 1995 Jeep Grand Cherokee

1 Answer

No heater blower

The first thing I would try is checking the fuse. If no joy it could be your fan that is dead. Do you get any converting heat when driving?

Jan 25, 2013 | Chrysler Town & Country Cars & Trucks

1 Answer

20005 kia spectra no heater or defroster or fan working

For troubleshooting this problem,click the link below and follow the procedure :----
--------This will help.Thanks.

Feb 08, 2012 | Kia Spectra Cars & Trucks

3 Answers

Heater fan not working no fuse blowen

The heater fan motor itself could have gone bad and needs to be replaced.

Jan 18, 2011 | 2000 Ford Focus

1 Answer

1995 subaru legercy heater

there is a resistor located under the dash which controls the settings for the fan if this has overloaded or blown up the blower motor wont work

Jul 19, 2009 | 1995 Subaru Legacy

1 Answer

2003 GMC Envoy lower 3 heater fan settings quit working.

had same problem on my XUV. changed the blower motor resistor, located under passenger side dash. easy to change, works no problem.

Jan 20, 2009 | 2003 GMC Envoy

1 Answer

Lower 3 setting on heater fan quit working.

have the block resistor checked for the fan

Jan 20, 2009 | 2003 GMC Envoy

1 Answer

Heater fan not working in 05 Chevy Equinox

I suspect you also checked the fuses, some vehicles are double protected, especially since you usually have to remove the entire dash panel to get to the heater fan blower motor. It should be in the middle or under the glove box, should be located in a plastic box that has like a bell shape to where the motor is. check fuses then check wiring, and make absolutely certain the relay was the correct one that you changed, in a 3 year old vehicle the fan motor should not be bad yet.

Jan 09, 2009 | 2007 Chevrolet Equinox LS New Cars

Not finding what you are looking for?
2000 Ford Escort Logo

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts


Level 3 Expert

77947 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers


Level 3 Expert

5651 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides