Question about 1999 Jeep Grand Cherokee

1 Answer

No Power sometime, Engine Light is Flashing

Starts right up and runs fine, Few mins after running it loses all power, Put the Pedal to floor and acts like no fuel, no power. Drove 50 miles last night and no problem, On way back home, Seemed like no power, was able to make it back to town, but after getting off interstate, not much power to get through side streets. Left Parked over night, Started right up this morning and ran fine. Drove 3 blocks and then no power, put in neutral and reved up, seemed like no fuel. Parked it and came back 10 mins later, Started right up, reved up and had plenty of power. Totally lost.. Thought Maybe ECM or Catalytic converter.

Posted by on

  • Daniel4880 Dec 16, 2008

    I have the same problem, i changed the cat converter but no luck, runs great for a little while but jerks,and stalls like out of fuel.Please help?

  • Anonymous Dec 16, 2008

    I have the 6 cylinder.. ... Trying to find out where the fuel filter is.. Hate to pay a mechanic a lot of money this close to christmas

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jeep Master
  • 6,674 Answers

If fuel filter hasn't been done lately I would start there & if you can, have fuel pressure tested while your at it. You may have tired fuel pump but pressure test will confirm. If you recently filled up somewhere different last time you got gas, I'd also try some "Heet" or similar just incase you got a tank full with some water in it.

Posted on Dec 13, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

RUNS ONLY AFTER IT WARMS UP FOR 10 MINS


I had this problem with my 2002 Chrysler Town and country. and even thou the "CHECK ENGINE" light was never on, it turned out to be a bad oxygen sensor. I replaced fuel pump and fuel filter cause it acted like it was starving for fuel, but that was not the problem. Typically if an O2 sensor is bad, a code will come up and the "CHECK ENGINE" light will be on, but not in my case. I replaced both O2 sensors (upper and lower) and it solved the problem and has been fine since. By the way, I got both O2 sensors from a junk yard where you take parts off yourself. I marked them right after removing them so they would go into my van in same places. Much cheaper, used, and they are factory, OEM parts compared to the junk universal type O2 sensors, they sell at part stores. Plus the fact that u have to splce your wire harness plugs onto the universal type they sell. terrible that it didn't throw a code, but I heard that this happens at times.

Mar 09, 2014 | 1995 Chrysler Cirrus

2 Answers

Car had been running fine, backfired once and lost a little power momentarily. Parked 24 hours,started right up but backfired and died. Now starts easily but dies without intense pressure on gas pedal.


Sounds like it's fouled a spark plug this happens as the plug wires fail and the power goes to ground instead of firing the fuel. The timing belt could have skipped time but the engine may run smooly but have very little power.65158335.jpgThe plug wires will act like what you say too.340881376.jpgThe boots get electrcal holes in them and they fire to the head instead of the fuel mixture and then it fires sometimes and throws everything of and they run very badly or not at all.

Feb 24, 2011 | 1999 Ford Escort

1 Answer

Where is the fuel pump fuse located on a 1992 Oldsmobile 98 Regency? The Olds runs fine except after it's on the road for approx 2 hrs it starts to lose power even if you put the gas pedal to the floor....


hi,
It is under the dash on the passenger side. There are a few fuses and 8 or 9 relays
You have to remove the underside cover to gain access to the electrical panel.

good luck!!!!!

Aug 03, 2010 | 1992 Oldsmobile Ninety Eight Regency

1 Answer

Interminently Losing Power 97 Saturn SC2


Hmmm, as to on-again, off-again engine power, it may be the electrical connector that runs from the electronic control unit. Read this diagnostic article, as it seems similar to your situation:
http://yourhandymanzone.com/Your_Handyman_Zone_How_To_Pages_Vehicle_Car_Zone_Cars_Trucks_Vans_Engine_System_Engine_Abruptly_Quits_Periodically_While_Driving.htm

You might also want to read up on engine overheating since you say you seem to have that:
http://yourhandymanzone.com/Your_Handyman_Zone_How_To_Pages_Vehicle_Car_Zone_Cars_Trucks_Vans_Engine_System_Engine_Overheats.htm

Hope this helps!
Brad

May 26, 2009 | 1997 Saturn SL

1 Answer

Car losing power for a few minutes then starts running fine. happens often


replace fuel pump relay.if it still loses power. check fuel pump pressure.if all good scan it check for egr valve going bad.

May 25, 2009 | 1996 Pontiac Grand Am

1 Answer

Back firing missing no power


check your catalytic converter and muffler for obstruction. if you smell rotten eggs replace catalytic converter

Oct 28, 2008 | 2005 Dodge Neon

1 Answer

1993 Ford Tuarus Gl


have the catalytic converter checked

Sep 02, 2008 | 1993 Ford Taurus

1 Answer

Runs fine for a few


it might be the fuel pressure regulator, i have a similar problem with my 95 302. but mine just dies but starts right back up. i was told fuel may be evaporating out of the fuel lines, when it doesnt start the first try i pump the gas pedal 2-3 times and it starts right up.

Jul 17, 2008 | 1995 Ford Bronco

Not finding what you are looking for?
1999 Jeep Grand Cherokee Logo

319 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

63661 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...