Question about 1998 Lincoln Town Car

1 Answer

Cooling system leak

1998 Lincoln Town town car leaks antifreeze where the upper heater core hose attaches to the motor. The Threaded connection seems striped and the o ring is worn. Is the threaded connection replaceable or where it screws into replaceable? The threads on both are a fine type not coarse thread.

Posted by on

  • Anonymous Mar 13, 2014

    just had the upper hose replaced now this is leaking

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 659 Answers

Sorry they are not. The plastic intake has to be replaced. It is common on these engines.

Posted on Dec 14, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1998 lincoln town car ran hot then a brown liquid leaked out of the car what happened


IT'S your antifreeze it dosn't last for ever.
A Lincolin has a vary large block and cooling system .
Yours is an 98 thats means its 17 years old..
It might be time to flush this system check the raditaor and heater core water pump ECT .

Mar 05, 2015 | 1998 Lincoln Town Car

1 Answer

Where is the rear heater core located on a 2002 town and country minivan?


hi,
Generally, in motor vehicles, the cabin air fans get the warm air from the same hot water/coolant circulating through the engine.
Surely, the leaking staff is antifreeze from the air blower heater element like a radiator. check the hoses in case of breaking and their joint in case of loose clamps.

Ngosa

Dec 08, 2013 | 2002 Chrysler Town & Country

1 Answer

Its leeking water out of a hose and cant see what the hoese goes to


is it water or coolant? aside from the upper and lower radiator hoses the only other hose carrying coolant is the hearter hose that goes to the heater core.inside the firewall. if it is leaking at the heater core. or the core itself is leaking this is a major job. as the heater core must be removed and tested.

Aug 23, 2010 | 1996 Lincoln Town Car

1 Answer

What might be causing the antifreeze to leak on my 92' towncar


If the sensor that you are talking about is mounted in the water line then it could be the sensor leaking through it,pull the wire connection out and see if it has water in it

May 14, 2010 | 1992 Lincoln Town Car

2 Answers

2000 lincoln town car leaks antifreeze from behind the motor


the car is going to have to be inspected. it will have to be pressure tested to see where the leak is. there are several area's back there that can leak

Dec 21, 2009 | 2000 Lincoln Town Car

1 Answer

I smell antifreeze when automatic control system is on


There is a good chance your heater core is leaking, have the cooling system checked with a pressure check.

Jul 29, 2009 | 1998 Lincoln Town Car

2 Answers

Car leak


possible to be a few different things...one is a freeze plug on the engine block the other is a blown headgasket

May 17, 2009 | 1991 Lincoln Town Car

1 Answer

1998 lincoln town car


If you notice a 'sweet' smell, or windows tend to fog up, it's your cars heater core leaking. The heater core is located under the dash, passenger side, it's like a mini radiator. The cars cooling system directs hot coolant to it so you can have heat. To change it is an involved procedure.
If there is no evidence of the anti-freeze smell or windows fogging up, and u have been using your air conditioner, it would be a blockage in the drain tube from the a/c. The end of the tube is located under the car on the passenger side , behind the front wheel. The blockage needs to be removed, and will solve the problem. Let me know what u find Curt

Mar 18, 2009 | 1998 Lincoln Town Car

2 Answers

93 lincoln town car leaking antifreeze down back of engine


there is a small heater hose on the pass side rear from the firewall(heater core) to the intake manifold. the plastic manifolds have a tendency to split where the hose fitting goes into the intake. If that is where it is leaking the manifold needs replacement.

Dec 25, 2008 | 1993 Lincoln Town Car

Not finding what you are looking for?

Open Questions:

0 Answers

98 Lincoln TC,Cold starts fine ,runs good until warm, then shuts off. No codes,Cranks ok, have spark, PATS ok. No fuel pressure, cant hear fuel pump prime,New Fuel relay. jumped fuel pump - works. I do not hear fuel pump prime up, do not have fuel gauge, but pressing on valve in fuel rail- no pressurized fuel. Fuel regulator seems ok, not leaking / vacuum line dry as a bone. If I let it set for 15 min , it will start up again, but for a few minutes then dies out. If I let it set overnight it starts up perfectly and runs until operating temp is reached then stalls/stumbles, and shuts down. Vacuum is good while cranking, even with no start, Checked Inertia switch in trunk, it is not tripped. I have seen Ford TSB summaries' that mention issues like this , but I am not able to see to description. A point to add, the MAF sensor was cleaned, then I decided to replace it and did not make a difference. I do not have any stored codes, and the PATS is working fine, typical 2 second flash from and once key is inserted a 3 second steady light, then disappears. I have seen the TSB mentioning C103 Connector, it looks fine, I swapped out fuel pump relay with ac relay, still no difference.mention of wires around battery, do not know where to start. in dash service engine light and odometer is normal, seen other posts the say they only have lines, but mine is ok. the start of all of this , I washed engine with regular garden hose, ( not using pressure washer).also in the mean time, rear window defroster stopped working as well, can not say for same reason, but a mention.My problem started after washing engine. this is one of four Panther platform vehicles I owned with exact 4.6l w code engine, which I rinced down before. The only sensor I can think of is Oil pressure , or a corroded wire

Feb 27, 2017 | 1998 Lincoln Town Car

See all 1998 Lincoln Town Car Questions

1998 Lincoln Town Car Logo

342 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

67757 Answers

Fordexpert

Level 3 Expert

5367 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22005 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...