Question about 1995 Ford Escort

1 Answer

Alternator not working

What causes alternator to not work. New alt and battery and new fuses.

Posted by on

  • 4 more comments 
  • angiesal28 Dec 12, 2008

    mechanic and all connects are clean and tight

  • angiesal28 Dec 12, 2008

    even took a multimeter to check connections



  • angiesal28 Dec 12, 2008

    Belt is tight. new tention guide. He is checking it further. Checking wiring from plug. Can't find field curcuit or fuseable link. Alt is not outputting any voltage. Do you know where they could be located. Or what the problem may be?

  • angiesal28 Dec 12, 2008

    I have taken two new ones back already.

  • angiesal28 Dec 12, 2008

    thanks..they r hard to see. do you know where i could see a bigger one for no cost?

  • Anonymous Mar 18, 2014

    alternator is is working. is there a fuse or relay>

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 6,674 Answers

Who installed & tested after? All connections clean & tight?

Posted on Dec 12, 2008

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 3.2l. Why are battery and brake lights on?


was not on before the new alt,? is alt new or used.?
or came on only after the new ALT?????????
my guess, is 2 failures.! (one ignored and 2nd grew)
on with engine running, guess yes.
Good question and is same answer on all cars.
1: engine rpm too low, what is yours (below 80 rpm)
2: fan belt slips. bad tension pulley (weak and old???)
3: Alt bad, or its wires bad.
4: brake level low, (@MC) or hand brake switch stuck on, or other brake failures. a plenty, scan the PCM and ABS if you have ABS.
id not drive it with the brake lamp on (Savvy?)
the battery light is really the ALT charge lamp.
it glows anytime the Charge system can not charge the battery
if you drive far like that, the engine will stall and not crank.

5: the horn fuse power the alternator, so check the horn fuse
10amp , key on, 12vdc on both sides of fuse is needed/
fyi: the meter fuse runs the charge lamp, if said lamp is dead bingo.
6: fact 2, the PCM does NOT run the Alternator on the 3.2L .
7: alternator case not grounded right.
8: battery is bad, causing alternator to drop off line
9: battery cables bad, at the 4ends or they are bad.
10: the plug on the rear of alt is bad or its wires or pins rusty.


brakes:
the brake lamp has 3 inputs ("OR" logic) master cylinder level low.
the hand brake lever and the EBCM (electronic brake control module)
a technician unplugs each to see what causes the error.
if you unplug mC wire and hand brake wire
then the EBCM is UNHAPPY, scan it.

Jul 31, 2015 | Isuzu Rodeo Cars & Trucks

1 Answer

Ford f150 4.2 not charging put in new alt and batt


Fully charge your battery. Some years of Ford F150 had parts which would interrupt any battery drain to preserve the battery. This would include the charging circuit which was see as parasitic.

The Antitheft would also cause problems in the electric circuit.

The newer Alternators are not made to work as well as the old ones. If the new Alternators have to work too hard they will fail from overheating so a bad battery could cause the Alternator to never catch up.

Also go to Autozone.com for a free wiring and fusebox diagram when you register your truck online. Check if there is a inline fuse within the first 30" from the Alternator. Or check for a charging Relauy in the Powerbox diagram.

Oct 30, 2012 | 2000 Ford F150 Flareside SuperCab

2 Answers

96 cougar v8. new alternator, new battery. we worked on it all day at autozone. got a new battery and alternator. when we started it up and tested it it would go to 12.6v then fail. we tested the...


I had the same problem on my 96'. It ended up being the mega-fuse, which is located on the left side of the fuse box under a plastic cover that slides up. It has two wires running to it(one of which is the main wire from the alt to the battery), and two bolts holding it in. Hope this helps.

Apr 22, 2011 | 1996 Mercury Cougar XR7

2 Answers

My car won't start, you hear one click, but nothing, we have to jump it to get to start. The alt. and the batt. and the starter work fine.. Plus our headlights don't work.


If the vehicle need to be jumped then the battery is too weak to start the car.
1. replace battery
2. with good battery start car and check charging system If voltage reads below 13volts possibly the alternator is bad.

Check bulb in headlight ( do not touch the glass part of the head lamp)
a good way to check is replace one with a new one see if it comes on.
If not check fuse for the headlamps ( I am assuming you are talking about low beams)

Jan 01, 2011 | 2002 Toyota Camry

1 Answer

I have a 2001 chevy montecarlo it has a new battery and alternator but my battery is still not charging why might that be?


There must be a wiring problem or defective alternator, check all connections to battery and alternator also make sure to check the fuses, check for a bad fuse under the hood fuse box and also make sure the connections are good, there are fusible links on the alt or battery, check the power wire from alt to battery and then the small plug going to alternator,

Dec 19, 2010 | Chevrolet Monte Carlo Cars & Trucks

4 Answers

Is there a fuse in car or under hood that would stop the battery charging system fro working in 98 lincoln town car


yes there is a fuse, labeled alt fuse and its under the hood in the relay fusebox, if the car is not charging, then just check for power to the alternator, the small wire not the big one, good luck,

Dec 19, 2009 | 1998 Lincoln Town Car

1 Answer

2000 astro van Battery and alternater are both new and checked out to be in working order. I am only getting 12 volts charging with the motor running should be 14 to 15 volts. In desperate need of ideas of...


You may have a voltage drop in the battery feed to the Alternator through the fuse link and into the battery. Check the charge rate at the battery feed on the Alternator, it should be at least 13.8 volts, if it is, locate the fuse link and check it there on both sides of the link, if its still good, follow the cable back to the battery checking the voltage as you go. If you find that the voltage suddenly drops across a connection or the fuse link, remove and clean the connection or replace it if possible. If the voltage at the back of the Alternator is less then 13 volts, then the new Alternator may be faulty. If the voltage is higher then 15 volts, then the Battery feed to the Alternator is bad and MUST be fixed. Check these voltages with the engine running but watch out for moving parts ( fans etc). If you think the battery feed to the Alternator is bad, shut the engine down and recheck the voltage at the Alternator, it should be at least the same as it is across the battery. If there is no power to the Alt when the engine is off, start at the fuse link, checking for voltage and trace back to the alt until you lose the reading. If you get no voltage at the fuse link, track it back to the battery. The voltages at the battery and Alternator should be the same or only have a difference of half a volt, any more and you need to locate and fix the bad connection. DO NOT run the Alternator without the load of the battery for extended periods as this will damage the Alternator. The Alt needs the internal resistance of the battery to function correctly. If the voltages from the battery to the alt are correct, check the regulator wiring. If memory serves, there are two small wires to the alt which are in a small plug into the alt and one thick cable which connects to a bolt on the alt. The thick cable is the battery feed, the two small cables are the regulator feeds. One small cable operates the warning lamp in the dash cluster and the other is another battery feed which gives the regulator an indication of the charge rate AT THE BATTERY so if this one is missing the regulator will also cut out. The warning lamp wire serves as an indication to the regulator that the ignition is turned on and makes the alternator charge. This lamp should be on with ignition on but engine NOT running and should go out when you start the engine. If this lamp does not light up at all, suspect a broken or missing warning lamp connection or faulty regulator.A blown warning lamp bulb will also prevent the alt from working, this is because the bulb is fed with power and is grounded at the alt through the regulator and exciter diodes, feeding the regulator with power until the engine starts, then the alternator output essentially puts power to both sides of the diodes causing the lamp to extinguish. A diode is a one way valve for electricity and the regulator is inside the alt. If you suspect a faulty alt or regulator, remove them and have them checked by an autoelectrician. Unless you know what you are doing, DO NOT attempt to disassemble the alt as you can cause catastrophic damage and have to purchase a replacement alt. You may also void any warranty by disassembling the alt.. Undertake these tests and if you have any questions, email me here: swoop@live.com.au
Dave.

Dec 15, 2009 | 1997 Chevrolet Astro

3 Answers

Battery light comes on when I accelerate


Have you tried changing the battery.as they can cause that to happen if your battery has a dead cell.

Jun 29, 2009 | 1998 Ford Contour

2 Answers

Dead battery. Alternator is charging, but the juice is not getting to battery. 1998 Slk 230. There is a relay p/n 002 542 20 19 05 3905 00, by the battery, (G) from the alternator has 19.8 volts, battery...


19.8 volts is too high. the alt regulator is not working. The regulator needs a battery source feed to work. Both the feed for the regulator and the connection between the output post and the positive battery terminal should go through an ALT fuse. Start by checking that.

Feb 28, 2009 | 1999 Mercedes-Benz M-Class

2 Answers

2000 Ford Ranger Alternator


have the alt tested there not very good do you have 12 volts going to the big wire on the alt and with key on you should have it to a small wire going to the regulator to turn it on

Dec 10, 2008 | 2000 Ford Ranger SuperCab

Not finding what you are looking for?
1995 Ford Escort Logo

Related Topics:

59 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

63291 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...