Question about 1991 Mitsubishi Galant

1 Answer

Hard start mit galant gli 91 . start fine but after driving a few miles, hard to start after engine stop of a few minutes. Then start fine after waitng for 30-45 minutes. Replaced battery, spark plugs, ignition coil and wires.

Posted by on

  • Anonymous Dec 29, 2008

    after cooling the fuel pump it will start, replace fuel pump.

  • Adam
    Adam May 11, 2010

    If you shut the engine off and attempt to start it will the car start?
    Dose it take a while for the engine to start initially


×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

Fuel mix is too rich,check temperature sender.thermocontact,

Posted on Jan 31, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Diesel engine runs then stops then runs stops every few minutes


Mate I use to drive a freightliner and it cut out on me one day, I eventually got it started but cut out again after about 5 minutes, I rang a mechanic to come out and he found a heat sensor wire came off the radiator and that caused the motor to cut out... Hope I haven't wasted your time.......

Mar 09, 2016 | 2007 Chrysler Grand Voyager

1 Answer

I have a 2006 jetta gli turbo with about 82000 miles on it about four months ago the check engine light came on but nothing noticeable was going on with my car or the drive. recently when it started...


Hi

You need to go to a shop with a code reader. The check engine light was telling you something and you need a code reader. Depending on which country you are in, if in the states autozone may have it for free.

Whatever initiated the light is now messing up the other parts of the car.

Hope that helps.

G.

Feb 11, 2011 | Volkswagen GLI Cars & Trucks

1 Answer

Starts fine & stops in 3-5 minutes or driving in 1-3 miles.


Did you replaced your whole distributor or just the cap and the rotor? Have you check the pressure on you fuel line it could be your fuel pump.

May 16, 2010 | 1993 Plymouth Colt Vista

1 Answer

I just replaced my tranny. It was working great


About 3 months ago, during my 25-mile commute to the ambulance base where I volunteer, my transmission started acting up. After a few minutes of driving normally, it started to upshift very hard. Each upshift was accompanied by a noticeable "Bang!" and it felt like the car was hitting a pot hole.

I immediately stopped and checked the tranny fluid at a service station, but the fluid level was fine and it didn't have any burnt smell. The car has 76K miles on it and the transmission fluid was changed at 50K per the maintenance schedule. I had no choice but to continue on to the base, driving very gently.

I made a stop about 5 minutes before arriving, to pick up dry cleaning. I was in the cleaners for about 8 minutes, and when I came out the hard shifting had completely disappeared. The car drove smoothly for the next 3 months.

Now, this problem seems to recur any time I drive the car even remotely hard. We're not talking about full-throttle accelerations here, since my everyday driving stays below 2500 RPM to save on gas. But if I'm in a hurry and start driving a touch harder - crossing over 3500 RPM - then the tranny will start shifting hard within minutes. Let it sit for 10 minutes with the engine off, and the problem is gone again

Oct 02, 2009 | 1995 Oldsmobile Cutlass Supreme

1 Answer

Oil Leaks I have an 2003 Mits. Galant GTZ...with117K miles. My question is, i've noticed oil spots on the ground under the car, a burning smell when i've driven along with smoke. In addition to a squealing...


the seal will gradually start leaking more as time goes by and needs to be replaced, but in the mean time if u keep the oil full and it does not go below low line on dipstick you can drive with no engine damage. sometimes adding oil leak additive to oil will help , using a slightly heavier oil during warm weather will often help reduce oil loss and give you more time to get enough money to replace seal. If engine gets too low on oil it will cause major engine damage.

Jul 16, 2009 | 2003 Mitsubishi Galant

1 Answer

97 mit galant in limp mode and displays a flashing


try checking your transmission control module for burn't resistors or capacitors also try clearing your tcm by pulling the negative side of your battery off for bout 10 minutes and look for any fuses related to the tcm or ecm in your owners manual

Mar 13, 2009 | 1993 Honda Accord

1 Answer

'99 chevy Silverado Z71,5.3 engine.....will not rev when hot.....


try replacing your EGR Valve, or your Oxygen Sensor

Feb 10, 2009 | 2001 Chevrolet S-10

2 Answers

Hard starting after a few miles


You might Think About the fuel pump. I have a friend having the samw problem. Except hers is a Nissan p/u. I posted it in here. But so far no one is suggesting anything it could be. Thats why im thinking maybe fuel pump

Dec 11, 2008 | 1991 Mitsubishi Galant

2 Answers

Idle air control


all the sudden the check engine light came on and it started to idle funny and dying at stops. I had a diagnostic done on it and changed out the idle air control valve but it doent seem any different. and the check engine light is still throwing the same code. we adjusted the idle up so i could drive it with out it dying but it is still acting funny.

Sep 19, 2008 | 1997 Mitsubishi Galant

Not finding what you are looking for?
1991 Mitsubishi Galant Logo

Related Topics:

270 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...