Question about Mazda Protege

1 Answer

My car wont start! When I took my car yesterday, i noticed that the ligtht for the electrical system on the dash board was on.it never hapened before! Once the car was started, the light would turn off. after 45 min. drive, once I got home, I turn the car off, and by curiosity tryed to turn it on. Nothing! the radio, the lights, the wipers would start working, but when I would it the break the lights would go dim. The motor wont even try working, its not catching, not idling. I tryed again several hours later, nothing, and then tryed again today and still nothing! thanks for your help

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

Check your battery connections make sure they are tight. If they are tight, then you have a bad battery or alternator.

Posted on Dec 11, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 98 che y cavilar that had a lighter fire in the dash fixed wires that were bad car stil wont start


you need to talk to cheverlet i noticed they had alot of issues with your make and model of car and seems that they are famous for catching fire its the electrical system from what i had read.

Aug 17, 2014 | Cars & Trucks

1 Answer

95 Chevy suburban I thought I was having a fuel issue I noticed that my dash lights aren't lighting up it wont start when the do starts right up an occasionlly dies like loss of electrical


electrical yes.. check grounds ..battery chassis engine to firewall etc... easiest solution ...then all fuses ...advise porgress please

Nov 20, 2013 | Cars & Trucks

1 Answer

Chrysler Town & Country 2006 Electrical problem


Failed Battery is where I would start my testing

Nov 19, 2012 | Cars & Trucks

1 Answer

Key wont start car


probably similar system to fords smart lock. they have a module located under the dash on the left of the steering wheel. a common fix for them is to hit the dash in that spot & it will always go. Just call an auto elec & ask if it has something like the smart lock module, if that is the probable cause, then how much to diagnose & repair.

Oct 12, 2012 | 2003 Mercedes-Benz C-Class

2 Answers

My 2004 ford explorer wont start, theft light on dash blinks fast when key is turned on to start. all dash lights come on, just nothing to the starter. hear a clicking under dash fuse box thats it. what...


got a 2004 ford explorer it wont start but it turns over put fuel pump starter evap canister and purge valve it was broke,and a battery fuel filter,tac system and it still wont crank



Mar 27, 2011 | Ford Explorer Cars & Trucks

1 Answer

2006 susuki swift wont start


Maybe the security system was not set to valet when service was done. If the alarm was triggered for several times, the security padlock will engage.

Jul 06, 2009 | 1997 Suzuki Swift

1 Answer

2002 Jeep Wrangler intermittent total electrical system failure


sounds like a battery or ground connection problem , disconnect and clean the inside of the battery cables and the posts,tighter securely . If that doesn't do it remove the other end of the negative cable and clean the cable end and the metal that it bolts to.

Apr 08, 2009 | 2002 Jeep Wrangler

1 Answer

Golf


i took mine off yesterday to fit an aftermarket mp3 stereo in my mark 5 & what a hassle!!
it basically clicks in place so carefully undo the clippings by inserting some scissors or a screwdriver under the plastic bit & peeling it back. that will reveal two screws which you can undo.
then you have to lift the top bit which contains the vents for the heating system & try and force the clips back with that. pretty tricky but just needs a bit of force.
once this is done there are four other screws that need to be undone & the whole system just slides out...
easy once you've done it but then the big problem starts...
the connections are all different so you need to get some new radio & cd connectors to adapt the aftermarket stereo with the cars standard wiring!!!

Jul 12, 2008 | 2004 Volkswagen Golf

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

252 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6878 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...