Question about Mazda RX-7

1 Answer

Motor surges at idle - RX-7 Mazda Cars & Trucks

Posted by on

  • SteveSalinas May 02, 2009

    engine surges at idle and when accelerating/deccelerating.

  • perplexed11 May 07, 2009

    mine surges at idle but not in gear just replaced o2 sensor and tried reseting the computer by taking off the neg battery cable for about a min and its still surging

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 59 Answers

I would check the tps sensor.

Posted on Dec 10, 2008

  • hzyoears Dec 23, 2008

    I would check Idle Air Control

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Daihatsu Motor won't idle, but surges


Check for a vacuum leak around the intake or broken vacuum lines around the engine

Jul 30, 2013 | Daihatsu Rocky Cars & Trucks

1 Answer

Have a 94 astro 4.3 new gaskets block up. surges at idle no engine light. runs fine at all other speeds


Honda's among other vehicles are prone to having this surging problem. I learned a little trick that takes about 5 minutes to do and it has never failed to solve the problem. Take a 1/8 inch drill bit and just below the center of the butterfly on your throttle body, drill one small hole. The vehicle idle surges because the throttle body assembly is not getting enough air through it at idle. This will stop the surging. You only need the 1 hole drilled. Don't forget to stuff a rag or paper towel in behind the butterfly before you drill the hole. It will prevent metal shavings from entering your motor. (do this with the motor not running)

Nov 26, 2012 | Cars & Trucks

1 Answer

Got a 99 Nissan Altima 2.4, t-chain broke... replaced head and all t-components... start up surging idle and whistling off idle... engine runs smooth and great power off idle


the surging and whistling sounds like there might be a vacuum leak that is causing this.recheck all vacuum lines and surfaces were this is a gasket that seals a vacuum source.smooth running and good power off idle suggest this leak only affects the motor at a low(idle)rpm.

Apr 14, 2011 | 2005 Nissan Altima

1 Answer

1998 chevy k1500 vortec 305, high idle, surges a lil bit, new plugs cap and rotor, coolant temp sensor, any suggestions, bad tps cause this, or intake leak confused help,love the truck,runs rich i can...


TPS probably not cause surging idle. Could be IAC motor, could be MAF sensor. If you dont have a check engine light I would be thinking IAC motor.

Jan 21, 2011 | 1997 Chevrolet C1500

1 Answer

1991 Camry with 2.0 L, 4 cylinder. When it is warm


Early 90's had a thing called Idle Stabilizer valve.It should sit on the top of the motor,some models had it sitting on the side of motor.Anyway this part is about 4-5 inches long,abou 1-1.5 in diametar and it has vacuum hoses connection and electrical conection.I'n most cases,the diaphragm could be dirty,thus restrictin internal part to slide back and forward.If you are handy,locate the ISV and remove it.Use some brake parts cleaner( can use up to 1 can) and clean it good.When cleaned spray, just a spritz of of WD40 on each opening and reinstall it.If problem still persist, you will have to purchase a new one that will run you about $200-325 buck.Hope I could help.

Jan 05, 2010 | 1991 Toyota Camry

1 Answer

High idle, surge when idling


It's a failed idle air motor, fairly simple , get a new one first and it's just a few bolts and one wire plug, right at or near the throttle body

Good luck, if that doesn't fix it it's the computer

May 31, 2009 | 1991 Isuzu Impulse

2 Answers

1997 Nissan Hardbody has rough idle/surges/stalls


ok i have the same truck my timing was off 3 teeth but mine wouldn't kick out of high idle is y mine was surging but know with timing right no vacuum leaks i cant get it below 1400 but when a vacuum turns on it almost kills my engine any thoughts i know i got a vacuum line mixed up idk were though

Mar 13, 2009 | 1997 Nissan Pickup

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

401 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...