Question about 1990 Suzuki Swift

1 Answer

Suzu 500 running problem

I have a vinson 500 and it was running great and then i powerwashed the mud off and when i went to restart it it started right up on full choke but after awhile of idling i hit the gas and it just bogged down and wanted to stall. i checked the vent tubes and they seemed clear and the lower half of the carb was very clean. any suggestions

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I ended up taking the carberator off and found a piece of dirt in one of the jets, cleaned it out with break cleaner and put it back together and everything ran great.

Posted on Dec 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to install a drive belt on 2004 vinson 500


https://www.youtube.com/watch?v=A-iQiB7AtVQ

This video on you tube is on an artic cat but believe it's the same set up...Hope this helps...

Mar 26, 2017 | Cars & Trucks

1 Answer

500 vinson 2002 trouble with cooling system fan runs once in a while (overheats)


CHECK THE TEMP SENDING UNIT, THE RELAY, AND THE FAN ITSELF.

Dec 18, 2014 | Cars & Trucks

1 Answer

I have a 2003 Suzuki Vinson 500 automatic. The problem is it wont shift into reverse


The cable uner the car for reverse maybe broken or the connector may have "popped off" take to a certified trans shop for diagnostic.

Oct 03, 2014 | Cars & Trucks

1 Answer

2001 VW Eurovan Starts, Runs Rough, Loses Power, OK after Restart


have you tried reseting the computer
disconect the batery and wait 5 mins then re conect the baterie

Aug 06, 2009 | 1997 Volkswagen Golf

1 Answer

While driving my 2004 pt cruiser touring edition it went dead after I stop at a stop light; after about 3 times of trying to restart my car it finally started. I proceeded to the next stop light about...


If you have a "Autozone" in your area, go there and have them run a check on your alternator. It is free to do, and they will run engine error codes for you free of charge.

May 03, 2009 | 2004 Chrysler PT Cruiser

1 Answer

96 cavalier 2.4 starts runs great -chokes


Check the crankshaft position sensor. If the plug is loose or the sensor itself is bad it will cause similar problems

Aug 23, 2008 | 1988 Chevrolet Cavalier Z24

Not finding what you are looking for?

Open Questions:

1990 Suzuki Swift Logo

Related Topics:

337 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...