Question about 2001 Chevrolet S-10

2 Answers

No heat but still pumping

When i turn my heat on to either setting, it only blows cold air,
ive been getting mixed reviews as far as what the problem actually is, some say heater core others say its the temp. dial on the console,

its a 2001 chevy extreme pick-up with no accidents ect.
any ideas before i start ?

Posted by on

  • Mama Estes Dec 06, 2008

    I have a 2002 Chevy S10. It only blows cold air. This happened a few years ago and we replaced the water pump.

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 75 Answers

I am going to start with the obvious and make sure that you have coolant running through your system. Then I would check the hoses to the heater core and make sure that the switch or dial is opening and closing the valve on the line in to the heater core.

Posted on Dec 05, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,450 Answers

Feel your heater hoses I believe you will find one warm and one cool.this will indicate a blockage in core. remove hoses and blow back thru core from cool side. with water or air. remember it is gonna blow coolant everywhere so try and hold a rag over it. this is common a very tiny bit of trash will restrict flow

Posted on Dec 05, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Nissan Almera 2005 Model keeps blowing heat even when the switch is off. now when l turn on the aircon hot air is mixing with cold air. Could it be the blower resister?


Could be the diverter paddle control that moves to allow cold air or hot air into the duct. It may be staying in the heat position even when you set the control to cool.

Jan 02, 2015 | Nissan Cars & Trucks

1 Answer

HEAT ONLY BLOWING WARM AIR ON PASSENGER SIDE


have someone check the driver's side temperature control doors, in behind the radio. there are two push rods attached to a plastic piece. the connector on one or both of these push rods, become unattached. leaving you with cold air. once that temperature door is closed you get hot air. passenger side still mixes, but not drivers. All or none for heat on Driver's side

Dec 12, 2011 | 2005 Kia Amanti

1 Answer

I have a 2007 subaru legacy. it has 17000 miles im having a problem with heating.. when i turn the heat on only driver side blows hot. the pessenger side blows cold even when i turn it on to the winshield...


The air is mixed and routed inside the dash by some flaps. In your case the flap that regulates the mixing of hot and cold air for the passenger side is broken or stuck in the cold position.
The only way to fix that is to remove the dash , access the air system and fix the flap.

Feb 07, 2011 | 2007 Subaru Legacy 2.5i SE Sedan

2 Answers

When I turn on the heat in my 2004 mazda mpv the front air vents blow heat but the rear air vents are blowing cold. I have adjusted every setting is there something I am overlooking.


When I turn on the heat in my 2004 mazda mpvicon1.png the front air vents blow heat but the rear air vents are blowing cold. I have adjusted every setting is there something I am overlooking.

Jan 14, 2011 | 2004 Mazda MPV

1 Answer

Heat blows cold air replaced thermastate still blows cold air


Check the flapper under the dash. there is a vacuum module on the heater box. If it doesn't get enough vac, it can't close the door all the way and cold air will mix with the hot air. Or it will never get hot because it's not closing at all.

Oct 24, 2010 | Ford F-150 Cars & Trucks

1 Answer

I have a problem with the heat in my 99 4 runner. It takes a long time to heat up and reach normal operating temps, and even longer for the heater to start blowing out warm air. The worst problem is if the...


When was last flush and thermostat replaced? Also, it may sound crazy but, when I have a partially clogged heater core, which I suspect you do, I usually will disconnect the hose at the heater core, and connect a drill operated pump from hardware store (about $10) to the heater core, and circulate C.L.R through it before putting it all back together. I usually set it up to pump through the core and back into a pail or similar, and then reverse the hoses to allow flow opposite way as well, then I plug lower inlet to core, and fill with C.L.R, and let it sit overnight if I have time, just to clean out as much calcium clogged up in there as I can. Saved me replacing 2 or 3 heater cores so far, that had little or no heat at idle, prior to cleaning, but had good heat after.

Dec 22, 2009 | 1999 Toyota 4Runner

1 Answer

Ford Windstar SE, 3.8L V6, 1999, front seat heat/defrost is cold


the blendor actuators strip out the gear inside the actuator cases on these all the time. replace the actuator.

Mar 10, 2009 | 1997 Ford Windstar

2 Answers

Engine running cold ?


check thermostat it can be stuck open

Dec 11, 2008 | 1995 Subaru Impreza

2 Answers

Car heating system sudnely stoped operating


Does the car warm up properly?
Check the themostat.

Nov 17, 2008 | 1998 Jaguar XJ8L

Not finding what you are looking for?
2001 Chevrolet S-10 Logo

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...