Question about 2000 Chevrolet Venture

1 Answer

Blower fan Why does my high speed fan come on when the keys are not in the ignition in my 2000 chevy venture cargo van?Ihad to pull fuse to stop.The low speed fan still works on #3 setting.

Posted by on

  • 2 more comments 
  • cfraser812 Dec 04, 2008

    Thanks eagleeye for trying to help.My fan is located above passengers feet.I did a test again by putting high speed fan fuse back in and relay stayed off which is normal.Next i turn on fan switch to one nothing,two nothing,three low speed,four low speed,five high speed.I think the resistor is in the switch the reason one and two speeds are not responding.How do you get switch out off dash? Where is relay located sounds like under dash.If the points on the relay are sticking on when i turn it to high speed which i suspect could happen but it works every time i test it.I am thinking the switch and resistor are the same unit.There would be a lot of arching on resistor and the van is eight years old and in the north which gets a lot of use!!!

  • cfraser812 Dec 04, 2008

    Problem fixed!!



    I was wrong thinking the resistor would be part of the switch.That would be too easy!!This is how to trouble shoot this problem.On the passenger side directly above your feet is the blower. Remove the shroud and there it is.Behind the motor is a connector that plugs into the resistor. Disconnect this and we will do a test on the male end using a DC volt meter.With power on the ignition, you will check to see if the blower switch is working. If not, the unit has to be replaced.Here goes G has 12 volts all the time,E is ground.Put meter between G and E must read 12volts.Next you will check between B and E set switch to #1speed must read 12 volts,next A and E set switch to #2 must read 12 volts,next D and E set switch to #3 must read 12 volts, next C and E set switch to #4 must read 12 volts,next F and E set switch to #5 must read 12 volts.If the switch is good you have money in your pocket!!The resistor is the female end of the unit you unplugged the male connector from. There are three screws holding this unit in place that are hard to get at so take your time.When you get it out you will see the problem.This is why they are looking for a bail out!You can do an ohm test on the resistor with no power by following same directions as above.I replaced mine without testing because you can tell moisture ruined it.It was corroded.Probably the reason it would be put in the housing is to open a vent when air is warm and close for air conditioning. Why else would somebody put it in there?

  • fin66 Dec 29, 2008

    1,2,&3 setting does not work.

  • Anonymous Mar 29, 2014

    the van seems to be ok when you turn key it just doesn't do anything at all when you try to start

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 22 Answers

It sounds to me like your blower moter resister or your blower moter switch are going bad both are right under the hood next to the blower moter one has 2 witers on it the other has 4 it usuley on the pass side right near the window

Posted on Dec 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 venture blower motor won't shut off with the ignition


Could be something in the key switch I suppose. There is a high speed relay for the blower that gets power directly from the battery, but the other speeds should go thru the fan switch and get power from the key switch.

Jul 25, 2013 | Cars & Trucks

1 Answer

The fan in my 2002 GMC Savana cargo van doesn't work. I lost low, then medium speed, and finally the high speed.I checked the fuses and relays.I changed the blower resister, still no fan. The heat


Hi Jim, If the vehicle is fitted with climate control it will have electronic management. However it can be wired by someone knowing electrical circuitry to by pass the control. It will save you some cash but will need manual control. Make sure whoever does the job knows what he or she is doing. Have a happy new year. Regards John

Dec 31, 2012 | 2002 GMC Savana

1 Answer

I have a 2002 GMC Savana Cargo van with a a/c and heater blower that will not work. The problem started when I lost the low speed, then the medium, and finally the highspeed. Fuses and relays are ok.


You checked the fuse and relay, did you check to see if you had power at the resistor ?
American built vehicles control fan speed by the power circuit which goes thru the resistor. The high speed usually bypasses the resistor.
You may need a new blower motor or control switch.

Jul 20, 2012 | 2000 GMC Savana

1 Answer

Heater/acblower fan doesn't work on high. Other fan speeds work ok. what is the problem? It's a 2003 chevy astro van


Hi, check fuse 12 first. If it is good, you will need to replace the blower resistor. The high speed relay is built into the resistor. The resistor is next to the blower motor and looks like the picture below. There is a connector in the resistor and the 2-wire connector coming out of the resistor attaches to the blower. The blower is usually under the dash above the passenger's feet. You may have to remove a kick panel to see the motor and resistor. Please let us know if you have any questions, and thanks for using FixYa.

jturcotte_285.jpgjturcotte_286.jpg

Feb 19, 2011 | 2000 Chevrolet Astro

1 Answer

Front blower still runs when key is out of the ignition


it may be an ignition switch, I believe the HVAC goes thru the switch

Dec 18, 2008 | 1997 Chevrolet Cargo Van

2 Answers

Keyless entry


watch this video if the video dosent work go to www.vehix411.com to see the video " />

Dec 03, 2008 | 2000 Chevrolet Venture

1 Answer

Ac controls quit working blower fan is running on high all thetime. compressor is not working.


fan elays are under hood in black box by battery. 3 of them. 2 for high speed, 1 for low speed. Default is high speed when there is a probem.

Suspect maybe they shorted something out when fixing dent. Did they do any welding on the van? Connecting the cables to the body can sometimes send voltage where it's not wanted.

Nov 06, 2008 | 2000 Nissan Quest

Not finding what you are looking for?
2000 Chevrolet Venture Logo

474 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...