Question about 1999 Oldsmobile Alero

2 Answers

99 OLDS ALERO 2.4 IDLING PROBLEM

This 99 olds alero "chugs" on idle, have changed the fuel pump, fuel pressure regulator coolant temp sensor & plugs. What could be causing this???

Posted by on

  • 2 more comments 
  • Richard Reed Dec 03, 2008

    Car starts & runs fine when cold. Idles fast & steps down when eng rpm goes below 1000 at approx 800rpm eng idle goes up & down, up& down, up & down chugging but never dies. Pinch off fuel return line, idle smoothes out for approx 4 to 5 seconds then chugs again. Have removed pinch off & plugged all vacuum lines, does not change problem. Have used propane to try & locate vac leak, no vac leaks found. Have changed cam sensor, crank sensor, air idle control valve, throttle posistion sensor, throttle body, coolant temp sensor, fuel pump, f/filter, fuel pressure reg, regulator, coil cover, coils, ign module, plugs & plug boots. Checked all grounds.

    Regualtor seemed to make chugging less noticable but still chugs at idle. Engine code , random misfire. Have noticed on scan tool data stream injector pulse width 4.2 to 4.5 on all injectors. When I pinch fuel return line eng idle smoothes out for 4 to 5 secs 7 pulse width goes to 2.8 TO 3.0

    Have noticed ign timing while chugging is all over the place -4 to 21

    Pinch off fuel return line timing goes steady.

    Please help me, going out of my mind and going broke! Could this problem be fixed by having the computor flashed at dealer?

    your truely, desperate mechanic.

  • Anonymous Mar 16, 2014

    99 alero with 2.4l water pump needs replacing how

  • Anonymous Mar 20, 2014

    changed o2 sensors, injectors plugs, independent coil boots, air filter fuel filter fuel pump fuel pressure regulator man the list goes on. The alero will turn over but will not start

  • Anonymous Mar 29, 2014

    how to replace the fuel pump

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Intake manifold has a vacum leak or other vacum leak hose etc.

Posted on Dec 03, 2008

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

Mine did the same thing clean the air flow sensor aka maf sensor and use maf cleaner

Posted on Nov 02, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine and sensor diagram 99 Olds Alero 2.4


Abbey, Engine and sensor diagram 99 Alero 2.4. Check the attached links, Good luck,
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."
found this helpful answer from an oldsmobile mechanic on JustAnswer com
http://www.tonkinonlineparts.com/
1999 Olds Alero 2 4 sensor diagram Google Search

Aug 18, 2016 | 1999 Oldsmobile Alero

1 Answer

How do i know my ETS is on on my 99 olds alero


IF YOU TALKING ABOUT ENGINE TEMPERATURE SENSOR.MOST OF TIME WHEN IT GOES BAD.YOUR ENGINE WILL OVER HEAT.COOLANT FAN WONT TURN ON.I SEEN A BAD COOLANT TEMPERATURE SENSOR CAUSE ENGINE STAY IN OPEN LOOP.CAUSE POOR ENGINE PERFORMANCE.FUEL CONSUMPTION.

Sep 22, 2010 | 1999 Oldsmobile Alero

1 Answer

My 99 alero GL runs great...85,000


COULD BE GROUND PROBLEMS OR THE TACH GOING BAD.EVEN THOUGH CAR SEEMS TO BE RUNNING GOOD IDLING GOOD.SOME TIMES A SPARK PLUG MISFIRE.CAUSING A LITTLE ROUGH IDLING CAUSING TACH NEEDLE TO GO CRAZY.I SEEN ALTERNATOR WITH VOLTAGE REGULATOR GOING BAD CAUSE A POWER SURGE CAUSING HEAD LIGHTS TO DIM A LITTLE THEN BRIGHT WHILE ENGINE IDLING.THIS WILL CAUSE TACH METER NEEDLE BOUNCE AROUND ALSO.

Apr 03, 2010 | 1999 Oldsmobile Alero

1 Answer

Car wont start


FUEL PUMP MAYBE PUMPING BUT IT MAY NOT HAVE THE RIGHT PRESSURE........

Jun 27, 2009 | 2004 Oldsmobile Alero

1 Answer

Olds alero 2.4 idle fuel pressure


most likely idle air control sensor or low engine coolant I know sounds funny but IAC uses coolant to regulate idle. Idle air control valve or throttle body positioning sensor.

Dec 10, 2008 | 1999 Oldsmobile Alero

3 Answers

99 olds alero 2.4


I'm sure you have installed a fuel pressure gauge and monitored the fuel pressure while the problem is occurring?Another diagnostic tool which is easy to do,is while the problem is occurring,unplug one sensor at a time beginning with the Mass Air Flow first,.if it uses one.Many times,not always,depending on the sensor,if the sensor is taken out of the picture as far as what the PCM is seeing,like unplugging the MAF,the PCM will substitute the missing sensor output with a generic value that will allow the engine to at least run,and if unplugging for example the MAF,the engine idle speed returns to normal,you know you're onto the problem.You didn't mention if the engine ran ok other than the idle problem.As far as checking for vacuum leaks,i use something like brake cleaner or WD 40,more of a liquid,and it does sound like a vacuum leak.Plastic intake manifolds do develop nearly invisible cracks that open up more with heat.Revsisit the possibility.And as for the PCM,it is possible,but more likely a mechanical problem.Lastly,remove an O2 sensor or two before the catalytic convertor,run the engine and see if anything changes.Cheap way to verify the catalytic convertor is flowing and not restricting engine airflow,as i have seen bad cats cause misfire codes and strange problems.Good luck.

Dec 03, 2008 | 1999 Oldsmobile Alero

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

1,117 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...