Question about 1995 Mercury Villager

3 Answers

1995 mercury villager tach jumping - 1995 Mercury Villager

Posted by on

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 4,369 Answers
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi loftyair,
I was having the same problem this summer... I dismantled the esthetic garniture on the passengers front seat and the CD tower just over the middle heat blower. I had some bad grounds connections that was rusted. I found a new spot to connect it and voila! All my cluster was working!

Posted on Dec 14, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 94 Answers

Check connections at ignition coil under hood, also plugs at cuircut board at rear of gauge cluster.

Posted on Nov 30, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a mercury villager 1995 and need to know where I can get the bottom of the transmission tray.


Your Mercury Villager is so old (in vehicle years) you may have resort to searching through junkyards to find a used part.

Jan 28, 2015 | 1995 Mercury Villager

1 Answer

I have a 2000 mercury villager runs fine when first started in the morning but after several miles stats bucking and knocking worse when you try to excelorate bogs down real bad, could this be the knock...


do not change the knock sensor.

sounds like cam sensor in distributor is going. works cold fine, then as engine warms upo it starts going. is tach needle jumping too?

Buy reman rich porter on ebay for $200. sensor inside is not serviceable. common issue on 99-00.

go here


Gerry

http://groups.yahoo.com/group/villagerquest/

Dec 30, 2010 | 1999 Mercury Villager

1 Answer

1999 mercury villager sputtering real bad it started after we did a tune up cap rotor and wires, plugs. the van ran fine around town on short drives then we took a trip and now where stuck 16 hrs later it...


You have a bad cam sesnor in the distributor- for certain. Rich Porter on ebay has the best reman for $200. Guaranteed fix. 99 was famous for this, runs cold for 15 mintues then acts up and quits, tach usually jumps around too.

Go here

http://groups.yahoo.com/group/villagerquest/

Dec 19, 2010 | 1999 Mercury Villager

1 Answer

I can not open my 1995 mercury villager


no switch in van. Spray with penetratingoil & see if it loosens up.

Fixed back glass or does glass open? Handle on back glass?

Go here

http://groups.yahoo.com/group/villagerquest/

Jul 28, 2010 | 1995 Mercury Villager

1 Answer

Have a 1995 Mercury Villager that wont start have replaced the starter, battery, cables, switch, what else can it be please help.


I assume it won't crank. Are you getting power to the small terminal to the starter when someone turns the key? Can you jump power to it and get it to crank? It could be a bad neutral safety switch.

Mar 27, 2010 | 1995 Mercury Villager

1 Answer

Location of the engine diagnostic connector 1995 village mercury


The diagnostic connector is located on the engine near the starter. However, there are four connectors in that location and without pictures it would be difficult to determine which is the proper one

Mar 08, 2009 | 1995 Mercury Villager

1 Answer

95 mercury villager


Check fuse 26(10 amp) in the instrument panel fuse box.

Feb 17, 2009 | 1995 Mercury Villager

1 Answer

Smell of gasoline in cold starts


call a Mercury dealer and give him your 17 digit VIN number and ask him to check for any recalls. If yes, they are free,
Also, this site has files on most Villager & Quest problems.

http://autos.groups.yahoo.com/group/villagerquest/

Jan 19, 2009 | 1995 Mercury Villager

1 Answer

Tachometer not working on 1999 mercury villager


his problem is caused by the failure of the circuit board that operates the tach needle, you will have to remove the instrument panel then the tach from the panel and send it out for repair to an authorized Nissan electronics repair center, contact your local dealer for the name and number.

Dec 01, 2008 | 1999 Mercury Villager

Not finding what you are looking for?
1995 Mercury Villager Logo

Related Topics:

170 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

63242 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...