Question about 1997 Mercedes-Benz C-Class

4 Answers

1997 mercedes benz E320 acceleration problem

My car starts and idles fine but does not respond at all when I press the accelerator, even in park...I replaced the accelerator control module(under hood connected to accelerator cable) and spark plugs but that didn't help at all. I even replaced the fuel filter and checked all fuzes and found all to be good...What else could be the problem???

Posted by on

  • 2 more comments 
  • noivaw53 Nov 29, 2008

    Hi,

    Thanks so much for comments...No, my check engine light is not on but I do know I have pressure at the fuel rail port. Don't have a pressure gauge to check psi...

  • noivaw53 Nov 29, 2008

    Hi,

    Thanks Guys for your comments...I did notice this morning that the butterfly on the throttle body is not moving in response to the TPS...Does that make the throttle body assy a more likely culprit???

  • noivaw53 Nov 30, 2008

    To all the guys that reponded with help on fixing my accelerator problem...Thanks soooooo much!!!! I really appreciate all the comments. I went to Sears and bought an Actron OBD II Scanner and reset my computer and bingo, problem fixed...Thanks so much and have a great holiday season!!! God Bless...

  • michaelgall Feb 14, 2009

    1997 E320. does not respond to accelration. idles at 1200 in gear drops to 1000. replaced battery. per OBD2 Scanner no error codes. do i need to reset some value for some reason?

×

4 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 426 Answers

You may also have issues with your air flow meter.Generaly though this symptom is usualy a fuel pressure problem.This test may or may not work depending on wether the fuel rail is the problem or the pump.Squeeze the fuel return line at the back of the fuel rail and if engine improves the fuel pressure regulator on the fuel rail may be faulty.If no improvement its likely the pump.The best and most accurate test would be to use an inline fuel pressure tester.Can you hear the pump pumping up to pressure when you turn the ignition on?Usualy though the pumps fail but can be heard running but unable to maintain pressure.

Posted on Nov 29, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Pull fuse 19 first....
resets computer without buying scanner

Posted on Jan 23, 2012

  • aquaticx
    aquaticx Jan 23, 2012

    Had this problem after a totally dead battery .. Would not go above idle . So with the car started I pulled fuse 19 and the car died ....
    Reinserted fuse , restart and I have full power

  • RAYMOND CROSS JR Jan 03, 2013

    HI I RAN BATTERY DOWN, LEFT LIGHT ON, START MISSING BAD, WHEN I PUSH ON GAS

×

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 24 Answers

Hello / it sounds to me like the throtel is bad, if you accel and there is no responce and the vehicle idles fine and you replaced the other possible option that is the accel poss sensor / that works in hand with the throtel body , need to check for priceing they are kind of exp /and depends on the year you may need to replace the dme aswell .good luck

Posted on Nov 29, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 255 Answers

Hi if your check engine light is not on you migh have cloged injectors obstructing the passage of fuel,if the light is on this can be the trottle position sensor,TPS, also check the fuel presure,,C1

Posted on Nov 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 E-320. Why doesn't it start?


Do you have it in N -neutral?

97 E320 Engine Won't Start - MBWorld.org Forums

mbworld.org/forums/e-class.../298412-97-e320-engine-won-t-start.html
May 15, 2009 - Hello ladies and gents, I bought a 97 E320 on February with 82k miles on it. ... hours I got out of work and try to start the car, it cranks but the engine justwon't start running. ... Drives: 1997 s320, 1997 e320 ... Cognomen is in homage to the late great Janis Joplin "Oh lord won't you buy me a Mercedes Benz". 2003 E320 cranks but won't start...
Oct 20, 2013
E320 cranks over but won't start
Mar 9, 2013
HELP....KEY WONT TURN ,CANT START CAR
May 17, 2011
W210 won't start.
Feb 13, 2008
More results from mbworld.org

1997 E320 Wont Start - PeachParts Mercedes ShopForum

www.peachparts.com > ... > Tech Help
Jul 2, 2008 - My 97 E320 wont start. ... 1997 E320 Wont Start ... So, we know that any engine won't start if it has no spark or no gas, so that is where we have ...

1997 E320 Trouble Cranking - YouTube

? 0:31
https://www.youtube.com/watch?v=AJu0k_rRb_o
Apr 4, 2013 - Uploaded by Roy Carlsen
1997 E320 Trouble Cranking ... 1998 Mercedes E Class (E320)Start Up and Review 3.2 L V6 - Duration ...

Dec 10, 2015 | Mercedes-Benz E-Class Cars & Trucks

1 Answer

C280 1997 starts, idles for a while and then dies. When accelerating it dies also, what is wrong with this car?


i have Mercedes c-180 model 1997 the srs light remains on and air bag does not come on rather when dipper is used the srs ligh t light goes till the time the lever is pressed and th dipper does not work similary when tthe wiper lever is used the srs light flickers

Aug 19, 2013 | 1997 Mercedes-Benz C-Class

1 Answer

E320 Gear changes normal, acceleration poor due to


Check the turbo to see if you can manually spin it freely, If it does not spin freely or easily, your bearings may be frozen up on turbo

Aug 24, 2009 | Mercedes-Benz E320 Cars & Trucks

1 Answer

Accelerater problem 1997 Mecedes C 200 Elegance


hi,try to check the accelerator cable for free movement,or you may check the idle actuator spring or clean the idle actuator,ty

Mar 17, 2009 | 1997 Mercedes-Benz C-Class

1 Answer

2000 Mercedes-Benz Mercedes Benz E320 Cdi Automatic


have yor dealer check for updated software for your transmission or engine control modules

Jan 24, 2009 | 2005 Mercedes-Benz Mercedes Benz E320 Cdi

1 Answer

Engine over-revs between 2nd and 3rd gear


they did not install bands right needs to be rebuild bands need to be adjusted

Dec 05, 2008 | 2005 Mercedes-Benz Mercedes Benz E320 Cdi

1 Answer

Mercedes C200 just idling accelerator does not work


Try this. Turn the ignition to position 2 and leave it about two minutes(you should hear components moving/making noise under the hood). This should relearn the throttle stop(sounds like your vehicle lost synchronization). After that period of time, start the car and see if it helps. If not, then it will probably have to go to the dealer so they can use the computer to try and relearn it.

Nov 03, 2008 | 1997 Mercedes-Benz C-Class

Not finding what you are looking for?
1997 Mercedes-Benz C-Class Logo

2,181 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

yadayada
yadayada

Level 3 Expert

60667 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

164 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...