Question about 2006 Chevrolet Malibu Maxx

2 Answers

Speedo, tach, and fuel gauge stopped working for about 3 minutes.

Can you help?

Posted by on

  • 2 more comments 
  • jthoennes523 Nov 27, 2008

    How do you check the cluster fuse?

  • alheg1 May 11, 2010

    Are the gauge needles at 0 or stuck at an er-onus setting? Also did all three gauge go out at once or at different times?

  • yadayada
    yadayada May 11, 2010

    Fuses are in the fuse box

  • yadayada
    yadayada May 11, 2010

    Have you checked the cluster fuse?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

This problems accure in the Tribeca, some Acuras, honda Odessey, all those clusters use the same memory chip 93c66, if you mess up the programming, usually it happens when you trying to adjuste the mileage. You need to find a file from exact the same vehicle and load it into your chip. If your car is under the factory warranty and you try to take the car to the dealer and try to replace the cluster under the warranty they might install a new cluster with 0 miles on it, and put the stiker saying that the real mileage is what ever is on odo+ whatever you had before. That might affect your car value in a negative way

Posted on Jun 11, 2012

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 449 Answers

Check the instrument cluster fuse if its good change the instrument cluster.

Posted on Dec 17, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is there a fuse for the tachometer?


Most vehicles power the tach from the same circuit as the other instruments. So if the speedo and fuel gauge work the tach probably has power. May not have a ground signal from the engine computer.

Nov 19, 2015 | Cars & Trucks

1 Answer

2003 Satria, Tacho and Fuel gauge dont work . Fuel gauge comes up now & again low fuel light works. Tacho works now & again. But speedo and temp do work all the time.


It may be that the speedo and temp are mechanical, whereas the tach and fuel are electrical. Check fuse for inst. cluster for clean and tight fitment. Check electrical connection at back of inst. cluster.

Dec 09, 2014 | Cars & Trucks

1 Answer

E46 instrument cluster not working


jjshock how did you fix this problem

Oct 17, 2012 | 2001 BMW 318i

1 Answer

Tach & speedo not working


Had same problem with my 2000 dodge stratus 2.4 liter and transmission would not shift out of 1st gear. Solution was ignition fuse under the hood was blown, one side of fuse working, replaced 10 am fuse everything works, tach, speedometer, gas gauge and transmission started back to shifting.

May 27, 2010 | 1996 Oldsmobile Achieva

1 Answer

I've got a 1991 BMW 525i which has done 253,000 km. It's been a good car but, the instrument panel on the dashboard has gone silly over the past couple of weeks. When I first start the car in the morning,...


this is just a rough guess, but i think it would be the battery or the alternator. Some part store have testers that they will check both for free.

Aug 14, 2009 | BMW 525 Cars & Trucks

3 Answers

99 firebird tach, speedo, odometer, and hazards stopped working


Is there a wire you forgot to put on when hooking up the battery or did one brake off.Theres a loose connection some where there..

Mar 29, 2009 | 1984 Pontiac Firebird

1 Answer

My gauges (speedo,tach
the display is going out and will have to be replaced.with new or reman.

Feb 20, 2009 | 1998 Lexus Gs 400

2 Answers

2005 pontiac sunfire


I have the same problem.. i installed a toggle switch for the fuse so at least I can reset it while driving.. its still a pain so Im thinking my next step will be to drill a hole through the plastic and put in a small metal post to stop the tach from going past 7

has anyone taken theirs into a shop?

Nov 28, 2008 | 2005 Pontiac Sunfire

1 Answer

Gauges gone crazy


Could need new instrument panel cluster but check for corrosion as the instrument panel connector

Aug 11, 2008 | 2000 Ford Windstar

Not finding what you are looking for?
Cars & Trucks Logo

185 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...