Question about 1999 Mercury Villager

1 Answer

What Can I Do About a Rough Idle on a 1999 Mercury Villager?

I have changed all wiring. plugs Dist,with no results. what next

Posted by on

  • Anonymous Mar 16, 2014

    i have 98 mercury villager with a missfire code, i replace plugs ,wires,and the distrubetor

  • Anonymous Mar 26, 2014

    smell burn after i drove it today , engine shake .

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

  • Expert
  • 89 Answers

Check the timing, PCV, fuel filter, clean out the throttle body, air intake, and check the Exhaust gas recirculation system. Valve and all.

Posted on Nov 27, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i fix my Mercury Villager 2002 with random misfire?


How to Fix error code P0300 for random misfires on your car ...

diy-auto-repair.wonderhowto.com/.../fix-error-code-p0300-for-random-...
Oct 15, 2010 - How to Fix error code P0300 for random misfires on your car ... amisfire (code P0304) on a 1999 Mercury Villager 3.3L · How to Fix error code P0500 ... I reset my codes and it ran fine for a couple of days, then I started getting ...

(code P0305) on a 1999 Mercury Villager 3.3L - auto repair

diy-auto-repair.wonderhowto.com/.../troubleshoot-misfire-code-p0305-1...
Sep 7, 2010 - The vehicle is a '99 Mercury Village, 3.3L, with 150000 miles on it. The chief ... How to Fix error code P0300 for random misfires on your car ...

2000 Villager Misfire - Car Forums and Automotive Chat ...

www.automotiveforums.com > ... > Mercury > Villager
May 24, 2010 - 2000 Villager Misfire Villager Car Forums. ... i was told that the 3.3L engines of 1999-2002 nissan quests/ mercury villagers are INTERFERENCE engines! ... Hope the following may help, and I will post if my last fix works. ... I have a 1999mercury villager that is showing a random multiple cylinder misfire ...

Rough Idle - 2000 Mercury Villager - RepairPal

repairpal.com > Questions > Mercury > Villager > 2000 Mercury Villager
Repair the code issue, because your Villager has OBD-II which is a very helpful Diagnostic system. Upvote (4) ... My 1999 Villager was running poorly; rough idle, lack of power at highway speeds and the engine problem light indicated random miss-fire, etc. I had new spark ... Have code po306 cylinder 6 misfire detected.

P0301 - OBD-II Trouble Code - RepairPal


Dec 17, 2015 | 2002 Mercury Villager

1 Answer

When warm runs rough sets knock sensor code will hardly idle turn front cat cherry red car sat for a year put new gas in it when cold runs great


If the cat is cherry red as you say it is I would check the firing order or timing they may have crossed plug wires this will cause the exhaust manifolds to get red hot and glow let me know if this heled you and good luck.It definitely sound to be timing related or crossed wires.

Feb 09, 2011 | 1999 Mercury Villager

1 Answer

I have a 1999 mercury villager that has a slight misfire P303


First clean the MAF sensor with carb cleaner several times with spray.

Then spray short bursts around intake manifold connections to see if idle flares up. That is where leak is.

go here for more help

http://groups.yahoo.com/group/villagerquest/

Apr 23, 2010 | 1999 Mercury Villager

1 Answer

Idle problem on my 95 villager


run some fuel injector cleaner through your engine

Aug 28, 2009 | 1995 Mercury Villager

1 Answer

Car running rough when raining


check the spark plug wires, put water in a spray bottle and spray along the wires,especially by the coil,if the car starts to run bad or you see sparks, the wires are no good, hope this helps, Ray

Apr 03, 2009 | 1999 Mercury Villager

1 Answer

1996 Mercury Villager with idle problems


Make sure there is no vacuumm leak.
Check and let me know.Then i would be able to tell you all the steps for troubleshooting.
Thanks.

Mar 30, 2009 | 1999 Mercury Villager

Not finding what you are looking for?
1999 Mercury Villager Logo

Related Topics:

435 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...