Question about 2004 Saturn ION

1 Answer

Running bad at low idle

My 04 barely runs at a low idle and it sounds like it is missing. I removed the spark plugs and 1 was in really bad shape ( the iridium tip was no longer there) I replaced all the plugs and now it runs a little bit better ( it wont die) but its still running bad. Do you think it could be the coil pack under the ecotec cover? What is that silver computer piece on top of the engine just to the right of the ecotec label? I don't think its the fuel pump, I can smell unburnt fuel heavily through the exhaust and its kind of making a putt putt putt through the tailpipe like its not firing on all 4 cylinders.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

From my previous experience with this sort of the problem, it tends to be your vacuum intake is clogged. One way to check it is to pop the hood and take off your hose going to your throttle. Have a shop rag ready, turn your car off and look inside and find the silver plate throttle control. This plate lets air travel in. Push the plate until it is horizontal and wipe bedind it with your shop rag. Pull it out and see if you have a build up of gunk in there. If so simply go to O'reilley's or Advanced and purchase the intake cleaner. Maybe 4 or 5 dollars. Then just spray it in and wip it off. If the problem still persists it could possibly be the master cylinder. I do not know exactly how to see if it needs replacing but I'm sure and garage would check for free and give you a whopping estimate. Hope info was useful.

Posted on Dec 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Check engine light on engine acts as if missing new plugs wires and #5 spark pack missing again 6cyl 4x4 3.4 185000 miles


was it running this way before you changed the plugs? just a shot in the dark here possibly a defective spark plug, rare but not impossible. if it was running fine before changing them. Other wise I would take it to autozone and pull codes if it is P0350 #5 misfire we would use the process fuel, fire and compression. is there any engine coolant around any cylinders? Have you checked the coil packs? could be a bad coil pack. if no evidence of fluid around them proceeded to check for spark, fuel then compression. post back results or new post with more deductions. iis it no spark no fuel or bad compression.

Dec 25, 2014 | 1996 Toyota T100

Tip

How To Find An Electrical Engine Miss


One way to find an engine miss, start the vehicle, and with a pair of leather gloves, (so you don't get a jolt and you might want to remove each wire boot and reinstall with the motor not running, this will help ease removal of the spark plug wires when the motor's running, also spraying some WD-40 and twisting the spark plug wire boots will help in removal of the spark plug wire). You'll want remove 1 spark plug at a time, if the engine bogs down or idle drops, put the wire back on, go to the next spark plug wire, until you get to the spark plug wire that has no effect on the running of the motor when you remove the spark plug wire from the plug, that is the cylinder that has a problem. The problem causing this could be the spark plug (wrong spark plug gap), a bad spark plug wire, the terminal on the distributor cap, or even an internal engine problems i.e, intake or exhaust valves, bent pushrods, broken or weak valve springs, or bad compression rings on the piston. This will help you narrow it down to what cylinder it is. If removing all of them doesn't make much difference, there could be a vacuum leak, caused by a broken or disconnected vacuum hose or fuel delivery problems, plugged fuel filter, low fuel pressure, or a bad fuel pressure regulator.

on Mar 09, 2010 | Chevrolet Camaro Cars & Trucks

1 Answer

How do I go about removing a 1992 Toyota engine from the vehicle so I can overhaul or rebuild ?


First I would pull plugs if its missing ,it seems like only running on 3 cylinders ,you'll find spark plug all loaded up and fouled clean or replace with new.If vehical uses excessive oil peticularly on freeway, possibly just head needs valve guide seals.

Sep 26, 2014 | 1992 Toyota Tercel

1 Answer

04 f150 misses on idle


Start by replacing the spark plugs and leads. Before doing so check that the problem is not simply a loose spark plug lead that has come away from its connecting point.

Dec 21, 2012 | Cars & Trucks

1 Answer

04 jaguar xj6 misses and no power after a couple miles


You are equipt with a ignition control module,located near the A/C pump when this fails the vehicle stays running and wont accelerate, but will stay at idle,

Mar 17, 2012 | 1994 Jaguar XJ6

1 Answer

1990 cavalier runs rough(misses)really bad at low rpms,gets over 1500 and smooths out totally,but barely wil pull in gear(almost impossible to drive)


I would guess that one of the coils on the back of the block is bad. Do you have spark on all four cylinders?

Jul 02, 2010 | 1990 Chevrolet Cavalier

1 Answer

Idle problems


Was it doing this before the installation of the tune up,or just afterwards?If it just started,remove the spark plugs and regap them.

May 23, 2010 | 1987 Isuzu I-Mark

1 Answer

Rough Idle and missing at low rpms on 2003 Ford Ka


make sure you put the right plugs in the fault is most likely the coil pack follow the plug leads from the spark plugs and you will reach the coil pack about £60

Oct 28, 2009 | 2003 Ford Escort

1 Answer

96 ford taurus ran fine yesterday go on 25 mile trip half way through trip engine runs ruff. Like miss firing just changed plugs about two weeks ago it idles ruff but runs doesnt stall at all. baffeled


sounds like spark plugs or spark plug cables are bad and it is in fact misfiring this happened to me in my car and my spark plug cables were bad

Aug 29, 2009 | 1996 Ford Taurus

2 Answers

Still missing


hi there i seems that you have replace alot of components after driving for a few days to let the ecm relearn with the new components . is it still missing at low speed ? seems you may have a spark plug thats not offering up its full potential please isolate what plug is the weak one by removing one spark plug wire from plug at a time to listen to the engine and see what plug is causing miss ok good luck you could replace all but this is an extra expense take a look

Jul 26, 2008 | 1991 Daihatsu Charade

Not finding what you are looking for?
2004 Saturn ION Logo

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...