Question about 1990 Chevrolet S-10 Blazer

2 Answers

Flat at acceleration, wont idle

Engine cranks o.k. but goes flat under acceleration, light acceleration engine runs fine truck has set up but has some fresh gas in it. 4.3 fi

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

)3 Chevy Avalanche cranks but don't start , So I put in new plugs, wires ,and fuel filter. odb codes were po171,p0174 bank 1nad 2 are lean..took to mech said 15lbs of pressure need 60lbs so he said I need a fuel pump $930.00, how can I be sure he isn't lying and it wasn't a bad MAF sensor or something..?..HELP

Posted on Mar 30, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 94 Answers

Check the fuel filter to make sure it is not pluged up, also check fuel presure, if its ok you possibly have a pluged cat. converter.

Posted on Nov 26, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1997 dodge ram 1500 4x4 abs light on runs fine idles good but put it into gear wont go past 35 mph engine running smooth even at 35 mph


Bernard's Blog: Dodge Transmission Output Speed Sensor

bernardsblog.blogspot.com/.../dodge-transmission-output-speed-sensor.h...
Sep 8, 2009 - My 99 Dodge 2500 Ram won't accelerate..transmission is NOT slipping,.... It has been running fine and the check engine light even cleared itself yesterday.... So it wouldn't go into first gear and then 3 minutes later my check engine ... I have a1997 Dodge Ram 1500 with a 5.9L instead of the stock 5.2L. It ...

Dodge Ram Idle and Stalling Problems - Car Forums at Edmunds.com

forums.edmunds.com > Dodge > Dodge Ram Pickup 1500

Aug 17, 2011 - 30 posts - ‎25 authors
Learn more about Dodge Ram Pickup 1500 at the Edmunds.com ... The crank sensorwas put on however it started stalling again. ... The truck starts fine, but will only runat 2000's RPM and only then if .... Then as I start driving about 1/3 of a mile go dead again, I knockout of gear, crank back up immediately.

WILL NOT GO OVER 30MPH WITH PEDLE TO METAL ...

repairpal.com > Questions > Dodge > Charger > 2006 Dodge Charger
I WAS DRIVING FINE AND THE CAR ACTED LIKE IT GOT STUCK IN ... Then the transmission didn't want to change into 2nd gear. .... Whenever i start up my car theabs and esp light turn on and when i try driving it doesnt go over 30 mph even .... in neutral but not it just wont go up hills and i think it has something to do with

Jan 07, 2016 | Dodge Cars & Trucks

1 Answer

2005 Dodge Ram 1500 4.7 Engine. Starts fine, Idles fine, but when engine shifts into high gear and RPM lowers engine runs really rough under load


Have you checked for a broken valve spring. Repaired a dodge engine with the same running issue as you have described and it was a broken intake valve spring.

Feb 22, 2015 | 2005 Dodge Ram 1500

1 Answer

I have a 97 grand am gt with 3.1 idles fine but normal acceleration and cruise is nearly impossible. Bogs down at all speeds. Hard acceleration is fine goes good.


I had the same problem with my 89 grand am it was caused by a faulty crank position sensor. Initially it would cut out when accelerating and eventually wouldn't start at all, replaced the sensor runs great again.

Aug 22, 2010 | 1997 Pontiac Grand Am

1 Answer

In park the engine dies; only will run if given gas


It sounds like there is a problem with the Idle Air Control (IAC) valve. Its job is to open and let air into the manifold when the throttle is closed at idle. If it does not open, the engine dies at idle. The IAC is mounted on the throttle body. Possibly the valve is clogged or stuck, in which case it could be ok again if it is removed and cleaned. Or it is broken, and needs to be replaced. Or, there is a problem with its electrical connection, that needs to be traced. Good luck, let me know if you have any questions.

Mar 30, 2010 | 1993 Chevrolet Lumina

1 Answer

Car hesitates and sputters


It seems like you have a vacuum leak in a hose some where. Check under the hood for any rubber hoses that are dry-rotted, cracks, or sharp bends in any of them.

Aug 21, 2009 | 2004 Dodge Neon

1 Answer

1993 (2.0l 4 cyl) Ford Probe Wont Idle when warm.


Josh, Did you output the car's diagnostic codes before you reset the computer?
Just to confirm: your car has the "FS" engine - 1991cc double overhead cams?
built on the Mazda "GE" platform?
does your car have an "engine check light" or "MIL" on the dashboard? if so where and what does it look like and what does do ? ie: comes on when ignition is turned on & goes out after engine starts. or comes & goes out after x seconds. etc etc
are you 5sp manual or auto trans?

does your car have a diagnostic plug with a flip open lid just behind the battery near the front left suspension tower?


Mar 12, 2009 | 1993 Ford Probe

1 Answer

1997 chevy 2500 4x4 stumbles


Fuel pump is most likely the cause. Probably just barely making the required pressure to start. Needs to maintain 60-66 psi while cranking to start.

Dec 21, 2008 | 1999 Chevrolet Silverado 1500

1 Answer

1998 honda crv misfire code 0303and 0304


problem solved mechanic had wires on wrong thanks

Nov 15, 2008 | 1999 Honda CR-V

1 Answer

Engine over revs at initial start up without touch accelerator. Shut down and restart, sometimes problems goes away.


it all depends on what yr the ford is b/c my grandmas car dose it a lot when you go to shut the car off make sure it is in park and it is in a idle then when you start it it should be fine if not go under the hood and see if it accelator can be lossened a littel bit if so it will save you on gas and the idle wont be as high. if that dose not work then dont worrie about it it wont harm the car any and dont pump the gas pedall while the car is not running

Jul 09, 2008 | 1999 Ford Taurus

Not finding what you are looking for?
1990 Chevrolet S-10 Blazer Logo

275 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...