Question about 1993 Mazda MX-3

1 Answer

WON'T START - BATTERY DOES NOT APPEAR DEAD.ALIGHTS AND RADIO WOR

WAS WORKING FINE. sTOPPED AND DID NOT ATTEMPT TO START UNIL ABOUT 25 MINUTES LATER. wEATHER WAS CLEAR AND IN THE 40'S.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 94 Answers

It sounds to me like a starter contact problem, most likely starter assembly will need replacement

Posted on Nov 25, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Battery problems. First the radio stops working, then a few days later the car will not start.


You may have loose or corroded terminals at the battery, that will affect the alternator's ability to charge, affect all electrical components including the radio. So you end up with radio and starting problems.

Mar 03, 2015 | 2001 Chrysler Concorde

1 Answer

Battery died for no reason


About the only thing you can do is disconnect the battery and connect them again after 5 minutes. If that do not work check for blown fuse. Other than that then the XM radio has been damaged by the charger.

Nov 14, 2009 | 2006 Buick Lucerne

3 Answers

Dead battery, replaced and car still wont start, alternater good


check all your connections at battery and make sure they are clean and tight

Oct 22, 2009 | 2002 Jeep Liberty

1 Answer

Is it my battery?


well this is what you should try ,,jump the car get it running
then when its warmed up take the positive lead of the battery
if the car stops the alternator is gone (thats what charges the battery) if the car runs its fine

and if u have put another new battery in it and the alternator is fine look for any broken wires earths or positives that could be making it drain so quick
and make sure your battery levels are full
hope this helps

Jul 02, 2008 | 2001 Mercury Cougar

Not finding what you are looking for?
1993 Mazda MX-3 Logo

Related Topics:

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6879 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...