Question about 1995 Oldsmobile Silhouette

1 Answer

95 silhoute 3.8

Starts up ok..can drive a block,a mile, 10miles or 20miles,......then the engine dies. could be in town or at hi speed ,the engine just dies. after 4/5 minetes , i can start up again not noing when the engine will die. need help




joe, spring valley ca

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Start out simple,look at your gas cap to see if the vent is plugged,after that have the crank sensor and electric fuel pump checked.If your check engine light went on have the code looked up that's on the computer.Some auto parts stores do it for free(Advanced Auto where I live).

Posted on Nov 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Vehicle is started while in neutral then is engaged to first gear and this is when the vehicle die


I must assume the car is a A/T automatic transmission?
Ok this is called stalling.
the one key fact is missing, can the fast right foot , make the car
drive fast up hills. that is you prevent the stall and drive.?
lacking this fact, makes all below too long........

the 95 sidekicks cam with 2 engines.
one is TBI 8v and other is 16v MPI, the repair is totally different on these cars, due to vastly different EFI systems.

so i will answer in the generic , lacking these facts.
1: idle speed controls dead.
2: engine problems, (low compression)
3: never ever tuned up? never did the 60,000 mile service.?
4: same as #3 timing belt slipped,
5: spark parts never replaced. plugs, wires ,cap, and rotor.?
6: weak fuel pressure do to never changing the fuel filter ever.
7: clogged injectors.
8: if MPI engine, huge air leaks in the induction (from behind the MAF all the way to the intake valves.. bad news on MPI , air leaks.
aka: vacuum leaks.
just a short list. for now.
got tool;s?

Aug 23, 2013 | 1995 Suzuki Sidekick

1 Answer

I have a 95 honda civic it has a drive 4, drive3, 2 and 1 so which do i use oh the highway


Hi,
You would use drive 4 for highway driving.
Drive 3 is good for in town driving with stop and go traffic.
Drive 1and 2 are for snowy and muddy conditions at slow speeds.
Enjoy,
Wayne

Jul 19, 2011 | Honda Civic Cars & Trucks

1 Answer

Hi, 1997 monte carlo that idles, but cuts out when put in gear, or at times while driving. 3.1 engine. 184,000 mi.


I don't have an answer for you, but I do have a similar or maybe even the same issue with mine. It usually starts up fine, and idles and runs fine when first started, however a few blocks or a few miles down the road it starts to cut out on me, sometimes dying completely... throwing it into neutral and pumping the gas usually will keep it running. This has gone on for a couple of months. When it does die, It normally will restart after sitting for a few minutes. Then a couple of weeks ago it died on me (normally this happens when slowing down and coming to a stop,) and would not restart even after a 1/2 hr, I had to have it towed. I periodically attempted to start it for over a week, it would turn over, but nothing more...then someone suggested that I disconnect the auto start box...It started right up. However, it still continues to cut out when slowing or stopping unless thrown into neutral and pumping the gas. It seems to run better on the open highway, than it does in town with all the slower speed and stop n go. I bought this car used about 6 mos. ago, and considering it's age and the 135K miles on it, I don't want to put any more money into it. I just read there is a recall on this vehicle for the fuel pump and additionally the fuel assembly, I'm not sure if this would be the answer to the whole problem or not.

Dec 30, 2010 | 1997 Chevrolet Monte Carlo

1 Answer

1990 Honda Civic Lx,- car dies in drive, in park on heating up


sounds like it could have ignition module failing,also possibly coil starting to go.I seen same problem on 92 hatchback,put module and coil on and runs fine.goodluck...

Jul 07, 2010 | 1990 Honda Civic

4 Answers

Truck doesn't want to drive,


iiT SOUNDS TO BE THE maf sensor. test and or replace. 1st swnsor coming out of air filter.

Jun 14, 2009 | 1989 Dodge D150

2 Answers

My 95 chevy blazer fuel preoblem i think


Check the Fuel pump with a presure guage.

Apr 21, 2009 | 1995 Chevrolet Blazer

1 Answer

Car Engine Shat off every 10miles


COOLANT TEMP SENSOR GOING OUT AS VEHICLE GETS TO OPERATING TEMP THE SENSOR TELLS ECU IT IS HOTTER THAN IT ACTUALLY IS.TYPICAL PROBLEM

Mar 23, 2009 | 1995 Toyota Camry

1 Answer

Miss fires catholitic converyor gloss red


Your cat is plugged, its not letting your exhaust leave the engine thus causing all these problems. You need to get it changed as soon as possible. You can get a shop to put in a universal one they are usually very cheep but do it soon. They can get hot enough to start a fire as you have already seen.

Dec 17, 2008 | 2003 Saturn L-Series

Not finding what you are looking for?
1995 Oldsmobile Silhouette Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...