Question about 2000 Pontiac Sunfire

1 Answer

Oil instument cluster light

Oil light comes on when car idels between 550 and 700 rpm and then goes off when i excelerate the throtle

Posted by on

  • b3poj2d2
    b3poj2d2 Oct 23, 2012

    correct me if im wrong but the only unit i know that sends oil is called a oil pump,wtf is a sending unit?and if you mean oil pump,why confuse people with overboard words for pump

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 260 Answers

Of course start with basics, does it have plenty of oil and what condition is it? is the engine noisey?(ticking/knocking?) if oil is full and clean and no engine noises, maybe try new pressure sending unit. verifying oil pressure with a guage at sending unit port would not be a bad idea.

Posted on Nov 22, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2005 jetta with a v6. the car jsut started to have aproblem where it would not accereralte above 3000 rpm. this startd jUST AFTER I HAD THE OIL CHANGED


EPC AND THE LIMITED RPM IS ONE ISSUE CAUSED BY THE THROTLE VALVE CONTROLER.CHECK IF CONNECTOR IS IN PLACE.CHECK OIL LEVEL ALSO JUST TO BE SURE.CHECK FOR CORRECT FIT OF THE OIL PRESSURE VALVE ALSO.ASK THE MECHANIC THE TYPE OF OIL HE USED.LET ME KNOW HOW IT GOES

Apr 25, 2014 | 2005 Volkswagen Jetta

1 Answer

The ABS light stays on, then the instuments go dead, then the Check Engine light comes on. When I check it with my Checker it says P1698 Error.


re[place instument cluster its an intermitand problem the abs light is probaly because the cluster isnt talking on the buss then it crashes and no one is talking so all the lights come on

Mar 08, 2014 | 1998 Dodge Grand Caravan

1 Answer

Engine oil light on at idel goes off when driving comes on at stops


Check oil level on dipstick. Check for loose connection on oil pressure sender unit. Have the oil pressure checked using a master gauge.

Mar 28, 2013 | 2004 Dodge Stratus

1 Answer

Does the ECM control the MPH gauge?


well yes but no,the speedometer signal comes from speed sensor in the transmission then goes through the ecm/pcm via the tcm (transmission control module, then on to your speedo,if the speed sensor goes bad usually the speedometer will work crazy if not at all also the instument clusters also go bad causing failure too find a new tech dude

Feb 28, 2012 | 1998 Dodge Caravan

1 Answer

Oil lite comes on at idel goes off when rpm increas


More than likely you need to add more oil, just when the car increase rpm the oil is mixed up and the oil light goes off. Let your car Warm up for about 5 mins and check the oil level. Add if needed.

Dec 13, 2010 | 2004 Chrysler Pacifica

1 Answer

2003 Silverado 1500 Instument gauges inoperative. Dash lights up, but cant't tell how much speed or rpm range and fuel level.


Sounds like your gauge drive motors are wearing out.  It requires motor replacement inside the instrument cluster.

I fix these instrument clusters and have a 12 year guarantee, check my site at www.DrSpeedometer.com

Or check the video about it:

utube.png You-Tube video "eBlE23m0Iio" placeholder [unremark-end]-->(do not delete) utube.png

Aug 17, 2010 | 2003 Chevrolet Silverado 1500

1 Answer

Audi a4 1995 1,6l no rpm in instrument and warning


If you've just had the instument changed then its probable that the connector has come loose and will have to be re-connected. It could also be that the instument has failed. Take it back to the mechanic who changed the old one. This assumes that the car drives ok and all the fluids are topped up and ok.

Nov 04, 2009 | Audi A4 Cars & Trucks

1 Answer

Instrument cluster is going crazy on my 2003 Isuzu Ascender, tach stays at 7000 RPM, fuel gauge all over the place, ammeter says 19 volts, check engine light on & off, among other things.


It may have a faulty cluster. Or possibly could have a charging system problem.
Take it to a dealer and have it scanned for codes.
The instument cluster is a module that can store trouble codes. If the cluster is at fault the new one will have to be programmed to the vehicle to work correctly.

Oct 09, 2009 | 2003 Isuzu Ascender

1 Answer

Instument Guages


well the issue is youe enitre gauge cluster i do understand that your speedometer is working but it is a cable speedometer not electronic like everything else in the gauge cluster so first i would recomend checking the voltage getting to your gauge cluster then just replace the guagecluster they are really cheap i a salvage and not hard to install at all but the cluster itself is not very comon to go out so make sure you check voltage to it first i wouldnt want you to go through buying and replaceing the cluster and that not fix it

Jan 20, 2009 | 1991 Mitsubishi Eclipse

1 Answer

Dashboard lights


check the wiring cable and the internal signal cable

Jan 10, 2009 | 1996 Nissan Sentra

Not finding what you are looking for?
2000 Pontiac Sunfire Logo

256 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

61292 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...