Question about 1996 Plymouth Voyager

1 Answer

1996 Plymoth Voyager runs rough only when cold

Have a 1996 plymouth voyager that rus rough only when cold .have replaced temp sensor but no results still runs rough

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,114 Answers

Service eng light on? scan retrieve codes if no code your gue$$ing

Posted on Dec 24, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Location of crankshaft sencor on 1996 plymoth voyager 3.3 motor


Look under the hood on drivers side, down near lower part of engine where it meets transmission/transaxle and it should be mounted on top of transaxle/transmission.

Jun 22, 2011 | 1996 Plymouth Voyager

1 Answer

Were is located the ecm plymouth voyager


The ECM is mounted on the fenderwell behind the battery. There is a lable on it with all the numbers you will need

Mar 05, 2010 | 1998 Plymouth Voyager

1 Answer

1998 PLYMOTH VOYAGER WANT START


If your voyager is equipped with one---- change the ballast resistor, it's an oblong white ceramic block usually on the firewall, or on the inner fender well, it has 2 wire connections, one on each side.

Aug 28, 2009 | 1998 Plymouth Voyager

Not finding what you are looking for?
1996 Plymouth Voyager Logo

Related Topics:

244 people viewed this question

Ask a Question

Usually answered in minutes!

Top Plymouth Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Plymouth Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...