Question about 1998 Mercedes-Benz E-Class

1 Answer

1999 e320 mercedes wiper problems

Its erratic. sometimes it won't stop until 20 wipes later even if its off. sometimes it stops on the passenger side then i have to turn back on to stop on drivers side of windshield. when you press the button to wipe once sometimes it goes on and on and on and on until it stops. how do you fix that? thank you very much.
steven

Posted by on

  • 2 more comments 
  • Anonymous Jan 12, 2009

    my wipers stop working i can hear its working inside but the blades doesnt turn what can it be?

  • Conor Sep 05, 2012

    I have replaced both relays and still the same but thanks for that.

  • TIM Marshall
    TIM Marshall Feb 03, 2014

    why wont my wind slade wiper wont goes slow not fast

  • Anonymous Mar 31, 2014

    I have a 2001 Mercedes E320 Station Wagon. The turn signals and windshield wipers stopped responding. It wasn't all at once, first there was a delay, and they would infrequently respond. Now they are dead

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 409 Answers

Sounds like the wiper control relay is going bad. I think it is mounted in the fuse box under the hood or just behind it.

Posted on Dec 30, 2008

  • John Weathers
    John Weathers Dec 30, 2008

    Here's the location guide for the system.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Passengers side wiper not working. Drivers side working but intervals erratic


You didn't state what kind of nehicle you have, so the best I can suggest, is below the windshield outside the vehicle, there should be a small grill type cover, that goes from the drivers side to the passenger side, you'll have to look for the mounting screws, then lift off the whole cover, & you'll see the motor & what is called the transmission for the wipers, there will be metal arms which is the linkage, turn the wipers on & check the linkage to see if it's moving,
one end could be disconnected or broken going to one of your wipers, hope this helps.

Jun 22, 2016 | Mercedes-Benz E-Class Cars & Trucks

1 Answer

How do I find and fix a broken ground wire that I cannot locate.


try to put one to the motor and to the body that should cover all bases

Nov 18, 2015 | 1999 Dodge Grand Caravan

2 Answers

Erratic windscreen wiper action


sounds like the wiper control itself is playing up

Feb 27, 2014 | 2001 Nissan Micra

2 Answers

Wipers only work sometimes


check that you do not have the wiper control set on delay . It is the first stop on the arm and on some cars it is adjustable by turning the knob on the lever to give different delays according to the rain conditions. The next stop down will be continuous wipes at low speed and the last stop will be flat out speed of the wipers.

Dec 23, 2013 | Cars & Trucks

1 Answer

1999 Dodge Intrepid with flickering Dash Lights and Wipers Delay Problems


the dash lights is a lose ground or power connection the wipers could be a couple things there is a wiper relay that may be going bad or the wiper motor is going bad could even be both

Jun 03, 2013 | 1999 Dodge Intrepid

1 Answer

My blower motore is not woking on a e320 2001


Once a blow motor regulator on the e320 goes bad over time, it will cause your blower motor to act erratically or just stop working.
It is located in the passenger footwell above the knee area. I can walk you through the diagnosis and replacement procedure. If you don't want to mess with it, I know that most shops will try to charge you around $200-250 for it and try to get 1 hr for replacement.
If you have a mechanic friend, you can buy the part from www.autohausaz.com or www.rockauto.com for around $100 shipped and negotiate a replacement cost.
I will be happy to help you further if you decide to replace it yourself.

Mar 27, 2011 | Mercedes-Benz E320 Cars & Trucks

1 Answer

I have a vauxall vectra and the passenger windsceen wiper has stopped working as when i switched them on the passenger side was iced up have removed the ice and only the driver side works


If the wipers have independent electric motors then the passenger side one has a problem.
Check to see if it's fused separately,try running direct power to the motor.
If no go, motor has to be replaced.

Dec 01, 2010 | Mercedes-Benz CLK Cars & Trucks

1 Answer

Drivers side air conditioning is warm, passenger side is cold on my 1999 E320 what do I do?


sounds like itslo on freon or has a temp door actuator stuck prob. just lo on freon

Aug 05, 2009 | 2005 Mercedes-Benz Mercedes Benz E320 Cdi

1 Answer

FUEL PUMP


hello,maybe fuel pump,, or your k-40 relay module(fuel pump relay)better to install a fuel gauge to determine, fuel pump or your fuel pump relay,ty

Apr 21, 2009 | 1999 Mercedes-Benz E-Class

1 Answer

99 Forester driver's side wiper arm no longer moves w/passengers


the linkage has popped off the back you need to get to it to push it back on ots possibly worn and needs replacing

Dec 21, 2008 | 1999 Subaru Forester

Not finding what you are looking for?
1998 Mercedes-Benz E-Class Logo

2,114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

60792 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

164 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...