Question about 2003 Volkswagen Jetta TDI

1 Answer

2003TDI.Ran perfectly when parked. Spins,but won't start..

Checked MAF sensor,shudder valve, fuses and just to eliminate the possibility I replaced the fuel filter and o-rings. The old filter had a little water but nothing of note. Mechanic shows up and has me crank the starter while he loosens the outgoing lines of the injector pump and says there is no fuel to the injectors! Is this a possibility that an injector pump quits after the car was parked and hadn't given any sign of problem before? I don't know if this Mercedes mechanic is up to speed on VW's.

Posted by on

  • wrsdallas Dec 02, 2008

    the 03 tdi doesn't have the delivery pump that earlier models have. thanx anyway...replaced that injector pump for just under $2k and all is well (except the wallet)

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 67 Answers

Ther is a delivery pump in the tank that feeds the injection pump.
typ TDI club in your seach ther is great info on this

Posted on Nov 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Won t start


run the fault codes and look for faulty cam/ crank position sensor as this is indicated by the backfire/hard start and lower idle RPM. Check that battery terminals are clean and tight..

Sep 22, 2013 | Pontiac Montana Cars & Trucks

1 Answer

Starts but won't keep running then won't start


Check your Fuel Pressure and if that is good (over 40 psi)

then check your Idle Air Control (IAC) Valve

and seeing that it is a Mid-90's Chevy.. MAF Sensor is going bad.

If you UNPLUG your MAF and see what happens.... MAF is in the Air Intake with a 4 wire...

Apr 15, 2013 | 1994 Chevrolet Lumina

1 Answer

2003 Lincoln Navigator, started bogging down on me and jerking when I tried to pass a vehicle that was doing 55 in a 65mph zone, I let up off the gas a little n it ran fine, but driving back home goin


Check it for codes

You most likely have a couple bad COP Ignition Coils,
possibly a bad EGR Valve or TPS Sensor

All those are common ford & lincoln items

Change the oxygen sensors just before the exhaust converters
if you have 100,000 miles on it

Replace the Gas & Air Filter & clean MAF Sensor with CRC MAF
Cleaner

Install New Spark Plugs

All I suggested should have beeb done when you got it

All your vehicles as well---It is called Preventative Maintenance

Nov 23, 2012 | 2003 Lincoln Navigator

1 Answer

Crank but no start after replacing MAF on 2001 corolla po171


Disconnect the maf and see if it starts, if not the MAF is not the problem.

Jul 25, 2012 | 2001 Toyota Corolla

1 Answer

2002 impala 3.8L 180,000kms. Having problems with car hesitating on acceleration(not all the time). Had maf sensor & idle air control sensor replaced recently. Fuel filter, air filter,new plugs &...


it is possibly the throttle position sensor(tps) malfunctioning. basically the computer or "brain" of the car thinks the throttle is in a different position than it really is and automatically makes adjustments to fuel, air ect.... based on these false readings from the sensor thus causing the engine to react a little different when you expect to have power.

May 14, 2011 | 2002 Chevrolet Impala

2 Answers

I have a 2001 VW golf auto with a 1.8L turbo engine. it starts and runs fine for about 5 to 10 seconds and then starts running badly and dies. when running badly, it does not respond to an increase in the...


Sometime unplugging sensors is a good way to find a bad one. If the incorrect reading is being supplied to the ecm, sometimes it can't tell.
When a sensor is disconnected, the ecm knows and uses a default value.
Obviously this doesn't work with the crank sensor.

One thing to check is the connector at the coolant resevoir. Sometimes coolant will migrate through the wires and cause all kinds of trouble.

Jan 30, 2011 | 2001 Volkswagen Golf

2 Answers

2005 Chevrolet Cavalier, No power


check air intake hose first, including MAF sensor (if dirty must clean) , then check for all other hoses for leaks and last but not least check air filter.

Feb 19, 2009 | 2005 Chevrolet Cavalier

Not finding what you are looking for?
2003 Volkswagen Jetta TDI Logo

232 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volkswagen Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

61037 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Volkswagen Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...