Question about 2001 Mercedes-Benz C-Class

1 Answer

Automatik trans speed works some times, the engine is ok

My car seems to be having no pressure suddently, D seems out it doesn't go, engine is ok in P drive, I turn it off and for next start car run again, repeatedly issues. next day it comes on 1 durring my driving

they say maybe oil to be change or electronic trans speed kit

what can I do

Posted by on

  • afiankan Nov 21, 2008

    as soon as they have to change the filter, oil, the kit of transmission, it is become normal. tkanks for answer

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

That can be something wrong with the oil , how long time since you change oil and filter on the transmisjon. A other fault could bee the clutch ore brake band inside the transmisjon. If you smell at the oil , when you tacke up the oil stick , the color on the oil shall bee red , if the color been brown and the smell are smell of burning , the are something wrong with the clutch.

Posted on Nov 20, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2001 Elantra GT. with the auto trans in drive the trans slips when I'm doing 50-65 mph and the trans is in 4th gear if i have my foot to heavy on the gas. it doesn't do it as bad if I have...


First of all, Hyundai Transmissions use a 'specific' fluid called 'SPIII' and ONLY SPIII. Any other fluid doesn't meet Hyundai's specification and can cause 4th gear slippage (which is the TTC - Torque Converter Clutch - frequently referred to as the "lock-up" converter). You should have had a Check Engine Light. The problem you describe regarding 'doesn't drop back to first when I'm at a stop' sounds like the transmission has gone into 'Fail-Safe' mode because of the 4th gear ration incorrect. In "Fail-Safe" mode, the trans stays in 3rd gear until you cycle the ignition key off, and then back on. You need to scan your engine's computer to see what/which trouble codes have been set/stored in it. You'll need an OBDII scanner to read any codes that might be there. When a 'check engine light' (MIL=Malfunction Indicator Lamp) is turned on, there is a DTC (Diagnostic Trouble Code) set/stored in the ECM/PCM (Engine Control Module/Powertrain Control Module). This code identifies which engine management system component/function experienced a malfunction. Once you pull/read this/these code(s), you can begin diagnosis.

Sep 07, 2011 | 2001 Hyundai Elantra

1 Answer

I have 2 questions. First of all I just got a 2005 Chevy Impala and the speedometer works when it wants to. I noticed that when I turn the key in the ignition the speedometer goes down and eventually will...


As for the first problem it could be a speed sensor in the transmission. Do you have a check engine light on? You need to drive it with a scanner on it to check the speed sensor. If the sensor is reading fine but the speedo doesn't read right you likely need to replace the cluster. As for the second problem, this is a common one on the 4t65E trans. You need to replace the Transmission Pressure Control Solenoid.

May 22, 2011 | 2004 Chevrolet Impala

1 Answer

Hi There, I have a 1987 Prelude 2.0 Ex Automatik (80kw -103ps) . Over the Last weeks when I start the Car in the Morning and Drive Off the Car seems to Stand Still although its moving. Its Stays in First...


have you done a trans service sometimes the filter gets clogged [its just a little screen in the trans housing] any leaks? perhaps torque converter is faulty you should have pressures checked but if engine is strong its likely trans problems do trans service first check fluid if it smells burnt replace it

Nov 18, 2009 | 1989 Honda Prelude

1 Answer

Hard shifting after highway driving 1998 tahoe. After driving on the highway (mostly in hot weather) after coming to complete stop the car shifts hard at about 10 mph. Ramdonly does this from time to time....


sounds like your pressure control solenoid inside your trans is sticking you will have to have your pan pulled and have the solenods checked or replaced since it only fails at times it might check out ok when the pan is pulled.

Nov 15, 2009 | Chevrolet Tahoe Cars & Trucks

1 Answer

1999 dodge ram 5.9 4x4 bogs in park when throttle is depressed


yes the speed control sensor can make the trans try to run in two gears at once on this type of vehicle plus other probs.

Nov 04, 2009 | 1999 Dodge Ram

1 Answer

I have a 2002 Maxima 6 Speed Manual Trans. Under Heavy Acceleration the check engine light blinks several times and then goes off and stays off during normal driving. The light seems to come on as I hit...


U have an ignition related problem, have the system tested for the trouble code that is stored in memory any time the check engine light comes on to determine what is causing this issue. check engine lights have nothing to do with oil level or pressure, they indicate electronic control problems with the engine, trans or emission system.

Jul 07, 2009 | 2002 Nissan Maxima

2 Answers

Transmission converter seems to lock and unlock


Hello;
You may have two problems at the same time. The speed sensor is the easiest to replace. I would check and or replace the sensor. Then if the test drive shows the lock up fluctuating, I would replace the lock up switch in the transmission. Let me know if you have questions. Hope this helps. Rate me highly, please.
Thanks;
Rich
RPM Northwest

Mar 21, 2009 | Chevrolet Suburban 1500 Cars & Trucks

1 Answer

1999 ford tauras transmission and speedometer


Replace the speed sensor on the trans that will cause exactly what you describe is happening.

Sep 18, 2008 | 1999 Ford Taurus

1 Answer

Reverse engages HARD!!!


Check for trans codes then I would suggest a fluid change if there are no trouble codes, many times these kinds of problems are caused by a little piece of dirt causing a shift solenoid to stick.

Jul 15, 2008 | 1995 Dodge Caravan

Not finding what you are looking for?
2001 Mercedes-Benz C-Class Logo

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...