Question about Hyundai Accent

1 Answer

Engine light was on. code was cam shaft position sensor. replaced it and plugsand wires and it runs great. Does seem to not start at times when engine is hot.has to cool off about an hour and a half. then fires right up and runs fine. what could be heat sensitive that once the key switch de energizes it the component wont send spark to the plugs

Posted by on

  • paul erickson
    paul erickson May 11, 2010

    hope you got a good answer to your question

    look into your ign moduel.

    later paul



1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 962 Answers

It could be an engine heat sensor or water temp sensor.

Posted on Nov 18, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

2007 Saturn Aura XR 3.6 code p00116. new timing chains and all parts...128,000 miles any ideas besides the crankshaft reluctor.. Car runs great idols smooth

you got a bit carried away with the code
code p 0016 refers to crank shaft position/cam shaft position sensor, bank 1 sensor A---correlation === causes --wiring---CKP sensor --CMP sensor ---mechanical fault
code p 0011 refers to cam shaft (CMP) intake /left /front bank 1 --timing over advanced / system performance==== causes ---valve timing---engine mechanical fault --- CMP actuator ---wiring
you didn't mention the fault so consider this
if the timing is out on the intake cam shaft , it will idle good but play up as the timing actuator moves it further advanced with rpm
if the actuator is not wire properly or the solenoid is faulty , then the inlet will lag with increased rpm and again cause you problems
It is doubtful if the position sensors for either the crank or cam shafts are a problem because it starts and idles good

Nov 12, 2017 | Saturn Cars & Trucks

1 Answer

1996 Honda accord no crank intermittently

cranking is turning the engine over
from you misinterpretation of the term the problem is that it is cranking but not running
if that is correct then yes the cam shaft position sensor may very well be the cause of the not running at times as it controls the ignition and injector operation , the same as the crank shaft position sensor
could be a loose connection that has now come apart or the sensor has finally reached a point of failure that it needs to be replaced

Dec 20, 2017 | 1996 Honda Accord

2 Answers


PCM= Powertrain Control Module. It is the brains of the car, it reads the sensor in put from all sensors including the cam shaft position sensor

May 14, 2014 | 2004 Toyota 4Runner

1 Answer

I have a 2003 kia sedona van 3.5 liter that jumped time. I reset the timing put a new belt on it and it ran good for 35-45 min. Then it cut off, and wouldn't start back up. It has an OBD2 code for cam...

cam sensor fail can be crank sensor fail engine will run with cam sensor fail but crank it will not fire. also recheck the timing belt settings you fit the timing belt and run engine till warm then recheck the belt adjustment to make sure its in line and at recommended tightness.

Aug 07, 2017 | Cars & Trucks

1 Answer

2008 Kia Rio-After I replaced the timing belt my check engine light came on. I was told that the cam shaft position sensor was bad and needed to be replaced. I replaced it and the check engine light came...

were the codes cleared after replacment if not try that
if they were test the wires for cam signal and check for damaged ---cuts---fraied---pinched

May 28, 2011 | 2008 Kia Rio

1 Answer

2006 GMC Sierra with 5.3lt 8 cyl engine 4x4. Key on, all lights warning lamps light up.Turn key to start and all warning lamps turn off.Engine not starting,Checked battery,ok.Starter was replaced two...

code p 0654 refers to engine rpm output--circuit malfunction ===causes wiring ---ECM
code p 0650 refers to malfunction indicator lamp(MIL)--circuit malfunction====causes wiring --MIL---ECm
also refers to crankshaft position/cam shaft position sensor bank 1 sensor A --correlation===causes wiring---CKP sensor ---CMP sensor--mechanical fault

Jan 27, 2018 | 2003 GMC Sierra 1500

2 Answers

Car is putting at an idle when gas is pressed runs smoothly

sounds like either you have 2 of the wires is loose....probably #1 or your #1 plug needs regapped or is not tight and losing seal....all will cause a misfire and set the check engine light

Jul 13, 2010 | 2001 Saturn SC

2 Answers

A 2004 Dodge stratus with the 4 cylinder that will not start

code p 16 refers to crankshaft position/cam shaft position bank 1 sensor A--correlation====causes ---wiring---CKP sensor ( crankshaft position sensor )---mechanical fault

code p 0340 refers to -camshaft (CMP) sensor A bank 1 circuit malfunction ===causes wiring--CMP sensor--ECM
cosrs nothing to check the timing belt , just remove the oil filler cap and see if the rockers are moving when turning it over
the clue here may be bewteen the 2 codes , the word correlation and circuit malfunction so check the wiring, harness connections for pin corrosion and then substitute the ECM with a know good unit as the correlarion and circuit malfunction could be in the ECM
if the ECM program is not getting good reports for both sensors then it reasons that the piston and cam shaft are not timed properly and so will not allow it to start

May 15, 2017 | 2004 Dodge Stratus

2 Answers

2005 Dodge Stratus ? Camshaft Position Sensor causing problems (I

I had the same problem with my '05 Stratus SXT 2.4 DOHC. I've replaced the cam pos sensor and it seems to be running fine right now. On the Dodge forums a lot of the guys say that you need to replace the crank pos sensor too. I've bought one of those just in case it comes back again. Hope this helps.

Apr 24, 2009 | 2005 Dodge Stratus

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts


Level 3 Expert

77932 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8830 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides