Question about Mitsubishi Galant

1 Answer

Hey, I own a 1991 Evo 0 rs when i go to start the car it sounds good but when the car warms up the idil drops right down but not enough for it to konk out.it wants to but it won't if you get my drift.i have a boost guage and the vacum use to read 20,but now its reading 18,19 when it idils.i have a fair idea that its a air leak unless other wise. MUCH HELP APPRECIATED THANK YOU

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 393 Answers

Take a small propane torch and w/out lighting it open valve and sweep along intake manifold where the gasket/head meet if/when idle smooths out you'll have found vac leak. be careful of open flame/sparks

Posted on Nov 18, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi i have a 1991 rs camaro 3.1 my question is when i crank the car up and its cold i have 80 pounds of oil pressure but as it warms up it drops when at operating temp it drops to zero but doesn't knock and...


I doubt it's the pump. The only reason I have ever replaced pumps are on engine rebuilds or someone wanted a high pressure pump. Since you have good pressure, then no pressure until the RPM's are up. I would say the crank bearings are a bit worn. Going to zero pressure means something is not getting enough oil. Just a note... If there is a lot of sludge, some port could be clogged. But this also leads to a total engine rebuild, not just the crank and bearings.

Jan 15, 2015 | 1991 Chevrolet Camaro

2 Answers

As you've probably heard before my 91 cav starts fine gets warm stalls at lights starts right back up but cuts off when i put it in gear


pull off the transmission transition switch wire pluged on to tranny
start car drive should be fine never hook op again 0 money
or pay 700 dollars to install a new one
or buy switch pull tranny and install your self

Jul 14, 2010 | 1991 Chevrolet Cavalier

1 Answer

High idile


turn the idle down. you need a flat head screw driver and find the idle switch and turn it down.

Dec 30, 2009 | 1989 Jeep Cherokee

1 Answer

1991 chevy S10 blazer fluctuating oil pressure


I assume from the year it has high mileage. With mileage comes wear in these engine's bearings allowing oil pressure to drop because of the excess clearance between cam and bearings, also the crank and bearings. When the engine is hot and idling the oil is thinner and goes by the bearings quicker. If you have good oil pressure while driving, I'd leave it alone, maybe use a thicker oil or some lucas additive. My 89 does the same thing sometimes in the summer, but don't remember it doing it this summer. I use Mobil-1 and an AC Delco filter.

Oct 17, 2009 | 1991 Chevrolet S-10 Blazer

1 Answer

1991 Toyota extra cab v6 manual tranny. starts


sounds like you have to adjust your idle, fuel injected or carburated?

Aug 10, 2009 | 1991 Toyota Pickup

2 Answers

Fuel Pump


Hey
Check fuel pump relay and take off fuel pump relay. And check connection. Test fuel pump i remeber green wire or green. Putting other side your battery plus connection And hearing nose (sound). Thats simple test your fuel pump test

Apr 18, 2009 | 1991 Pontiac Trans Sport

1 Answer

1986 subaru gl wagon non turbo stays idiling at 2500


Hate to tell you this but sounds like the problem is a vacuum leak. This will make the engine rev. Check all the vacuum lines before making any adjustment. Have to dig out some of my old books to find factory settings for that carb. Good luck and I will try to find in case you need them to restore carb settings.

Apr 13, 2009 | 1986 Subaru Gl 2 Door

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6879 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...