Question about 2003 Oldsmobile Alero

1 Answer

2003 Alero Dies after faulty turn signals on for a week

Hi I have a question. My 2003 Alero has been working funny for about two weeks. My trip to bc. I replaced the alternator because my car died. Now about two weeks later my turn signals are working intermittently. Sometimes they would work and then I would pull over and restart my car then they would work for a bit. Sometimes they would go when I was turning. Then I drove during the day and the next night my car would not start. It had some electric because my radio would turn on but no starting the car. My battery is fairly new. Any thoughts to why this is happening. My car is an automatic and is 5 years old with 130,000 km on it. Any answers. Please.

Posted by on

  • missywallack Nov 21, 2008

    Yes I charged it now my car is running again. However, I my command start is not working now. I am not sure what to do. I think if this battery drains i will take it in.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 203 Answers

Is the battery charging? the indicator control could need replacing .joe

Posted on Nov 21, 2008

  • joe duff Nov 21, 2008

    if you still have problems chat with 1 of the other guys

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2003 4cylinder Alero is not charging my brand new battery. How can I isolate the problem?


LOL but that does not mean the alternator is good disconnect the battery while running if it dies it is the alternator .

Sep 09, 2015 | 2003 Oldsmobile Alero

1 Answer

03 ford focus replaced alternator checked charging system still not charging have power to alternator from battery light comes on after 10 seconds while running new battery, it only shows battery voltage...


Im no expert but my kids older car had several alternators replaced. 2nd one was bad.. We got one new and one rebuilt. I think the rebuilt worked a week and car died again.

Sep 07, 2013 | 2003 Ford Focus

1 Answer

I have a 2003 Oldsmobile Alero, the alternator and battery has been replace however the battery will not hold a charge.


Yes.
If the alternator has output on the car and the battery is not being charged look for a faulty fuse or fuseable link between the two.
You would check the output of the alternator first.

Sep 06, 2012 | 2003 Oldsmobile Alero

1 Answer

Where is the alternator located on a 2003


it is in engine compatment it os fix at eng and pulley is driven by belt.

Jan 25, 2010 | 2003 Oldsmobile Alero

3 Answers

2003 BMW 325xi won't start, dashboard and radio go on.


My 2003 325xi died on the highway a few weeks ago, and I thought it was the battery. It turned out to be the alternator, which was an expensive problem to repair. If your battery is new, it could be the alternator, or a problem with the electrical system. I find the BMWs to be too complicated electrically, which often leads to problems! I'd check your alternator...

Aug 08, 2009 | 2003 BMW 325

2 Answers

03 Oldsmobile alero vibration will running


it would be a good i dear to have it scand.that would help you pin point the prolbem. look at your cv joint you may have one going bad. good luck

Jun 04, 2009 | 2003 Oldsmobile Alero

4 Answers

The car turns on and then shuts off


if the car runs for a second and then dies its not the punp but try it again and see if the theft light either stays on or blinks if so its the factory passlock11 security system you may need to get a new coded key or ignition module

May 21, 2009 | 2000 Oldsmobile Alero

1 Answer

Warning lights


Feel safe about your trip as this a only warning lights that some issues are at hand concerning your car, it does not mean you can not travel 1000miles.

Just take your car for a scan and it will all be corrected.

Rate this

Apr 10, 2009 | 2002 Oldsmobile Alero

3 Answers

'03 Alero engine ust died while driving down the road. Help?


  • see if you can hear the fuel pump click over when you turn it to start position! this may be a fuel pump?

Mar 27, 2009 | 2003 Oldsmobile Alero

1 Answer

2003 OLDS ALERO DIES


It's probably the main engine computer. Same thing happened to my Cadillac. Dealer replaced computer module and problem stopped.

Dec 12, 2008 | 2003 Oldsmobile Alero

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

339 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

77202 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8743 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...