Question about 1993 Ford Explorer Limited

1 Answer

Radio says ''BAD'' in my 1993 explorer

The alternator went out in my 1993 ford explorer, after I got a new one put in, my radio just reads "BAD" and won't respond to any buttons. It won't turn on, but the fact that it reads "BAD" suggests that it is still getting power to it.

Posted by on

  • spudgo Nov 15, 2008

    My radio is factory, yes. No CD player or anything, just tape deck and am/fm.

  • Anonymous Feb 28, 2009

    I turned my '93 Explorer on after work today and had the same problem. Radio worked on the way to work this morning, not on the way home. Only thing I found relating to it was this.

    http://www.automotivemessageboard.com/ar...

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Factory radio?

Posted on Nov 15, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i reset my alarm on my 1999 ford explorer


If it starts and runs, it's not the security. Most common things I have found to drain the battery are. The alternator(even though it is putting out the voltage), the starter, the interior lights(wiring here) and the radio (Internal problems)

Jan 08, 2015 | 1999 Ford Explorer

1 Answer

1998 Ford Explorer Low Battery/Voltage Reading


Bad alternator you should have about 14.7 volts at idle with a new alternator.

Nov 02, 2012 | Ford Explorer Cars & Trucks

1 Answer

Hello. My 1993 Mercury Grand Marquis died on the highway after the battery "alternator?" light coming on about 20 minutes prior. We replaced the alternator with a rebuilt and the light is STILL...


A ford needs a fully charged battery to work the alternator. You may burn out the replacement alternator by hooking it up to a dead battery. Get the battery charged and have it load tested. You may have a bad battery and it should be checked. http://www.cardone.com/english/club/select/electrical/protech/tech_bulletins/PT37-0006.pdf

May 21, 2011 | Ford Crown Victoria Cars & Trucks

2 Answers

When starting it sounds like it is puttering and then stalls out. If I try to start it again, it wont start. Almost like it is flooded. I have a 1998 ford explorer with a little over 117,000 miles on...


I've got the same (1998 exploder). Someone went through the neighborhood trying to syphon gas. My truck started then sputtered out and now wont start. Gas is showing half tank plus I added 2 gallons Spark is good and gas pressure is reading 40psi(normal). Everyone else's including my 2005 Chrysler Pacifica started. I need help. Did you find something out that may help?

Mar 31, 2011 | 1998 Ford Explorer

1 Answer

Will not change gear until you have done about 2 miles. 1993 ford explorer 4ltr v6 left hand drive ( eddie bouer )


How many miles? Get the transmission serviced. Get the filter changed and get new fluid put in. Ford transmissions arent that great, but try getting the transmission serviced. I got a ford taurus that was said to have a bad trans. I changed the filter and put a new filter in. Voila, a 500 dollar car turned into a 3000 dollar car. : )

Oct 07, 2009 | 1993 Ford Explorer Limited

2 Answers

I have a 97 ford explorer all my lights in the interior came on my battery level went low and the car turned off as though i had no battery but i had just bought a new battery and recently changedle the...


12.6 is to low. It should be reading 13.8 to 14.5 when the alternator is functioning properly. Sounds to me like you got a bad connection or a bad alternator. hope this helps. good luck.

Aug 11, 2009 | 1997 Ford Explorer AWD

2 Answers

Need fuse diagram for 98 Ford Explorer Sport


If your radio does not diplay but works it is the kcd display seen many of these with this issue new radio will correct this concern no fuses for the display

Apr 27, 2009 | 1998 Ford Explorer

1 Answer

Charging system


change your battery cables and check all wires on the alternator for loose connections, expecially the grounds.

Oct 02, 2008 | 2000 Ford Explorer

Not finding what you are looking for?
1993 Ford Explorer Limited Logo

Related Topics:

197 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

64052 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...