Question about Mercedes-Benz 190-Class

2 Answers

Mercedes 190e 2.6 auto,starts fine when cold but idles rough and hesitates for ten minutes untill warm then fine, starts fine when warm but idles rough and hesitates for 1 minute

Posted by on

  • 1 more comment 
  • Anonymous Mar 16, 2014

    when it is fully warmed up its fine.

  • Anonymous Mar 20, 2014

    van hesitates for first 15 seconds after warm start then runs fine.example stop for gas restart get hesitation then fine

  • Anonymous Mar 26, 2014

    starts fine when it is cold but is sometimes hard to starts when warm and the idle has become rough



2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

190 e sun roof dose not want to close can not here moter

Posted on Aug 30, 2009

  • Level 1:

    An expert who has achieved level 1.


    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.


    An expert who has answered 20 questions.

  • Contributor
  • 23 Answers


Posted on Nov 15, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Engine running rich

Most likely throttle positioning sencer

May 08, 2016 | Cars & Trucks

1 Answer

97 3.9 dakota when it's cold outside and I start my truck it'll start right up but idle down til it quits . Start it again and it will idle.. Go down the road and it misses bad until it warms up. After it...

Here are the most common causes of idle surge, rough idle esp when cold and stalls at stops, slow idle speed, erratic idle speed, rough idle and engine hesitation (and other problems), it is in most cases the idle speed control air-bypass valve and or throttle valve and upper intake, these area's get full of gunk and combustion residue over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

Jul 09, 2017 | Cars & Trucks

1 Answer

My 2002 Chrysler voyager engine light just started flashing and goes on that way for about 2 minutes, then it stays solid for about 30 seconds then starts flashing again. The oil is good and this happens...

go have the vehicle scanned for trouble code usually flashing is a misfire but have scanned so your not guessing as to what the problem could be most auto stores offer service for free

Jul 16, 2017 | 2002 Chrysler Voyager

1 Answer

2000 beetle cold start rough idle until it warms

Could be the fast idle sensor check to see that the vacume line is hooked up properly.

Mar 12, 2010 | 2000 Volkswagen Beetle

2 Answers

86 Ranger 4X4 2.9 fuel inj runs rough when warmed up

1988 ranger 2.9 runs great cold then after a few minutes when warmed up hesitates with intermittent black smoke from the tail pipe until i hit the the throttle then clears and will repeat this behavior...

Jan 26, 2010 | 1986 Ford Ranger 2WD

2 Answers

MB 190E will start and stall within 2 seconds

cold start relay either the fuse in the relay, or the relay itself.

Jul 21, 2009 | 1987 Mercedes-Benz Mercedes Benz 190 Class

1 Answer

2006 Chevy Colorado, rough idle when cold

Mine did the same thing at 16K miles, I cleaned the throttle body and the ploblem went away. Took me about 30 minutes.

Feb 17, 2009 | 2006 Chevrolet Colorado

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

838 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers


Level 3 Expert

78010 Answers

Joseph Prosser

Level 3 Expert

772 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides