Question about 1991 Nissan Maxima

2 Answers

1991 maxima crank, putts for 6 seconds, touch accelerator it dies

1991 maxima cranks and after long crank it will semi start but just barely putt putt but it you touch the accelerator pedal it quits. I pulled the line off the fuel filter and it has good fuel delivery from the pump. When I first got the car (in this condition) it would crank and start and it would build up to an idle and I could move the car if I feathered the throttle. You could not give it full throttle or it would die.
Any ideas as to what this is?

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 261 Answers

I have a ver simple solution, check the big air duct which runs between the mass air flw sensor and the throttle body yes the big air duct which gives air to the engine if you pull on it you will notice it being cracked or even torn what it is doing is letting the air bypassing the air lfow meter and it is putting and dying, the best way to fix it is to replace the air duct they run around a 180$ frm the dealer

Posted on Nov 15, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Nissan Master
  • 60,769 Answers

1st thing to do is try cleaning the inside of the MAF sensor and having the ECT sensor tested, that controls cold enrichment, it does the same thing as a choke, sounds like you have a lean run issue. You might also consider getting the fuel injectors professionally cleaned, it can make a real difference.

Posted on Nov 15, 2008

  • jayII Jul 08, 2011

    i have a 1996 maxima. it is starting to putt and lack of power when i take off. Also when driving, its putting and lack of power. Do you think this is the MAF sensor?

  • yadayada
    yadayada Jul 08, 2011

    A quick way to test the MAF is to unplug it, this forces the computer into input loss failure mode strategy and the engine will run almost normal.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Changed plugs an wires and cap on 89 Toyota corolla and sprayed coberator clean in ccoberator and since cranks right up but putt putt like not getting gas.please help


Hi open your fuel cap and see if it has compression in the tank.you will hear if there is air coming out of the tank.if so try starting it without the fuel cap,if it starts drill a small hole 2mm in the fuel cap.

Jun 24, 2016 | Toyota Cars & Trucks

2 Answers

Engine turns over but won't start


Catalytic converter in the exhaust system might be plugged solid.

Dec 28, 2013 | 2010 Jeep Liberty

1 Answer

What is wrong if the car over heats quickly?


Ethier your car's overheating is a stuck thermostat or cause of overheating is a leak in your cars cooling system. -------------------------------------------------------------------
ECU Chip Tuning Tool

Dec 06, 2012 | 1991 Toyota Camry

1 Answer

The check engine light came on and instantly no acceleration just a major putt, putt, putt! What caused this?


First guess, catalitic converter. But you need to have the codes read first. This will point you in the right direction.

Jun 21, 2011 | 1999 Dodge Ram 2500 4WD

1 Answer

Crank up and stalls and give it gas and than run a little 1000rpm than half which is half or the 1000rpm then motor jumping like putt putt


I would give a tune ut with new fuel filter,spark plugsand wires with some carb or injection cleaner in a full tank of gas depending if it is carbourated or fuel injection....Hope this helps.

Aug 19, 2010 | 2000 Ford Windstar

1 Answer

Car has starting problems


The signs you mention 'putt putt' are normally casued by excessive fuel, something approaching a flooded engine. If you do this with the hood open, you will probably smell raw gasoline.
A cold engine needs an extra shot of fuel to fire off but once warm, it gags on it. I don't know your car so I can't tell you what controls the extra gas for cold starts; it seems to be doing it whether cold or not. I guess I would first check any electronic temperature sensor which could be located in the cooling system or intake or exhaust system. Your new computer is getting the same wrong information as the old one.     

Aug 19, 2008 | 1996 Mitsubishi Eclipse

1 Answer

My car is actin up!!!!


I have a similar problem. Start with the cheap stuff like spark plugs and wires. Then check your fuel filter. After that, check your MAP sensor, and or fuel pump. Also your TPS (throttle position sensor)
I know this problem is very common. I have searched everywhere, and there is no one specific solution. Good Luck!

Aug 18, 2008 | 1997 Mitsubishi Eclipse

Not finding what you are looking for?
1991 Nissan Maxima Logo

170 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...