Question about 1998 Ford Expedition

1 Answer

Wont stay running

I have a 1999 ford crown vic 4.6 it wont stay running at all just started this i replaced the tps unplugged and re plugged most of the sensore still nothing no check engine light on at all. any thoughts?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 60,973 Answers

You may have a defective idle speed control valve. Clean it first.

Here is the most common cause of surges and stalls, it is the idle speed control air-bypass valve and throttle valve, they get full of gunk over the miles and cause idle issues (stalls) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

Posted on Nov 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 1996 Crown Vic. recently started to buck and backfire a bit, turned out to be a misfire on #4, have been looking into it with a bit of progress but not complete success


I have faced the same thing with my car, this is not a single answer to this problem. It could be a bad boot on the coil pack, it could be a improper coil install, sometimes the spring does not sit in well, it could be that the intake manifold is leaking, it could be that the egr valve is stuck, it could the exhaust manifold is leaking, sometimes these issues are not caught by the OBD 2 sensors, you can try to move the coils around to see if that works out.

Mar 17, 2014 | 1995 Ford Crown Victoria

1 Answer

I have a 1995 Crown Vic' that has 102000km, it recently started to sputter and buck a little accelerating, I then replaced the plugs, coil packs, TPS sensor, checked vacuum lines, cleaned MAF sensor and...


run it at night with it dark under the hood and see if you have any sparking from the wires to ground or any other shorts. also replace the fuel filter and run a can of seafoam in your tank on your next gas fill.

Mar 17, 2014 | 1995 Ford Crown Victoria

1 Answer

96 Crown Vic will not start. Has spark, has fuel, crash button is set, has oil, Will run when fuel start is sprayed into carb. Any ideas ?


Check your fuel pressure to the Injectors at the pressure valve. Then check the wiring to the Injectors to see if they are getting power. Backtrack the Injector wiring if it is dead.

Your Crankshaft and Cam sensors would be working to supply the sparkplugs their power in the firing sequence. You need to check the part that supplies the Injectors their power in sequence.

Usually a bad TPS throttle position sensor will make a "Check Engine" light turn on. This part is on the drivers side of the Airhorn behind all the plastic Air filter ductwork. It has 2 screws and 1 electric connector. Unplug the connector and use an Ohmmeter to watch for resistance to change as you work the accelerator cable attached to the opposite side of the Airhorn. Connect the Ohmmeter to the TPS switch. The Resistance should change if the switch is good. If nothing happens, replace the TPS.

Jan 19, 2011 | 1996 Ford Crown Victoria

1 Answer

Hi Folks, My 99 crown vic has an intermittent stalling issue. I can be driving along and it just cuts out (usually, not always, when I take my foot off the gas). It will start right up at first and...


Was the fuel pump checked out?
Have a scope put on it,to check for a worn armature. May also be binding up mechanically
Also check TPS Sensor data or scope it

Nov 03, 2010 | 1999 Ford Crown Victoria

1 Answer

Changed coil pack wont start on  99 crown vic


Check the ignition module,and the crankshaft sensor.

Feb 06, 2010 | 1999 Ford Crown Victoria

2 Answers

P0304=misfire in cylinder 4. coil? spark plug? spark plug wiring. 1999 crown vic 4.6 V8. runs ok, just little cutting out every now and then.


not coil coil it wouldnt fire at all it is either a plug or a wire replace the wire and plugs and that will fix it

Oct 06, 2008 | 1996 Ford Crown Victoria

1 Answer

1999 Ford Crown Vic transmission problems


check u joints and drive shaft for weights hope this works

Aug 09, 2008 | 1999 Ford Crown Victoria

Not finding what you are looking for?
1998 Ford Expedition Logo

281 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...