Question about Chevrolet Silverado 1500

1 Answer

1994 k1500 4x4 5.7 speedo goes to 100 when started

Also truck idles fine give it gas engien braeks up like it has bad wiers

Posted by on

  • Anonymous Mar 29, 2014

    when i move wier on the presser switch by the canaster my ac clutch come on

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 275 Answers

The spedo may have a short and check for fouled plugs or bad plug wires

Posted on Nov 12, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Car doesn't seem to get enough gas to engine


Have you done a tune lately on the car?
I would also suspect a fuel pump problem is you've done a tune up recently.

Jul 11, 2008 | 1994 Hyundai Excel

1 Answer

My truck turns on, idles fine but when i give it gas it only goes about 3 mph. when i want to excellerate it goes nowhere


Not quite everything is fine.
Is the check engine light on ?
When you push on the gas pedal, does the engine speed change ?
Can you rev up the engine in park ?
What have you checked so far ?

Jan 15, 2013 | 1993 Nissan Pickup

1 Answer

I have a 1958 ford f-100 idles fine when i give it gas i can press pedal half way down but if i go to floor it sounds like a major air leak and the truck dies


You need to rebuild the carburetor is my opinion based on your symptoms. The carb rebuild kit comes with full instructions and you can get it here.

Oct 12, 2012 | Cars & Trucks

1 Answer

I have a toyota with a 3L engien. when i drive up to 90km/h the temperature goes fine but when i push more ex: up to 120km/h he start geting hot and if i ve been drivi´ng for 40 min the water pipes...


You have a bad Radiator. It is clogged and needs to be flushed and cleaned. At normal driving speeds it is flowing just enough water to keep the car cool, but under heavy demand, like driving fast, the flow rate is inadequate to keep the temp down.

Oct 24, 2010 | 1994 Toyota Corolla

1 Answer

1994 ford t-bird starts fine but surges and check engine light on


have you checked the vacum lines under the hood for cracks in the lines or a vacum leak, sounds to me its a vacum leak.

Jun 18, 2009 | 1994 Ford Thunderbird

1 Answer

Oil light stays on when I start engine but goes off after a while


When you give it gas or idle for awhile the pressure will build up to normal and turn off the light.

If you are consuming oil and coolant you should check your head gasket also.

May 19, 2009 | 1994 Nissan Sentra 4-Door

1 Answer

Bouncing RPMs


My car would do the same thing turned ot to be a loose wire at the coil/distributor. there is a plug connector with tow wires one wass loose I crimped the wire no works great

May 04, 2009 | 1985 Pontiac Fiero

1 Answer

My 2004 BMW 325 ci convertible is difficult to start.


If the fuel filter has been replaced, then maybe these are other reasons:

1. intake camshaft sensor (known to go bad on BMW E46s). ~$100 part.

2. fuel injectors (though I doubt they go bad that easily). ~$100/ piece. Your car has 6.

3. Ignition coils. ~$90 a piece. Your car has 6.

4. mass air flow sensor. Again, another expensive part. ~$300.

Apr 10, 2009 | 2001 BMW 325

1 Answer

1994 k1500 4x4 5.7 speedo goes to 100 when started


as soon as key is turned on gauges self test then return to zero on some vehicles.

Nov 13, 2008 | 1994 Chevrolet C1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

38 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70374 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6878 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...