Question about Mitsubishi Galant

3 Answers

My heat isn't working. I also can't feel the heat coming off the motor even when the heat is not on. What could it possibly be?

Posted by on

  • 2 more comments 
  • Anonymous Nov 19, 2008

    I changed the heater core and heat still does not work

  • Anonymous Dec 02, 2008

    I think I have the same problem. Air blows but it is not hot. If I keep the fan on 1 or 2, the air is hotter than on 3 and coldest on 4. I can feel the temperature changing from warm to cold if I turn the temp knob to cold, so some hot air is coming in, I also noticed the temperature gauge drops almost at the bottom if I turn the fans on, if I keep them of, the temp gauge goes back to normal in a few minutes.

    Any ideas?


  • org106 Dec 07, 2008

    i have the same probem. my heater wont work. i can feel a little warmth when i turn it on, but if i turn it to 3 or 4 then it gets a little colder.

  • Gary Queen
    Gary Queen May 11, 2010

    Fist you need to check the hoses leading to the heater core with the engine at normal running temp. If both are warm, all is good so far. I one is cold you have a clogged heater core. If both were warm its time to check the heater controls to make sore that the vents are opening. Let me know what you find out...

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 1 Answer

It could either be your theromast or your heater core....does the blower blow out air???cold or warm??

Posted on Nov 12, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My heater went out, my son-in-law just checked things out for me and found that i need a new cable for the knob on the left (cost $6.48) which i ordered from the dealer. was a simple fix, tg. hope this helps. had some kind of a kink in it, don't know what happened...

Posted on Dec 30, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have toyota symphony (sienna) 2002, I turned fan (heater) on back not on front, it is not working on top, we don't feel heat come out thru air flow window, but it was hot underneath driver, but I turned AC it worked on top. I don't know what happened?? Please let us know, my e-mail is usdavid1958@yahoo.com. Thank you very much.

Posted on Dec 04, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Little heat coming out of vents.


IF YOU CAN'T FEEL THE AIR FLOW OUT BUT YOU HEAR THE BLOWER MOTOR WORKING, BEHIND THE GLOVE BOX IS A CABIN FILTER.REPLACE FILTER
IF YOU HAVE GOOD AIR FLOW BUT NO HEAT:
1;VACUUM LEAKING TO HEATER CONTROL
2;WATER PUMP GOING BAD / NOT CIRCULATING COOLANT,HIGH RPM/MORE COOLANT TO THE HEATER CORE
3;OPEN THERMOSTAT/ENGINE TEMPERATURE TO LOW
1;CHANGE THE DIRECTION FROM VENTS TO FLOUR TO WINDSHIELD. IF NOTHING HAPPEN IS THE VACUUM
2;RUN THE ENGINE INSIDE ON WARM PLACE ON IDLE.NOTE THE GAUGE IF PAS 1/2 TO 3/4. IF PAS 3/4 MARK REPLACE WATER PUMP
3;IF GAUGE STAY BELOW 1/2 REPLACE THERMOSTAT
GOOD LUCK

Mar 27, 2014 | 2005 Dodge Neon

1 Answer

I have a 2002 Grand Am SE, my heat works fine, temperature wise, but doesn't flow out of my vents very well. Whenever I turn the heat on I hear a loud humming/vibrating sound coming from my blower...


I had a very similar problem on a Buick recently. Like mine, your blower's fan blade assembly may have come loose from the motor shaft. There is a very small washer type clip that holds the fan blade part to the motor's shaft. Usually the whole blower assembly is pretty easy to get to and take off...usually. A lot of GM cars had the assembly accessed from the firewall behind the engine. You would need to pull the blower motor out and check the fan assembly.

Jan 21, 2014 | Cars & Trucks

1 Answer

My car has no heat


The first thing to check is the level of coolant-is it full? Because no heat is the first indication of low coolant. When car is cool, open radiator cap and fill with a 50-50 mix of antifreeze and water. Also fill the overflow tank halfway up with the coolant mix.
Also feel both heater hoses after the car has come to normal operating temperature. Both should be hot. If they are, the heater is working as intended. If only one is hot, the coolant is not circulating through the heater, and someone will have to get that working-possibly an air block in the heater core, possibly a plugged heater core.
Finally, the blower motor may have wore out. Without the blower, very little heat will come out. Test or replace the blower motor.

Dec 11, 2013 | 2001 Pontiac Grand Am SE

1 Answer

HEAT NOT WORKIN IN 1989 CADILLAC?


either the blower motor is bad or you need to flush out the heater core.due to the age of the vehicle its probably clogged up with deposits and needs to be flushed out with air pressure or you can try hooking up your garden hose to it and flushi9ng it out that way

Jan 25, 2013 | 1989 Cadillac Sedan DeVille

1 Answer

I have a 2001 Alero, rear defrost isn't working at all, frost inside my car, won't defrost and heat isn't working! :( HELP any idea's... I thought it was the heater core but there isn't any leakage un


You definatly have water inside the car. Pull the carpet back in the front and rear checking for water leaks. The only way frost can develope inside a vehicle is the presents of moisture.
The other possibility is your HVAC drain is plugged and water has built up inside the heater motor area. Have the drain checked and cleaned.

Nov 21, 2011 | 2001 Oldsmobile Alero

2 Answers

2003 Buick Century is over heating in the morning only. Radiator, thermostat and sensor have all been replaced. Water pump and fans have been checked. When it idles it gets hot but when you rev the motor...


Sounds like the intake gasket or even possibly the head gasket have gone south if everything else has been replaced. Internal engine leaks will cause engine to overheat very easily.

May 19, 2010 | 2003 Buick Century

2 Answers

No heat in my ford explorer


You Feel the heat but it does not blow--
Check your Blower motor Ralay first if it is Clicking then check the Blower motor itself apply 12 volts to pos wire at blower motor if it does NOT come on Replace blower motor if it does work the Problem is at the Switch itself

Jan 13, 2009 | 2002 Ford Explorer

1 Answer

Motor fan blowing


do you keep the fresh air button on ? if you do , you will feel heat or cool air come in with out the blower motor running

Dec 01, 2008 | 2004 Chrysler Pacifica

1 Answer

Heater issue - only works when on highest setting


this is caused by the blower motor speed control resistor being defective, this part is located near the blower motor.

Oct 30, 2008 | 2000 Chevrolet Prizm

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

858 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...