Question about 1987 Subaru Gl 4WD

1 Answer

Starting prob subaru legacy 2.0gl only when hot/warm

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Possibly vapor lock? 

Posted on Nov 16, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When my 1990 subaru legacy is cold it runs good then after 10 miles it starts skipping engine light comes on and a strong ordor of gas can be smelled. it does not run hot but when it starts to cut bac


Could be a faulty O2 sensor. The sensor would not take action until the engine warmed up. Have you checked for trouble codes in the engine computer ?

Jul 28, 2014 | 1990 Subaru Legacy

1 Answer

92 legacy wont start when hot


if it hae a coil pack have it checked if i get hot it will do that

Nov 01, 2012 | 1992 Subaru Legacy

1 Answer

Replaced fuel pump on 96 legacy wagon. will not start now, it does start if hot wired directly to pump. Any suggestions? Have also replaced the fuel pump relay.


Hi yes had same problem it was the plug that sits under the rear seat that supplys power to the fuel pump it had got hot and was charred inside, just cut it out and soldered wires together and fixed prob hope it helps

Apr 01, 2011 | 1996 Subaru Legacy

2 Answers

The heater just quit working. It worked fine yesterday but this morning it does not. The car is running a little hotter trhan normal but not overheating. Any ideas?


I would check to make sure the radiator is full and the overflow tank is filled to the proper level. It doesn't have to be very low for these cars to stop blowing heat.

Feb 01, 2011 | 1992 Subaru Legacy

1 Answer

97 Subaru Legacy, 142,000 miles. Temp Guage


Sounds like the Coolant is not full and has a air bubble. It is very important to have the system filled complete. That would be the first step.Good luck and have a great day.

Feb 22, 2010 | 1997 Subaru Legacy

1 Answer

2002 subaru legacy heater not working


heater core could be plugged,try removing both heater hoses to core and back flush

Aug 15, 2009 | 2002 Subaru Legacy

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...